Why Does a Completed Process Instance Appear "In Progress" in SharePoint?
Symptoms
After a process instance has completed, the status still appears “In Progress” in the SharePoint Library. The AgileConnector log (at (AgilePoint Server installation folder) C:\Program Files\AgilePoint\AgilePoint Server\log\AgileConnector\info) shows the following error with a incorrect proxy name:
01/19/2012 12:09:49 <<< SPConnector: Error when processing event TerminateProcessInstance. Process TerminateProcessInstance . The proxy name could not be resolved: 'xxxx'
Cause
The system is configured to use an old (or default) proxy server.
Resolution
- In a text editor, open the web.config file for the .NET Framework at C:\Windows\Microsoft.NET\Framework\[version]\CONFIG
- Set the usesystemdefault attribute of the <proxy> node to false:
<system.net> <defaultProxy> <proxy usesystemdefault="false"/> </defaultProxy> </system.net>
More Information
- http://forums.asp.net/p/1751051/4738577.aspx/1?The+proxy+name+could+not+be+resolved
- https://support.microsoft.com/en-us/help/318140/prb-error-on-net-client-that-consumes-a-web-service-through-an-http-pr
- https://social.msdn.microsoft.com/Forums/en-US/a57ed0f8-55ac-4b24-8d6b-5838ebdbc004/error-msg-proxy-name-could-not-be-resolved?forum=tfswebaccess