Why Does My App Fail to Connect to SharePoint for Microsoft 365?
Symptoms
These types of connection problems occur when AgilePoint NX apps access SharePoint for Microsoft 365.
- SharePoint lookups fail
- SharePoint access tokens fail
- File uploads to SharePoint fail
Connection problems can occur as no connectivity or slow connectivity. The connection problems may be intermitent. The issues may resolve after a few minutes then occur again later.
Cause
Microsoft is retiring TLS 1.1 and lower protocols, and the changes are not propogated to all Office 365 servers. Microsoft's updates are ongoing, and as of the time of this article's publication (June 1, 2021), there is no deadline for completion from Microsoft. Updated ciphers are required on the AgilePoint Server machine.
Good to Know
- This issue is not related to AgilePoint NX software.
- The configuration changes in this article appear to resolve the connection issues in environments where they have been applied.
Resolution
- On the AgilePoint Server machine, enable these security ciphers on the operating system.
For more information, refer to https://docs.microsoft.com/en-us/sharepoint/troubleshoot/administration/authentication-errors-tls12-support.
TLS_DHE_RSA_WITH_AES_256_GCM_SHA384
TLS_DHE_RSA_WITH_AES_128_GCM_SHA256
- In the Windows registry, add these keys:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319] "SchUseStrongCrypto" = dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v4.0.30319] "SchUseStrongCrypto" = dword:00000001