Why Are Participants Not Receiving Emails Sent from an AgilePoint Process?
Symptoms
The e-mails sent from an AgilePoint NX process are not received.
Good to Know
- This issue can have more than one cause.
Incorrect SMTP Server Configuration
Cause
The SMTP Server configuration is incorrect. The notification log contains the following error message:
The remote name could not be resolved: '[xxx]'.
To find this notification, in Manage Center navigate to the Notifications section. Find the notification by the process template. If the Log column contains an error message, move the pointer over the message to display the detailed message.
Resolution
- On the AgilePoint Server machine, in Windows Explorer, right-click the file (AgilePoint Server installation folder) C:\Program Files\AgilePoint\AgilePoint Server\WCFConfigurationUtility.exe, and click Run as Administrator.
- On the AgilePoint Server Manager screen, in the left pane, select your AgilePoint Server instance.
- Click Open Server Configuration .
- On the System tab, in the Notification area, validate the SMTP Server declaration, and then test the configuration using the Test button.
- After modifying the SMTP Server value, recycle AgilePoint Server. Do one of
the following:
- For AgilePoint Server running in IIS mode, reset IIS.
- For AgilePoint Server running in Windows Service
mode:
- Stop IIS.
- Restart the Windows service for the AgilePoint Server instance.
- Start IIS.
SMTP Configuration Not Recognized
Cause
AgilePoint Server doesn't recognize the SMTP configuration, although the SMTP configuration in the AgilePoint Server Configuration is correct.
Resolution
- Find the most recent AgilePoint Server log from AgilePoint Server to display the
SMTP Server name that the service is running on.
For more information, refer to Where Are the AgilePoint NX OnPremises Logs?
- If the value is not correct, recycle AgilePoint Server. Do one of the following:
- For AgilePoint Server running in IIS mode, reset IIS.
- For AgilePoint Server running in Windows Service
mode:
- Stop IIS.
- Restart the Windows service for the AgilePoint Server instance.
- Start IIS.
The SMTP Server value is recorded in AgilePoint Server log. The following example displays a portion of AgilePoint Server log:
2013-01-09 16:50:55.294 >>> Configuration >>>
Home Directory = (AgilePoint Server installation folder)
C:\Program Files\AgilePoint\AgilePoint Server
Database Vendor = MSSQLDatabase
Domain Name = LDAP://DEMO3, , Check Backslash=True
System User = aps
Default Locale = en-US
Smtp Server = demo3
Sender E-mail Address = administrator@tusca.com
System User E-mail Address = administrator@tusca.com
E-mail Encoding = System.Text.UTF8Encoding
E-mail Format = Html
Send E-mail Separately = False
Work Hour = starts at 9 and ends at 17
Query on Archive Database=False
Initial CPU Usage=50%
Maximum Retry for failed e-mail notification=32
Maximum Process Instances in cache=Unlimited
Trusted authorization=True
Weekdays = Monday,Tuesday,Wednesday,Thursday,Friday
Process Swapping = 5(minutes)
Invalid E-mail Address
Cause
The e-mail address specified in the To or Cc field doesn't exist for the user associated. The notification section log displays the following error:
The Specified string is not the form required for an e-mail address.
Resolution
- Open the Manage Center, and then navigate to the Users page.
- If the user doesn't have an email address associated, click the Edit tab to provide a valid e-mail address.