Why Does an Error Occur During Bulk Migration Using APADM Utility?
Symptoms
While doing the bulk migration of process instances, the following error is displayed in the command line prompt and migration fails:
Connecting to AgilePoint Server…Failed!, The caller was not authenticated by the service.
Cause
This problem occurs because the default credentials of the client is not recognized by the AgilePoint Server WCF service. In this case, the client is the APADM command line utility, apadm.exe.
Resolution
As both the APADM client and the AgilePoint Server WCF service are running on the same machine, use localhost or the IP address of the machine (instead of the host name) for the AgilePoint Server's URL argument that is passed in the following console command:
apadm -mgproc [Process Migration Instruction XML File] [AgilePoint Server URL]