Why Are Notifications In Deferred Status?
Symptoms
Notification e-mails appear in the deferred status in the notification queue for several minutes before being sent.
Good to Know
- This issue can have more than one cause.
Many E-mail Deliverables in Queue
Cause
There are numerous mail deliverables in the queue, and especially there are a number of failed e-mails that are being resent repeatedly.
Resolution
- In a text editor, open the netflow.cfg file for AgilePoint Server.
- In the <notification> node, decrease the maxRetryFailedMail attribute. The default value
is 32.
<notification mode="true" format="text" mailServer="smtp.dslextreme.com" sender="admin@AP_Server1.com" sysadm="me@mycompany.com" maxRetryFailedMail="10" />
Deferred Time Setting
Cause
Under normal operations, notifications can appear in the deferred status if the Deferred Time property is set in the E-mail activity is configured for a value greater than zero.
Resolution
Make sure the notifications in question are not being delayed because the Deferred Time property within an E-mail activity.