Unable to Log On to Enterprise Manager

Symptoms

Receive an error when attempting to login to AgilePoint Enterprise Manager.

Times out, previous AgilePoint Server instance is shutting down.

Cause

The application pool being used by AgilePoint Server is configured as a Web garden.

Resolution

The application pool you select must not be configured as a Web garden (e.g. the number of worker processes assigned to the application pool should not be greater than 1). To ensure this is configured properly:

  1. In IIS Manager expand the local computer, and expand Application Pools.
  2. Right-click the Application Pool you want to configure (e.g. DefaultAppPool), and then click Properties.
  3. Click the Performance tab and make sure the Web garden field is set to 1.

Cause

The AgilePoint Service Account does not have write privilege to the server.lock file.

Resolution

  1. Right-click the file [AgilePoint Server installation folder]\Master\server.lock.
  2. Click Properties.
  3. Click the Security tab.
  4. Click Edit.
  5. Do one of the following:
    • To set permissions for a group or user that does not appear in the Group or user names:
      1. Click Add.
      2. Enter the name of the group or user for which you want to set permissions.
      3. Click OK.
    • To set the permissions from an existing group or user, click the name of the group or user from Group or user names.
  6. Under Write permission, select Allow.

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