Why Do I Get a Database Permissions Error when I Open AgileReports in Enterprise Manager?

Symptoms

When I try to open AgileReports from Enterprise Manager, this error occurs:

Sorry, your assigned roles don't have permission to use any of the databases.

Cause

AgilePoint Server was not restarted after the adHocAdmin group was added in Active Directory.

Resolution

Verify if the adHocAdmin group has been added, and AgilePoint Server has been restarted. On the machine where AgileReports is installed, do this procedure.

  1. Add the attached NTLoginTest.aspx page to [AgileReports installation folder].
  2. In a text editor, open the file [AgileReports installation folder]\_Definitions\_Settings.lgx.
  3. Add LogonFailPage="NTLoginTest.aspx" as in this example.

    Sample “ _Settings.lgx” file:

    <Security SecurityEnabled="True" 
        AuthenticationSource="AuthNT" AnonymousUserID="1" 
        LogonFailPage="NTLoginTest.aspx" 
        NTAuthenticationDomain="xxxx" CacheRights="Session" 
        LogonPage="http://localhost:9000/EnterpriseManager/Common/LogonForm.aspx" 
        SchedulerUsername="Admin">
  4. Restart the machine.

Downloads

NTLoginTest.zip

Cause

No AgileReports role is configured for the Active Directory group.

Resolution

Make a role in AgileReports with the same name as the Active Directory group with permissions to access AgileReports. The role name is case-sensitive.

For example, if your AgileReports group in Active Directory is named AgileReportUsers, make a role in AgileReports with the name AgileReportUsers.