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Preface

Disclaimer of Warranty
AgilePoint, Inc. makes no representations or warranties, either express or implied, by or with respect to anything
in this document, and shall not be liable for any implied warranties of merchantability or fitness for a particular
purpose or for any indirect, special or consequential damages.

Copyright
Copyright © 2013 AgilePoint, Inc. All rights reserved.

Trademarks
AgilePoint, Inc. and AgilePoint's products are trademarks of AgilePoint Inc. References to other companies and
their products use trademarks owned by the respective companies and are for reference purpose only.

Government Rights Legend
Use, duplication or disclosure by the U.S. Government is subject to restrictions set forth in the applicable license
agreement and as provided in DFARS 227.7202-1(a) and 227.7202-3(a) (1995), DFARS 252.227-7013(c)(1)(ii)
(Oct 1988), FAR 12.212(a) (1995), FAR 52.227-19, or FAR 52.227-14, as applicable.

Virus-free software policy
AgilePoint recognizes that viruses are a significant security consideration for our customers. To date, we have
had no report of AgilePoint BPMS carries any virus. AgilePoint takes the following measures to ensure our
software is free of viruses upon delivery:

• AgilePoint is built on top of Microsoft .NET framework. The pre-compiled executable is a.NET Common
Language Runtime (CLR) application, not a native machine binary. As far as is known at this time, there are
no viruses that infect .NET CLR executables.

• The virtual environment for the product packaging process in is fully isolated and protected, and anti-virus
software is installed and running during packaging.

• The deliverable package is scanned by anti-virus software before upload to our customer download site.

Document Revision Numbers
AgilePoint documentation uses the revision number format rX.Y.Z. The letters and numbers in this revision
number can be interpreted as follows:
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• r - Indicates "revision." This helps to differentiate the document version numbers, which start with v.

• X - The major version number for AgilePoint BPMS to which this document refers. For example, AgilePoint
releases 5.0, 5.0 SP1, and 5.5 would all have an X value of 5.

• Y - The major document revision number. This number typically changes only when either there is a new
AgilePoint release, or there are major changes to the document.

• Z - The minor document revision number. This number is incremented each time the document is
republished.

AgilePoint Documentation in PDF and HTML
AgilePoint documentation is provided in both print-friendly (PDF) and web-based (HTML) formats.

Advantages of HTML Documentation

• HTML is the primary delivery format for AgilePoint documentation.

• Unified, global search across all documentation. PDF documents allow you to search only within the context
of a given PDF file.

• All hyperlinks supported. Links in PDFs are only supported in certain contexts.

• "One-stop shopping" for all information related to AgilePoint BPMS.

• The HTML documentation is updated more frequently than the PDF documentation. Web-based
documentation is updated periodically between AgilePoint releases to address errors and omissions, but the
PDF documentation is updated only at the time of a software release.

Advantages of PDF Documentation

PDFs can be more easily printed, archived, and transferred (such as by FTP or email) than HTML
documentation.

For more information, refer to Downloading Files and Sharing Links from the Documentation Library in the
Documentation Library.

Opening the Documentation Library
To open the AgilePoint Documentation Library, do the following.

Prerequisites

You must have a valid account on the AgilePoint Support Portal.

Instructions

1. Log on to the AgilePoint Support Portal.

2. Click Documentation.

3. On the Documentation page, click the documentation library for your AgilePoint release.

• For AgilePoint BPMS v5.0 SP1 and higher, the web-based documentation library opens in a new tab or
window in your web browser.

http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
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• For releases prior to v5.0 SP1, a download starts for a Zip file with the PDF documentation for your
release.

Finding Information in the Documentation Library
The information in this topic will help you to locate information in the AgilePoint Documentation Library.

Using the Table of Contents

The table of contents in the AgilePoint Documentation Library is divided by content areas. For example, the
Installation section includes all the information you need to install AgilePoint BPMS. The AgilePoint API section
includes information about the AgilePoint APIs.

You can use the Table of Contents to explore the AgilePoint documentation content and find the information you
want.

Searching

The web-based documentation includes a centralized search for all documentation content. To search for
information:

1. In the AgilePoint Documentation Library, click the Search tab. In the Search box, enter 1 search team, and
click Search.

The search results display in alphabetical order by topic title.

It is important to understand that the third-party software AgilePoint uses to generate web-based
documentation allows only 1 search term. More than 1 search term will cause the search to fail.

AgilePoint recommends using a relatively unique search term to find the information you need. For example,
entering a common term, such as "process," will return a high percentage of the total documentation topics
in the search results.

2. Browse the list of topic titles to find the information you want.

Printing

The PDF documentation is provided mainly for the purpose of printing and archiving. To print a set of
information:

1. Navigate to the main page of the Documentation Library from which you want to print.

2. In the list of documents, click the document name in the PDF column.

3. From your PDF reader software, print the portion of the document you want.

Downloading Files and Sharing Links from the
Documentation Library
You can download and share files AgilePoint's documentation library as you would in any other web page. Note
that if you send links to recipients, they must have a Support Portal login to view the file.

These procedures are common examples based on Internet Explorer with the Adobe Reader plug-in. Exact
procedures may vary depending on your web browser, PDF viewer, and email client configuration.
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Share a Link to an HTML Topic

1. Navigate to the topic you want to share.

2. Copy the URL in the Location box in your web browser.

3. Paste the URL in an email, IM client, etc.

Share a Link to a PDF Document

1. In Internet Explorer, navigate to the Documentation Library home page.

2. In the PDF column, right-click the name of the PDF file you want to share.

3. In the quick menu, click Copy shortcut.

4. Paste the URL in an email, IM client, etc.

Save a Copy of a PDF Document

1. In Internet Explorer, open the Documentation Library home page.

2. In the PDF column, click the name of the PDF file you want to share.

3. In the Adobe Reader plug-in, click Save button.

Contacting AgilePoint Sales
AgilePoint is a leading Business Process Management System (BPMS) provider created by a team of driven
people who strive to incorporate the principles of relentless innovation for the benefit of our customers. Our
mission is to help companies of any size attain and sustain operational success through process excellence.

Headquarters: AgilePoint Corporation 1916C Old Middlefield Way Mountain View, CA 94043, USA

Tel: (650) 968 - 6789

Fax: (650) 968 - 6785

Email: info@agilepoint.com

Web site: www.agilepoint.com

International: For AgilePoint EMEA and AgilePoint Asia Pacific, please call the AgilePoint Corporate Office for
contact information.

  

Contacting Customer Support
To contact AgilePoint Support, please submit a ticket on the AgilePoint Support Portal: http://
support.agilepoint.com/SupportPortal/

If you do not have a Support Portal account, you can send an email to request one: support@agilepoint.com

mailto:info@agilepoint.com
http://www.agilepoint.com
http://support.agilepoint.com/SupportPortal/
http://support.agilepoint.com/SupportPortal/
mailto:support@agilepoint.com
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AgilePoint Server
AgilePoint Server is the server-side software engine that runs your AgilePoint-based processes. AgilePoint
Server interprets the XML schema associated with a process and programmatically executes the appropriate
actions. AgilePoint Server's SOA-based software model is what enables you to create and run processes without
writing software code.

This document is a user's guide and reference to the features, functionality, usage, configuration, and
administration of the AgilePoint Server component of the AgilePoint BPMS Suite.
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Deploying an AgilePart to AgilePoint Server
To deploy an AgilePart to AgilePoint Server, use the AgilePoint Deployment Wizard utility. For more information,
refer to AgilePart Deployment Wizard Utility in the Documentation Library.

http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
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Restarting AgilePoint Server in Windows
Service Mode
To restart AgilePoint Server running in Windows Service mode, do the following.

Prerequisites

• Microsoft Windows PowerShell is installed on your machine.

Navigation

1. Open the Windows PowerShell utility.

Instructions

1. At the PowerShell command prompt, enter the following commands, as appropriate for your system:

a. If you are using AgilePoint Clustering Server Manager (NLB environment), enter the following:

Restart-Service [Cluster Server Manager service name]

b. To restart AgilePoint Server, enter the following:

Restart-Service [AgilePoint Server Manager service name]

Note:  In an NLB environment, AgilePoint recommends restarting the servers on different days
to maintain system availability. If you restart them on the same day, it is possible to experience
system downtime.

Scheduling an AgilePoint Server Restart in Windows
Service Mode
To restart AgilePoint Server running in Windows Service mode based on a schedule, do the following.

Prerequisites

• Microsoft Windows PowerShell is installed on your machine.

Navigation

1. Open Notepad.

Instructions

1. In NotePad, create a new file with the following command, and save it as a PowerShell script file with a
name such as apserverrestart.ps1:

Restart-Service [AgilePoint Server Manager service name]

If you have multiple AgilePoint Server service instances, create a separate script file for each instance.
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2. If you have an NLB environment, in NotePad, create a new file with the following command, and save it as a
PowerShell script file with a name such as csmrestart.ps1:

Restart-Service [Cluster Server Manager service name]

3. In Notepad, create a new file with the following command, and save it as a batch file with a name such as
apserverrestart.bat:
PowerShell -command "& '[path]\apserverrestart.ps1' "

If you have multiple AgilePoint Server service instances, create a separate script file for each instance.

4. If you have an NLB environment, in Notepad, create a new file with the following command, and save it as a
batch file with a name such as csmrestart.bat:
PowerShell -command "& '[path]\csmrestart.ps1' "

5. Use Windows Scheduler to execute the batch files according to the schedule you want.

Note:  In an NLB environment, AgilePoint recommends restarting the servers on different days to
maintain system availability. If you restart them on the same day, it is possible to experience system
downtime.
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Safely Stopping AgilePoint Server in IIS Mode
To stop (or shut down) AgilePoint Server in IIS mode safely (i.e. without risking any data loss for requests
currently being processed), please use the following instructions.

Whenever you are performing maintenance on a resource required to run AgilePoint Server (e.g. taking the
workflow DB offline, upgrading AgilePoint Server, etc.), it is recommended that you first stop AgilePoint Server.
This will prevent possible problems, such as: data loss; email notification errors; etc.

1. (Optional) If you are using the AgilePoint Server Monitor windows service, it is recommended that you stop
the service while AgilePoint Server is unavailable.

2. Open the IIS management console.

3. Under your server's Application Pools node, select the application pool associated with your AgilePoint
Server application.

4. Stop the application pool (e.g. by right-clicking and choosing Stop).

You can also choose Recycle if you want the AgilePoint Server application to be available again
immediately.

5. When you are ready, start the application pool to make the AgilePoint Server application available again.
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Configuration Settings
This section describes additional AgilePoint Server Configuration Settings that can be implemented via
AgilePoint Server's configuration file (i.e. netflow.cfg). This file is located in the [AgilePoint Server installation
folder]. These additional configuration options are done manually, as currently there is not a user interface to
support them.

Configuring an SMTP Account
By default, AgilePoint Server uses anonymous SMTP. To configure your SMTP server to require authentication,
do the following.

How to Start

1. In a text editor, open the AgilePoint Server configuration file netflow.cfg from the following location:

[AgilePoint Server installation folder]\netflow.cfg

Procedure

1. In netflow.cfg in the notification node, enter the email address and password in the smtpService attribute
as follows:

<notification
    mode="[true or false]"
    format="[text or html]"
    smtpService="[smtp service assembly name]:[smtp service 
        class name]:[email address],[password]"
    mailServer="[SMTP server host name]:[port number]:ssl"
    sender="[sender email address]"
    sysadm="[AgilePoint administrator email address. 
        If blank, the system uses the sender email address.]"
    encoding="[encoding format]"

Example:

<notification
    mode="true"
    format="text"
    smtpService="Builtin::username@sbcglobal.net,mypassword"
    mailServer="smtp.sbcglobal.yahoo.com"
    sender="apnotifier@mycompany.com"
    sysadm="adminuser@mycompany.com"
    encoding="utf-8"

Note:  It is not required to add the user name/password to AgilePoint as a registered user.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
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Implementing a Custom Email Notification Delivery
Module
By default, AgilePoint uses System.Web.Mail for the Email Delivery Module. However, System.Web.Mail
sometimes may not work as well with some SMTP servers. AgilePoint provides the flexibility to allow you to plug-
in your own email delivery module or use a third-party component for the email delivery.

To plug-in your own mail delivery module:

1. First, implement the interface IWFSMTPService:

public interface IWFSMTPService
{
  void Authenticate(String smtpServer, String authenticateString);
  void Send(
        String mailDeliverableID,
        System.Text.Encoding encoding,
        Constants.MailFormat format,
        Constants.MailPriority priority,
        String sender,
        String to,
        String cc,
        String subject,
        String body,
        String attachments);
}

2. Add your assembly and class information into the AgilePoint Server configuration file (netflow.cfg). For
example:

<configuration>
        .. ..
        <notification mode="true"       
        smtpService="EasyMailForSMTP:CustomSMTP.EasyMailForSMTPService:"
        .. ..

Where EasyMailForSMTP is the assembly name and CustomSMTP.EasyMailForSMTPService is the
class name.

Configuring the AgilePoint Server Thread Pool Size
The System tab of the AgilePoint Server Configuration utility provides the user interface to configure the
maximum number of threads that AgilePoint will be able to use at runtime while handling workflow requests.
When the thread pool is configured via this utility it sets both the Event Capacity (for processing AgileWorks)
as well as the Working Capacity (for processing AgileParts). In most cases, the same thread pool size as
configured via the utility is sufficient for both the Working Capacity as well as the Event Capacity.

For thread pool sizing, anything between 10-100 should be fine. In most cases, a thread pool size of 10 provides
a good balance between concurrent processing and server resource optimization.
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In some cases, additional tweaking of thread pool sizing may improve performance when heavy CPU usage
is apparent for processing AgileParts versus AgileWorks. This finite control over thread pool sizing can be
accomplished via the AgilePoint Server Configuration file (i.e., netflow.cfg).

As stated above, when using the AgilePoint Server Configuration utility to set the Thread Pool Size, the
value entered, sets both the Event Capacity (for processing AgileWorks) as well as the Working Capacity
(for processing AgileParts). However, manual customization can be done via the netflow.cfg to adjust the
Working Capacity for a thread pool without changing the Event Capacity or vice versa. For example, if your
CPU is processing a large number of AgileParts rather than AgileWorks, you may want to increase the Working
Capacity thread pool size, and leave the Event Capacity as is. Improving AgilePart performance is the key to
improving capacity because AgilePart processing can cause a bottleneck.

To modify the netflow.cfg file for thread pool optimization, follow these steps.

1. Open the netflow.cfg file and locate the server eventCap and workingCap attributes.

2. Increase the eventCap number to increase the available threads for processing AgileWorks or increase
the workingCap to increase the number of threads for processing AgileParts. The results are viewed via
Enterprise Manager on the Performance page.

Thread Pool Sizing Guidelines
When configuring thread pool size, bigger is not always better! More concurrently running threads requires
more server resources (e.g. RAM and CPU), so increasing the thread pool size past a certain point could
start to decrease performance rather than improve it. In most cases, a thread pool size of 10 provides a good
balance between concurrent processing and server resource optimization. Anything between 10-100 should
typically be fine for the Thread Pool. Also, it is often just as (if not more) important to configure the IIS App Pool
Queue Length Limit appropriately as to fine tune the Thread Pool size.
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If all of your process' activities are "short-duration" ones, then you may not need many threads, because the
only way that "short-duration" activities alone would typically cause AgilePoint to (simultaneously) utilize the
maximum number of threads in the Thread Pool is if a large number of such activities were entered/activated
nearly simultaneously. However, if you have a mixture of "long-running" activities and "short-duration" activities,
then increasing thread pool sizes may help considerably because "short" activities that start in the "middle" of a
long running activity will not have to wait for it to end before being processed. In general, if you analyze a given
time period, then increasing either the quantity or the average duration of activities that are active within that time
period will increase the likelihood that some of those activities will require concurrent processing (and therefore
require a larger Thread Pool size). However, in certain environments, usage patterns may also have a significant
affect, and may render some of the above guidelines less (or more) accurate.

In the above context, a "long-running" activity is defined as one that will require server resources for a length of
time long enough that it may overlap with other/subsequent activities or processing. Examples of long running
activities could include: synchronous AgileParts that require several minutes (or even hours) of processing to
complete; Web Service activities with a large timeout value; AgileShapes that interact with (and may have to wait
for data from) other servers or systems; etc.

Conversely, a "short-duration" activity is one that will only consume server resources for a brief period. Examples
of such activities include: AgileParts that perform minimal processing; Manual activities (or AgileWorks that
perform minimal server-side processing); Single- or Multiple-Condition AgileShapes; etc. Note that Manual
activities are normally considered to be "short-duration" activities regardless of the activities' time span or due
date, because the AgilePoint server's resources are not being used during most of the activities' duration.

Another way to consider the issue is to determine how frequently new processes will be initiated/launched,
how long each process takes to complete, and how much of that time is spent on "automatic" activities that
are performed by the server. If you have many long-running processes running simultaneously, and each one
contains automatic activities that require minutes (rather than seconds or microseconds) to complete, then you
are much more likely to have simultaneous workflow processing occurring, which would require more threads for
optimal performance.

See below for a list of guidelines that should be helpful in determining a good Thread Pool size for most
environments.

Increasing Thread Pool Size
It may help to increase the Thread Pool size if:

• The average server-side processing duration for activities increases.

• The number of activities entered/activated per day increases.

• The number of new process instances per day increases (because this will typically increase the number of
activities entered/activated per day).

• The average number of activities per running process instance increases (i.e. if you start deploying much
more complicated process models than you were, it increases the likelihood of concurrent processing).

• The average duration (from Start to Complete) of your process instances increases (because this may
increase the number of activities entered/activated per day). This is especially true for processes whose
duration is determined by the number of times the process instance "loops" back and re-enters an activity
earlier in the process model. It may not be relevant for processes whose duration is primarily determined by
the durations of the Manual activities in the process.

• Any of your commonly-used processes contain activities that require minutes (or longer) of server-side
processing (as described above), as this significantly increases the likelihood of concurrent processing.

• Your environment is prone to intermittent periods of much-higher-than-average load during certain times of
day (or week, month, etc.). For example, if your process instances are often started nearly simultaneously
(e.g. at the start of the work day or shift, or because of certain events like the upload of a large batch of
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files), or you have many activities that "time out" simultaneously (e.g. at the end of the month), then it may
make sense to increase the Thread Pool size to take the higher-load periods into account.

• Your server, network, or database is prone to intermittent "slowdowns" (i.e. periods of slower-than-normal
processing). E.g. This could be due to scheduled services running in the background at specified times of
the day, or could be caused by periods of high server load caused by non-AgilePoint sites or applications (on
a non-dedicated server).

• Your server has plenty of memory (i.e. RAM), but not a lot of processing speed (i.e. CPU speed). In other
words, activities will take longer to process on a slow machine.

Decreasing Thread Pool Size
It may help to decrease the Thread Pool size if:

• Your server has limited memory (i.e. RAM). Regardless of CPU speed, a server with limited RAM should
limit the amount of concurrent processing performed (i.e. threads used) in order to limit memory usage.

• All (or almost all) of your processes use only short-duration activities. In such a scenario, it may be faster
for the server to process all activities sequentially (more or less) using a small number of threads, than to
concurrently process the same activities. In such a scenario, the server resources required in order to split
the server's CPU cycles between multiple threads may actually be (slightly) slower than simply waiting for
any activities currently being processed to be completed.

• The opposite of any of the items in the previous list is true. However, note that decreasing the Thread Pool
size will rarely result in dramatic performance improvements, so you typically don't need to fine-tune the
Thread Pool size below 50. 

Configuring the Max Loop
The Max Loop is the number of times a process instance can loop back to the previous step. The maximum
number of sessions for an activity is set to 50 by default. Once a process instances loops back the 51st time, the
process instance will become suspended.

Procedure

In some cases, you may have a special need to have more than 50 sessions, in this case, open the netflow.cfg
file in Notepad, and change the value for maxLoop to a higher value, and then save the file.

Reset IIS upon making changes to the netflow.cfg file.

You can also set the Maxloop at the process model level to avoid an infinite loop scenario. The process level
MaxLoop setting overwrites the global/server level setting in the netflow.cfg file.

There is a Process Template property in AgilePoint Envision called 'Maximum Session Allowed' that allows for
the configuration of MaxLoop that will overwrite the global/server level setting in the netflow.cfg file.

Configuring the Swap Out Time
The Swap Out Time configuration option refers to the maximum amount of time a process instance remains
in idle before it is swapped out of memory. The maximum swap out time is set to 5 minutes (300 seconds)
by default. Increasing the swap out time lets the process stay in memory longer, avoiding the CPU intensive
swapping, but keep in mind this may eventually affect capacity. Because swapping consumes a lot of CPU time,
it may be beneficial to reduce this number if the CPU is low on memory to improve performance.



Configuration Settings 19

AgilePoint BPMS v5.0 R2 SP1 AgilePoint Server Administrator's Guide r5.3.16

To change this setting, open the file [AgilePoint Server installation folder]\netflow.cfg in Notepad, change
the value for swapoutTime to a higher/lower value depending on the needs, then save the file. (Any changes to
netflow.cfg require an IISReset in order to take effect.)

Adjusting the swap out time should only be a temporary workaround solution. If performance is an issue,
investing in another CPU, more memory, or a faster hard drive, is a better solution.

Configure Session State Handling
After installing AgilePoint Server and Enterprise Manager, you must configure session state handling. There may
be several valid options, depending upon your environment and your organization's requirements.

Value Description

InProc This is the default value for ASP.NET. This value is suitable for single-machine
AgilePoint Server environments; you cannot use this setting for NLB.

StateServer This setting can be used in a single-machine or NLB environment to manage the
session state using the ASP.NET State Service Windows Service. To use the
StateServer setting, the ASP.NET State Service must be running on a separate
machine from AgilePoint Server.

SQLServer In NLB environments, this setting allows the AgilePoint Servers to store their
session data on a separate machine in a SQL Server database. If an AgilePoint
Server fails, another server in the cluster can take over and serve requests without
session data loss.

Off This setting enables you to turn off the session state for AgilePoint Server.
This setting can help to improve performance of AgilePoint Server in NLB
environments. You cannot use this session for Enterprise Manager.

Custom This setting requires custom coding. For more information, contact AgilePoint
Support.

If you use Session State handling in an NLB environment, note the following:

• The session must be persisted outside of the current server.

• This session persistence is managed by the .NET Framework, not by AgilePoint. The framework uses the
connection string declared in the web.config for AgilePoint Server and AgilePoint Enterprise Manager. See
http://msdn2.microsoft.com/en-us/library/87069683(vs.71).aspx   to communicate to the database where the
session is persisted.

To set up session state handling:

1. Run InstallSqlState.sql (installed by default in [system root]\Microsoft.NET\Framework\version) on the
computer running SQL Server that will store the session state (i.e. the db server). This creates a database
called ASPState with new stored procedures and ASPStateTempApplications and ASPStateTempSessions
tables in the TempDB database.

2. Open the AgilePoint Server and AgilePoint Enterprise Manager web.config files. In the <sessionState>
node, set the values as required for your environment.

For example, if you are using the SQLServer setting, the SQL connection string must point to the session
state SQL Server database on the DB server machine that stores the session data:

<sessionState mode="SQLServer" 

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
http://msdn2.microsoft.com/en-us/library/87069683(vs.71).aspx%20
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sqlConnectionString="[your sessionState database connection string]" 
cookieless="false"
timeout="20000"
/>

If you are using the Off setting, no further information is required:

<sessionState mode="Off" />

Configuring Ascentn.AgilePoint.WCFService.exe.config
The file Ascentn.AgilePoint.WCFService.exe.config provides back-end configuration settings for AgilePoint
Server.

Prerequisites

• AgilePoint Server running in Windows Service mode.

How to Start

1. On the CSM machine, open the file [AgilePoint Server installation folder]\bin
\Ascentn.AgilePoint.WCFService.exe.config

Procedure

1. In Ascentn.AgilePoint.WCFService.exe.config, add or modify the following keys as required for your
environment.

Field Name Definition

LicenseActivationCode Definition:

Specifies the encrypted activation code for the
AgilePoint BPMS license. This code is paired with
a license key to enable product activation.

Allowed Values:

An appSettings key in the following format:

<add key="LicenseActivationCode"
value="[activation code]" />

This value must be supplied by AgilePoint Sales
or Customer Support.

Default Value:

None

Example:

<add key="LicenseActivationCode"
value="DFKORh
lBxwvSGlo2R03T7AHnlq729JjpNZHYH6ruF8NmiXGctp2wigeklicXPp
+eNaEzHTKKD51z
JJWj17Ejls1OQxGy59eSyKYzlrkV22DtlDSssKCDB6ntTEpfPVlr35Gl2fzCaLdOfd1zPEbMjka6

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
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Field Name Definition

IlsnQ
+36ln7tgnb5wwV7yCqkWCPxtsxYlpBgxBDoycvNr0IYi
+NJwvKRaY8wPMwtsy5sFp2h9pNA
DPx9HuYfeJwc8eonlR7002MH9mV9k45Hcnyq/
ybs7oEZBzZyyQ8xcBJQgj0qNLtmTZ9mvjJkl7vE
ZIS3w/f40JJ6obEy7MJKr7wRUZQmXreubTf/MdF
+udsZjTVg9hjEhU4fiVQNwkVNTa2iP4OdmcVh
lOBUVr4d8nhOtJiR6KBhTdr6FLBW2dk8rC
+eSJJceUt9wF2kfLGwSzUzl8P2rAvHNPQopCb3eeiA
sFLqng92o6J/jLdFs7k1xXrTNSIA05gcwOrTQPs
+7n1qkU619EGvijSvFBbwLNtFMoD6PQ+5EXSz
V8MuSXnSvrbAaJnh5MdRRL1COiIFXmOzMOZ1+
+jFnV3IL6TcOka5th2sDk
+CnszRxL8iARJyUzdM 0jQkDKCibk7Bm6hMm
+EQcBGM7ntN5efsIPNkz0aOGKNH/
qkdwL24tFxOI0wdoW0I6FazCY6Zf4IO
gaGrWSWgTwuwUwbRI2LQnVyb/
ue+WqeB047nJY1sFV/LRfLmx1c/
SoWKzzGImJr9NsRpnrHVH/eR
ptoSjK5DX00QjEZF78ojIcuPu/D0kk98v
+hCOekwtF0oXaeEaaHWBsgi7xUgpSbLDnUbbt3F16dA
vrK/cDUKNdNZg06Ve
+OB80eUzS9dJBEh/7QS1QgJSZ5bYS95Vx/
HLEPUfFqEkNFnpRAoLYmIChnj xvA5ffZItVt
+P6BjXKlBS7staCpllBwO6DkXXpY993mh6vGG7mHyn1JjA0TPQAEYuYqeT0eqS8zG
BQSiIwdMffnG6yWBZXHGsj5cXpfBxn+HP0/
RpUKtVzjd2olq4myzSEB8fFWMaoPXGMrH6MHzKRlC
lZjoAzZs3rKqmx
+ZaG9qkvDUnczuyZqiLe7PpIjXy3q5FftKvWsEQ9pfN0Z7fnMZLNs
+QHpFLj0k lvsoI/
gBmFbjgfDJ8SfOiZYbgifCXFiyYzPXJg
+rppP2lhISNSPWpBFpIwS0ntPCwKpqhQ7NLDMA
ZbTnBus+OnEatxfvAVYtAJYGfT/
qRhqDFAjGqNJxuysy/
X9wmbx1XwL5ERZmRBES5j8Od9FlY2gB
yRK2hS2Cu+8RtcOTa2N/
BsxGAkO3R99ztKwn9uGAItmGGKXNgLpLxoen7a4DEwx
+iM1n2iWYcpO3
2IdaWphvtlILoxNhCIwsbNq/8KhlyQzjGewixwpnl9IHDEIYDKVTc5QFAMBaXZLzS7ntjTePu3tK
0W2VIwSmXm9A9/
+CCkm3mQ2VI96p3kLO1H0u3frI1voRilZJwHUgHGE4nwM1CyV85S5oAQJWCGWT
N7+NAoEei0CYDAAYiOeX8fG1aqlMXBp8Wwlld085iqJDYuwPMB717jH89sKrHndDsQCLqnKzZgdp
bTtvrBL8pRkPI
+LfziHoL6EKY1IRo6NVsYsLxTXnXXsCcob0w2sBgnpahVwZXNA5FafounHPHiCm
0B7pACbyXQ
+LKWwoYYNJI20cLIgsAcwXgqbXYjqaQQfu0PyKgJ6tZMuzV
+fLbA1toq+s7h7LYLj4
FACaKVzYYIxq0cktosg6wOBuukyjwlRzNZVLGiJrXqj0+KKmIIrbc4tsAaP72wRN1PMDRQaGFkT2
1AWs3b/
JTFyse0VZNgXgPEDPDUu4wUhIjil5zySahnrnl79x6nwd
+2qz8FHIun6/oEhFepu9U0JM xCqw
+gbeysruVrd9zPTtgXBP5HxgPHqxu09MDFdxomCRXxxduSVIAg/
hBva97eO5TXovtcYxZl8u
ffF1PWxUupv9tSxiU2WYru/bkyaI5Q==" />
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AgilePoint Server Configuration Utility
The AgilePoint Server Configuration utility can be accessed via: Start > All Programs > AgilePoint >
AgilePoint Server Configuration.

This utility is a user-friendly editor for AgilePoint Server's netflow.cfg configuration file. This file can be
found in the root folder where you have installed AgilePoint Server (e.g. c:\inetpub\wwwroot\AgilePointServer
\netflow.cfg). The location of AgilePoint Server can be determined from the registry.

Although most of the AgilePoint Server configuration settings can be managed via the AgilePoint Configuration
Utility, there are some additional configuration settings that can be modified manually via the netflow.cfg file.

For more information, refer to Configuration Settings in the Documentation Library.

System Window
This window allows you to configure the AgilePoint system user, thread pool sizing, and default email notification
settings.

http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
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System Settings
The System area allows you to specify the identity and authentication information for the AgilePoint system
user, and the maximum number of threads that AgilePoint will be able to use at run time while handling workflow
requests.

The System User and Password fields should contain the same values that you would use when logging into
Windows. However, if you are installing AgilePoint Server on a Windows Server that is a Domain Controller, you
cannot use a local administrator account as the AgilePoint Server System User, because the domain controller
will not recognize local accounts. To successfully configure AgilePoint Server on a Windows Server domain
controller, check the Active Directory check box, and specify the domain name and administrator account that
belongs to the domain controlled by the domain controller.

For thread pool sizing, anything between 10-100 should be fine. In most cases, a thread pool size of 10 provides
a good balance between concurrent processing and server resource optimization.

Note:  In some cases, additional tweaking of thread pool sizing may improve performance when heavy
CPU usage is apparent for processing AgileParts versus AgileWorks. This finite control over thread
pool sizing can be accomplished via the AgilePoint Server Configuration file (i.e. netflow.cfg). For more
information, refer to Configuring the AgilePoint Server Thread Pool Size in the Documentation Library.

Email Notification Settings
The Notification area allows you to specify the default values for the email notification settings.

AgilePoint Server's notification mechanism uses an extensible framework that allows for the creation of custom
notification modules. AgilePoint server provides a built-in notification module as default. However, it is possible
to replace AgilePoint's default module with a custom notification module so that all AgilePoint notifications
are processed and sent using the custom module. This allows you to implement virtually any kind of custom
notification scenario, including IM, email "batch sending", sending via custom APIs, etc.

For more information, refer to Implementing a Custom Email Notification Delivery Module in the Documentation
Library.

Database Window
Specifies the configuration of the databases AgilePoint Server uses to store data. AgilePoint Server uses two
possible databases:

• Workflow database - Stores data for processes that are in current use.

• Archive database - Stores a backup of the workflow data, as well as the data for processes that have been
archived.

http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
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How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the AgilePoint Server Configuration Tool window, click the Database tab.

Fields

Field Name Definition

Main Database Tab Action:

Specifies the connection to the AgilePoint workflow
database to store the data.

Archive Database Tab Action:

Specifies the connection to the Archive database
to store backup of the workflow data and archived
process data.

Database Type Definition:

Specifies the database technology you are using to
store AgilePoint data.

Allowed Values:
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Field Name Definition

• Microsoft SQL Server

• Oracle

Default Value:

Microsoft SQL Server

Encrypt Database Setting Definition:

Specifies whether to encrypt your stored database
settings.

Allowed Values:

• Selected - Saves the database settings in
encrypted format.

• Deselected - Saves the database settings in
plain text.

Default Value:

Deselected

User Definition:

The user name for the database account AgilePoint
Server uses to connect to the database.

Allowed Values:

A valid user name for the database.

Default Value:

sa

Password Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None

Integrated Security Definition:

When integrated security is selected, the current
windows account credentials are used for
authentication.

To Access This Field:

1. In the Database Type list, select Microsoft
SQL Server.
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Field Name Definition

Allowed Values:

• Selected - The windows account credentials
are used for authentication automatically.

• Deselected - The user and password fields are
enabled for database authentication.

Default Value:

Selected

Database Server Definition:

Specifies the server name and domain for your
database.

Allowed Values:

A valid database server name.

Default Value:

None

Database Name Definition:

Specifies the name of your database.

To Access This Field:

1. Click Ellipses to populate the database names
from the database server.

Allowed Values:

A valid database name.

Default Value:

None

Service Name Definition:

Specifies the Oracle database service name.

To Access This Field:

1. In the Database Type list, select Oracle.

Allowed Values:

A valid service name.

Default Value:

None

Connection Pool Size Definition:
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Field Name Definition

Specifies the maximum number of simultaneous
database connections for the workflow database.

To Access This Field:

1. Click the Main Database tab.

Allowed Values:

Any integer.

It is recommended to use a connection pool size
that is >= 100, or 2 * the thread pool size.

Default Value:

100

Archive Completed Process In Definition:

Specifies the minimum number of days to save
completed or canceled processes before archiving.

To Access This Field:

1. Click the Archive Database tab.

Allowed Values:

Any integer, representing a number of days.

If you set this value to 0, archiving does not occur.

Default Value:

180

Configuring Process Archiving
Process archiving moves a process instance and all its related data to an archive database when the Completed
or Canceled date for the process instance exceeds a specified number of days. This helps save storage space
on the main AgilePoint database and improve performance.

You can also archive process data manually. For more information, refer to APADM Archive Database
Command in the Documentation Library.

Prerequisites

• Create a database to use as the archive database.

How to Start

1. Log on to Windows using a user account with the access rights "Archive Process Instance" in AgilePoint.

2. Open the AgilePoint Server Configuration Utility: Start > All Programs > AgilePoint > AgilePoint Server
Configuration.

3. Click the Database tab.

http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
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Procedure

1. In the AgilePoint Server Configuration Utility On the Database tab, click the Archive Database tab.

2. In the Authentication section, configure authentication for the archive database.

3. In the Database Server field, enter the server name for the archive database.

4. In the Database Name field, click the ellipses button to populate the database names on the database
server.

5. In the Database Name field, select the name of the archive database.

6. In the Archive completed process in field, set the number of days to save Completed or Canceled
processes before archiving.

The process for archiving AgilePoint processes runs once per day between 1:00 a.m. and 3:00 a.m.

To suspend a database archive schedule without deleting the settings, set Archive completed process in to 0.

Extension Window
AgilePoint provides a powerful integration framework; Global Server Control Extended Module, to allow you
to easily extend AgilePoint with additional server control modules. These server control modules extend
AgilePoint's functionalities and provide a higher level of customizability. The Extension window allows you to
register and configure certain optional server extensions through the Global Server Control Extended Module
that can be used to modify the workflow engine's run time behavior. See the sections below for details on the
supported extensions.
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The Add and Edit buttons allow you to register a new server extension. (See below for details.)

The Remove button allows you to un-register the highlighted server extension.

The Configure button allows you to modify the settings and configuration of the highlighted server extension. It is
only enabled for server extensions that support additional configuration options.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

ADSyncModule Extension
For most enterprises, Active Directories are changing continuously with users added or removed frequently.
For enterprises with large numbers of groups and users, a mechanism to automate the synchronization of the
member association in Active Directory plays an important role for any Active Directory integration.

In addition to the built-in Active Directory integration with products such as: Envision and Enterprise Manager,
AgilePoint also provides an out-of-the-box Active Directory synchronization module which can be plugged into
AgilePoint through the Global Server Control Module framework. This synchronization module provides the
synchronization capability between Active Directory groups and AgilePoint groups automatically.

This synchronization module can be added to the AgilePoint system through the AgilePoint Global Server
Control Extended Module. This server extension allows you to enable and configure automated synchronization
of the AgilePoint authentication data with Active Directory. It will automate the member synchronization between
Active Directory users and groups and AgilePoint users and groups.

Requirements

• The AgilePoint System User (as defined in the AgilePoint Server Configuration utility) should belong to the
Active Directory domain.

• AgilePoint Server's Application Pool's Identity user account (as configured in IIS) needs to have read
permissions to the Active Directory server and data.

Enabling the AdSyncModule Extension
To enable the AgilePoint Server extension:

1. Open the AgilePoint Server Configuration utility and go to the Extension window.

2. On the Extension window, click Add.

3. Click the Ellipses button next to the Assembly field and add the following assembly:

…\AgilePointServer\bin\ADSyncModule.dll

4. In the Impersonator field, enter the credential for the AgilePoint Service Account.

For more information, refer to Setting Up the Hosted Service

5. Click OK. Now you will need to configure the module to schedule the synchronization.

6. Click the Configure button, and specify the desired configuration settings. In the following configuration
interface, you can specify the synchronization with the frequency of every day, week, or month and at a
particular time of day starting with the day you set the schedule. The synchronization module also provides

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#cloudSetUpHostedService.html
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the option of registering the users automatically or sending an alert email to AgilePoint system user if there
are members in the Active Directory groups that have yet to be registered in AgilePoint.

7. Click OK.

Configuration for Active Directory Groups Synchronization Window -
Active Directory Configuration Tab
Synchronizes AgilePoint Server user data with Active Directory.

Prerequisites

• Before configuring, you must  enable the ADSync Module Extension AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select ADSyncModule.dll.

4. Click Configure.

5. On the Configuration for Active Directory Groups Synchronization window, click the Active Directory
Configuration tab.
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Fields

Field Name Definition

LDAP Path Definition:

Specifies the LDAP connection string for your Active
Directory.

Allowed Values:

A valid LDAP connection string.

Use the Ellipses button to retrieve the connection
string for the current Active Directory.

Default Value:

LDAP://

Example:

LDAP://DC=MyCompany,dc=com

Domain Definition:

The authentication domain for Active Directory
users.

Allowed Values:

A valid domain.

Default Value:

None

Configure Opens the Following Window:

Advanced LDAP Settings Window

To Access This Field:

You must be using a Multi-Tenant environment.

Purpose of this Window:

Specifies to map the LDAP connection string for
your Active Directory with your tenant.

AgilePoint System User Definition:

Specifies whether the ADSync module extension
connects to the specified Active Directory using the
AgilePoint Service Account (or system account).

Allowed Values:
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Field Name Definition

• Selected - The ADSync module uses the
AgilePoint Service Account.

• Deselected - The ADSync module uses a
custom account.

Default Value:

Selected

Custom Account Definition:

Specifies whether the ADSync module extension
connects to the specified Active Directory using a
specified account other than the AgilePoint Service
Account. This is useful if the AgilePoint Service
Account does not have an account on your Active
Directory domain.

Allowed Values:

• Selected - The ADSync module uses a custom
account.

• Deselected - The ADSync module uses the
AgilePoint Service Account.

Default Value:

Deselected

Username Definition:

Specifies the user name for an account you want
AgilePoint Server to use to connect to your Active
Directory domain.

Allowed Values:

A valid user name for an account that has access
to the Active Directory domain to which you want to
connect.

Example:

DEMO3/jsmith

Password Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None
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Field Name Definition

Sync Settings Tab Opens the Following Window:

Configuration for Active Directory Groups
Synchronization Window - Sync Settings Tab

Purpose of this Window:

Specifies the how often Active Directory users and
groups are synchronized.

Configuration for Active Directory Groups Synchronization Window - Sync
Settings Tab
Specifies the how often Active Directory users and groups are synchronized.

Prerequisites

• Enable the ADSync Module Extension AgileConnector.

• Complete the Configuration for Active Directory Groups Synchronization Window - Active Directory
Configuration Tab.
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How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select ADSyncModule.dll.

4. Click Configure.

5. On the Configuration for Active Directory Groups Synchronization window, click the Sync Settings tab.

Fields

Field Name Definition

Schedule Action:

The frequency for Active Directory synchronization.
Synchronization can occur every day, week, or
month, at a particular time or day.

Disable Email Notification of the Synchronization
Activities

Definition:

Disables email notifications for Active Directory
synchronization.

Allowed Values:

• Selected - Disables email notifications for
Active Directory synchronization.

• Deselected - Enables email notifications for
Active Directory synchronization.

Default Value:

Deselected

If Active Directory group member is not AgilePoint
user

Definition:

Specifies what actions to take if a member of your
Active Directory is not a registered AgilePoint user.

Allowed Values:

• Register user to AgilePoint automatically
- Creates an AgilePoint account for the user
using their Active Directory information.

• Send email to AgilePoint system user, and
do not take any action - Does not create an
AgilePoint account for the Active Directory user,
but sends a notification email to the AgilePoint
system user account.

Default Value:
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Field Name Definition

Register user to AgilePoint automatically

Sync all Lync IDs with email IDs Definition:

Synchronizes all of your users' Lync IDs with their
email IDs.

This synchronization occurs each time and Active
Directory synchronization occurs. AgilePoint
recommends using this option only if all of your
users' messaging IDs and email IDs are the same.

Allowed Values:

• Selected - Synchronizes Lync IDs with users'
email IDs.

• Deselected - Does not synchronize Lync IDs
with users' email IDs.

Default Value:

Deselected

Sync all Yammer IDs with email IDs Definition:

Synchronizes Yammer IDs with AgilePoint users'
email IDs. This synchronization occurs each time
and Active Directory synchronization occurs.
AgilePoint recommends using this option only if all
of your users' messaging IDs and email IDs are the
same.

Allowed Values:

• Selected - Synchronizes Yammer IDs with
users' email IDs.

• Deselected - Does not synchronize Yammer
IDs with users' email IDs.

Default Value:

Deselected

Sync all Chatter IDs with email IDs Definition:

Synchronizes Chatter IDs with AgilePoint users'
email IDs. This synchronization occurs each time
and Active Directory synchronization occurs.
AgilePoint recommends using this option only if all
of your users' messaging IDs and email IDs are the
same.

Allowed Values:

• Selected - Synchronizes Chatter IDs with users'
email IDs.
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Field Name Definition

• Deselected - Does not synchronize Chatter IDs
with users' email IDs.

Default Value:

Deselected

Advanced LDAP Settings Window
Specifies to map the LDAP connection string for your Active Directory with your tenant.

Prerequisites

• To access this window, you must have a multi-tenant environment.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select ADSyncModule.dll.

4. Click Configure.

5. On the Configuration for Active Directory Groups Synchronization window, click Configure.
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Fields

Field Name Definition

Add (+) Action:

Creates a row where you can specify your tenant
name and LDAP string.

Tenant Definition:

Specifies the name of the tenant for which you want
to map with LDAP connection string.

You can have multiple instances of the same tenant
name, and each tenant can have multiple LDAP
connection strings.

Allowed Values:

A list of your enabled tenant names.

Default Value:

None

LDAP String Definition:

Specifies the LDAP connection string of your Active
Directory for your tenant.

Allowed Values:

A valid LDAP connection string.

Default Value:

None

Example:

LDAP://DC=MyCompany,dc=com

Remove (-) Action:

Deletes the selected row from the multi-tenant
LDAP settings list.

Delete ( ) Action:

Deletes all rows from the multi-tenant LDAP settings
list.
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Group Member Synchronization Rules

• Only groups that have already been added into AgilePoint will be synchronized with Active Directory. New
Active Directory groups will not be added automatically to AgilePoint. The new Active Directory groups can
be added manually through the Enterprise Manager interface.

• The changes of user members (adding or removing) in the Active Directory groups will be synchronized to
AgilePoint but the changes in AgilePoint groups will NOT be synchronized back to the Active Directory.

• The synchronization only applies to member association (Add or Remove) within the groups. Group
properties such as names and descriptions are NOT synchronized.

• When a new member is added to Active Directory, this member will also be added to the corresponding
AgilePoint group. If the actual user entity is not registered in AgilePoint yet, the user entity will be
registered to AgilePoint automatically.

• When a member is removed from Active Directory, this member in the corresponding AgilePoint group
will also be removed. The actual user entity will NOT be removed from AgilePoint as the same user
entity can also be associated with other groups in the system.

• If the Active Directory contains sub-groups (Nested groups), the members in the sub-groups will also be
synchronized and the members will be added to or removed from the top level group.

User Synchronization Rules

• Changes to the following Active Directory User properties will be synchronized to AgilePoint. Other
properties will NOT be synchronized.

• Full Name

• Email Address

• Department

• Title

• Manager

• Removal of an Active Directory User will result in the following AgilePoint synchronization actions:

•   The user will be removed from any AgilePoint Groups.

•   Any tasks assigned to this user will still exist, it may be required to cancel or reassign these tasks to a
valid AgilePoint user.

Filtering the ADSyncModule Extension
The Extra Filter feature has been added in the ADSync module using two keys of String data type:
RequireExtraFilter and ExtraFilterValue. This feature provides extra filter options to synchronize users between
Active Directory and AgilePoint. The RequireExtraFilter key is used to enable the Extra Filter feature. The
ExtraFilterValue key stores the extra filter value which is a LDAP query. Do not use the objectcategory or
objectclass keywords in the query because these keywords are included in the feature.

Prerequisites

• The ADSyncModule extension is enabled.
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Procedure

1. In the Windows Registry, create the following keys in the location SOFTWARE\Ascentn\Server
\ActiveDirectory

Name Value

RequireExtraFilter Definition:

Specifies whether additional LDAP filters are
required for the Active Directory Sync module.

Allowed Values:

• Yes/True - Enabled

• No/False - Disabled

ExtraFilterValue Definition:

Specifies an LDAP query that defines a
synchronization filter for Active Directory.

Allowed Values:

An LDAP query that does not include the
objectcategory or objectclass keywords.

Example:

• (mail=*)

Synchronizes users who have email IDs.

• (givenName=John)

Finds users with the given name John.

Synchronizing Active Directory groups with AgilePoint groups
Special characters can be included in group names while synchronizing users of Active Directory and AgilePoint
by using a CustomActiveDirectorySync key of String data type in the ADSync module. However, the semicolon
(;) and tilde (~) characters cannot be used in group names, because they act as group-pair separators, as
follows:

<AgilePointGroup1>~<ActiveDirectoryGroup1>;<AgilePointGroup2>~<ActiveDirectoryGroup2> and so on.

Prerequisites

• The ADSyncModule extension is enabled.

Procedure

1. In the Windows Registry, create the following keys in the location SOFTWARE\Ascentn\Server
\ActiveDirectory
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Name Value

CustomActiveDirectorySync Definition:

The data type is String.

Allowed Values:

A semicolon-delimited list of group pairs in the
following format:

<APGroup1>~<ADGroup1>;<APGroup2>~<ADGroup2>

Example:

• <APMyGroup>~<ADYourGroup>

Specifies that an AgilePoint Group named
APMyGroup is to be synchronized with an
Active Directory Group named ADYourGroup.

• <APMyGroup>~<ADYourGroup>;<APOurGroup>~<ADTheirGroup>

Specifies that 2 pairs of groups are
synchronized: APMyGroup with
ADYourGroup, and APOurGroup with
ADTheirGroup.

Scheduling
The schedule of the synchronization is set through the module's configuration interface. The synchronization can
be performed at a particular time of day with the frequency of every day, every week, or every month.

For example, if you schedule the synchronization to be performed at 2am on Jan. 1 and you also select Every
day as the frequency, the synchronization will be started automatically at 2am on Jan 1, Jan 2, Jan 3, etc.

The following table summarizes the different ways that the schedule can be set for the synchronization.

Frequency Time 1st Sync 2nd Sync 3rd Sync 4th Sync 5th Sync

Every Day 2am Jan. 1 Jan. 2 Jan. 3 Jan. 4 Jan. 5

Every Week 2am Jan. 1 Jan. 8 Jan. 15 Jan. 22 Jan. 29

Every Month 2am Jan. 1 Feb. 1 March. 1 April. 1 May. 1

The synchronizations typically happen within five minutes of the scheduled time. For example, if the scheduled
time is 2am, the actual synchronization could happen between 1:55am to 2:05am.

Note:  The scheduling pattern (daily, weekly, or monthly) and scheduling time should be the same for
multiple AgileConnectors of the same type.
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Exception Handling
This module also provides exception handling for the scheduling. In the event that your server is down during
the scheduled synchronization, as soon as your server is back online, the synchronization will be automatically
kicked off. After that, the next synchronization will resume the original schedule.

Log Files
The Active Directory Synchronization module provides the following logs.

Time and Status Log

The time and status is logged in the following location:

• AgilePointServer\log\[DateTime]-[server name].log

Example:

3/12/2012 12:53:29 PM>>
Synchronization started on 3/12/2012 12:53:27 PM 
    
Path=LDAP://DC=MYDOMAIN,DC=com, UserLogonDomainName=MYDOMAIN
43 groups found.
   Synchronizing users
       Updating user 'MYDOMAIN\John.Sample'. User full name:John Sample,
 department:
        
Synchronization finished on 3/12/2012 12:53:29 PM.

Error Log

Errors are logged in the following location:

• AgilePointServer\log\ADSynchModule.log

Example:

2012-03-12 12:53:27.732 >>> Active Directory group synchronizer 
    'ADSyncModule' has been started. Configuration: every Day at 1 O'clock, 
    register user automatically=True, Path=LDAP://DC=ASTN,DC=com, 
    Domain=ASTN

Notifications
In addition to log files that keep track of the synchronization statuses, the synchronization module also provides
email notification capability. Email notification is sent out to the AgilePoint System User with information about
the synchronization. This will allow the system user to determine if there is a need to manually synchronize the
groups or users in the event of failed synchronization.

DBSyncModule Extension
The DBSyncModule AgileConnector extension allows you to synchronize custom user and group database
tables with AgilePoint groups automatically.
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Requirements
The following are requirements for the DBSyncModule AgileConnector:

• The AgilePoint System User (as defined in the AgilePoint Server Configuration utility) should be a Database
user.

• AgilePoint Server's Application Pool's Identity user account (as configured in IIS) needs to have read
permissions for the appropriate database.

Enabling the Extension
To enable the AgilePoint Server extension:

1. Open the AgilePoint Server Configuration utility and go to the Extension window.

2. Click the Ellipses button next to the Assembly field and add the following assembly:

…\AgilePointServer\bin\DBSyncModule.dll

3. Leave the Impersonator field blank.

4. Click OK. Now you will need to configure the module to schedule the synchronization.

5. Click the Configure button, and specify the desired configuration settings.

In the configuration interface, specify the following information:

• Connection - Provide a valid database connection string.

• Query - Provide the SQL query to fetch records from a table. The query must fetch the following fields,
which are mandatory:

• TITLE

• USER_NAME

• FULL_NAME

• DEPARTMENT

• EMAIL_ADDRESS

• MANAGER

• GROUP_NAME

To check that the query was set up correctly, click Verify Query.

• Schedule - Specify the synchronization with the frequency of every day, week, or month and at a
particular time of day starting with the day you set the schedule.

• Option - This section provides an option to select what action needs to be taken when a database
member is not an AgilePoint user. Either one can select to register user to AgilePoint automatically or
send a notification to AgilePoint System user.

Configuration for Database Groups/Users Synchronization Window
Synchronizes AgilePoint Users and Groups with the user information resulting from a database query.
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Prerequisites

• Before configuring, you must ` enable the DBSync Module Extension AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select DBSyncModule.

4. Click Configure.
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Fields

Field Name Definition

Configure Opens the Following Window:

Database Configuration Window

To Access This Field:

You must be using a Multi-Tenant environment.

Purpose of this Window:

Synchronizes users and groups for a tenant with the
user information resulting from a database query.

Connection String Definition:

Specifies the connection string to be used to
connect to the database.

Allowed Values:

A valid connection string.

Default Value:

server=localhost;database=pubs;trusted_Connection=yes

Custom Attributes:

Yes

Example:

server=DataServer;database=StoreDb;trusted_Connection=yes

Query
Definition:

The SQL query used to fetch the records from the
database.

Allowed Values:

A valid SQL query.

The query must fetch the following fields, which are
mandatory:

• TITLE

• USER_NAME

• FULL_NAME

• DEPARTMENT

• EMAIL_ADDRESS

• MANAGER
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Field Name Definition

• GROUP_NAME

Verify Action:

Verifies whether the specified query and connection
string are valid.

Schedule Action:

The frequency for database synchronization.
Synchronization can occur every day, week, or
month, at a particular time or day.

If Active Directory group member is not AgilePoint
user

Definition:

Specifies what actions to take if a member of your
Active Directory is not a registered AgilePoint user.

Allowed Values:

• Register user to AgilePoint automatically
- Creates an AgilePoint account for the user
using their Active Directory information.

• Send email to AgilePoint system user, and
do not take any action - Does not create an
AgilePoint account for the Active Directory user,
but sends a notification email to the AgilePoint
system user account.

Default Value:

Register user to AgilePoint automatically

Sync all Lync IDs with email IDs Definition:

Synchronizes all of your users' Lync IDs with their
email IDs.

This synchronization occurs each time and Active
Directory synchronization occurs. AgilePoint
recommends using this option only if all of your
users' messaging IDs and email IDs are the same.

Allowed Values:

• Selected - Synchronizes Lync IDs with users'
email IDs.

• Deselected - Does not synchronize Lync IDs
with users' email IDs.

Default Value:

Deselected

Sync all Yammer IDs with email IDs Definition:
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Field Name Definition

Synchronizes Yammer IDs with AgilePoint users'
email IDs. This synchronization occurs each time
and Active Directory synchronization occurs.
AgilePoint recommends using this option only if all
of your users' messaging IDs and email IDs are the
same.

Allowed Values:

• Selected - Synchronizes Yammer IDs with
users' email IDs.

• Deselected - Does not synchronize Yammer
IDs with users' email IDs.

Default Value:

Deselected

Sync all Chatter IDs with email IDs Definition:

Synchronizes Chatter IDs with AgilePoint users'
email IDs. This synchronization occurs each time
and Active Directory synchronization occurs.
AgilePoint recommends using this option only if all
of your users' messaging IDs and email IDs are the
same.

Allowed Values:

• Selected - Synchronizes Chatter IDs with users'
email IDs.

• Deselected - Does not synchronize Chatter IDs
with users' email IDs.

Default Value:

Deselected

Database Configuration Window
Synchronizes users and groups for a tenant with the user information resulting from a database query.
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Prerequisites

• To access this window, you must have a multi-tenant environment.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select DBSyncModule.

4. Click Configure.

5. On the Configuration for Database Groups/Users Synchronization window, in the Multi-Tenant
Database Information section, click Configure.

Fields

Field Name Definition

Tenant Definition:
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Field Name Definition

Specifies the tenant name.

Allowed Values:

List of your enabled tenant names.

Default Value:

None

Connection String Definition:

Specifies the connection string to be used to
connect to the database.

Allowed Values:

A valid connection string.

Default Value:

server=localhost;database=pubs;trusted_Connection=yes

Custom Attributes:

Yes

Example:

server=DataServer;database=StoreDb;trusted_Connection=yes

Query
Definition:

The SQL query used to fetch the records from the
database.

Allowed Values:

A valid SQL query.

The query must fetch the following fields, which are
mandatory:

• TITLE

• USER_NAME

• FULL_NAME

• DEPARTMENT

• EMAIL_ADDRESS

• MANAGER

• GROUP_NAME

Add Action:

Creates a row where you can specify your tenant
name, connection string and query.
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Field Name Definition

Verify Action:

Verifies whether the specified query and connection
string are valid.

Update Action:

Updates the selected row from the database
configuration list.

Remove (-) Action:

Deletes the selected row from the database
configuration list.

Edit ( ) Action:

Modifies the selected row from the database
configuration list.

Delete ( ) Action:

Deletes all rows from the database configuration
list.

Group Member Synchronization Rules

• Only groups that have already been added into AgilePoint will be synchronized with the database. New
groups will be added automatically to AgilePoint when the group name starts with a Group prefix value. The
new groups will automatically be assigned to the default "Users" Role. If a group prefix value is empty, then
new groups can be added manually through the Enterprise Manager interface.

• The changes of user members (adding or removing) in the database will be synchronized to AgilePoint but
the changes in AgilePoint groups will NOT be synchronized back to the database.

• The synchronization only applies to member association (Add or Remove) within the groups.

• When a new member is added to the database, this member will also be added to the corresponding
AgilePoint group. If the actual user entity is not registered in AgilePoint yet, the user entity will be registered
to AgilePoint automatically.

• When a member is removed from the database, this member in the corresponding AgilePoint group will also
be removed. The actual user entity will NOT be removed from AgilePoint as the same user entity can also be
associated with other groups in the system.

User Synchronization Rules
Changes to the following database field properties will be synchronized to AgilePoint. Other properties will NOT
be synchronized.

• Full Name

• Email Address
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• Department

• Title

• Manager

Scheduling
The schedule of the synchronization is set through the module's configuration interface. The synchronization can
be performed at a particular time of day with the frequency of every day, every week, or every month.

For example, if you schedule the synchronization to be performed at 2am on Jan. 1 and you also select Every
day as the frequency, the synchronization will be started automatically at 2am on Jan 1, Jan 2, Jan 3, etc.

The following table summarizes the different ways that the schedule can be set for the synchronization.

Frequency Time 1st Sync 2nd Sync 3rd Sync 4th Sync 5th Sync

Every Day 2am Jan. 1 Jan. 2 Jan. 3 Jan. 4 Jan. 5

Every Week 2am Jan. 1 Jan. 8 Jan. 15 Jan. 22 Jan. 29

Every Month 2am Jan. 1 Feb. 1 March. 1 April. 1 May. 1

The synchronizations typically happen within five minutes of the scheduled time. For example, if the scheduled
time is 2am, the actual synchronization could happen between 1:55am to 2:05am.

Note:  The scheduling pattern (daily, weekly, or monthly) and scheduling time should be the same for
multiple AgileConnectors of the same type.

Exception Handling
This module also provides exception handling for the scheduling. In the event that your server is down during
the scheduled synchronization, as soon as your server is back online, the synchronization will be automatically
kicked off. After that, the next synchronization will resume the original schedule.

Log Files

Note:  The SharePoint Groups Synchronization module also writes log messages to the
SPSyncModule.log file. The SPSyncModule.log file can also be found at the AgilePointServer\log folder.
This log file contains detail information about each synchronization operation, such as the status of each
group, or what users were unable to be registered to AgilePoint.

The following is an example of the log message in the ActiveDirectorySynchronizer.log file:

3/1/2005 5:51:49 PM>> Synchronization has started
    to perform on 3/1/2005 5:51:47 PM
Synchronizing Users Registering user 'MYDOMAIN\Test1' to
    AgilePoint. User full name: Test1, department: Testing
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Notifications
In addition to log files that keep track of the synchronization statuses, the synchronization module also provides
email notification capability. Email notification is sent out to the AgilePoint System User with information about
the synchronization. This will allow the system user to determine if there is a need to manually synchronize the
groups or users in the event of failed synchronization.

Email Approval Extension
Using email approval, process participants can approve documents or requests through email, without accessing
their task lists. The MailApproval AgileConnector supports the following functionality:

• Approve or reject tasks using a simple email reply

• Multiple AgileConnector configurations

• Network load balancing

Requirements
One of the following:

• A POP3 mailbox configured with a valid account in the AgilePoint Server Configuration

• An IMAP4 mailbox configured with a valid account in the AgilePoint Server Configuration

• An Exchange Server mailbox with a valid account

Enabling the Email Approval AgileConnector
To enable the Email Approval AgileConnector, do the following.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

Procedure

1. On the Extensions tab, click Add.

2. In the Impersonator field, enter the AgilePoint user name that is used to connect to your email server.

By default, this is the AgilePoint Service Account.

3. Browse to the assembly [AgilePoint Server installation folder]\bin
\Ascentn.AgileConnector.MailApproval.dll, and then click OK to add this extension to AgilePoint Server.

Configuring the Email Approval AgileConnector
To configure the Email Approval AgileConnector, do the following.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
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Prerequisites

• Before you add the Email Approval AgileConnector, you must add the Event Service AgileConnector.

• Before you configure these settings, you must add the Email Approval AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select MailApproval.

4. Click Configure.

5. On the Configure Email Approval window, click the Settings tab.

Procedure

1. On the Settings tab, complete the following fields:

Field Name Definition

POP3 Server Definition:

Specifies the host name or IP address of the
POP3 server.

To access this field, select POP3.

Allowed Values:

• A valid host name or IP address for your
POP3 server.

Default Value:

None

Example:

Demo3

POP3 Port Definition:

Specifies the port number which is configured to
communicate with your POP3 server.

To access this field, select POP3.

Allowed Values:

• A valid port number.

Default Value:

110

SSL-Connection Definition:
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Field Name Definition

Specifies whether the POP3 server uses an SSL
encrypted connection.

To access this field, select POP3 or IMAP.

Allowed Values:

An appSettings key in the following format:

• Selected - SSL communication is enabled.

• Deselected - SSL communication is disabled.

Default Value:

Deselected

Microsoft Exchange Server URL Definition:

Specifies the Exchange Server URL.

To access this field, select the Microsoft
Exchange Server mode.

Allowed Values:

https://[host name]:[port]

Default Value:

None

Custom Attributes:

Yes

Example:

https://agilepoint.com:2030

IMAP4 Server Definition:

Specifies the host name or IP address of the
IMAP4 Server.

To access this field, select IMAP.

Allowed Values:

• A valid host name or IP address for your
IMAP4 Server.

Default Value:

None

Example:

Demo3

IMAP4 Port Definition:
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Field Name Definition

Specifies the port number that is configured for
communication with your IMAP4 server.

To access this field, select IMAP.

Allowed Values:

• A valid port number.

Default Value:

110

Exchange WebService URL Definition:

Specifies the Exchange WebService URL.

To access this field, select EWS or Office 365.

Allowed Values:

https://[ExchangeServerMachineName]:[Port]/
EWS/exchange.asmx

Default Value:

None

Custom Attributes:

Yes

Example:

https://agilepoint.com:2030/EWS/Exchange.asmx

Login Definition:

Specifies the username for the mailbox containing
the email-based approvals.

Allowed Values:

A valid username.

Default Value:

None

Password Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None
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Field Name Definition

Custom Attributes:

Yes

Schedule every Definition:

Specifies the time interval in minutes for the
AgileConnector to check the mailbox for new
incoming email.

Allowed Values:

Any integer.

Default Value:

1

Delete incorrect approval emails Definition:

Deletes all the emails from the mailbox once it is
read from the server.

Allowed Values:

• Selected - Deletes the emails from the
mailbox.

• Deselected - Does not delete the emails from
the mailbox.

Default Value:

Deselected

Basic Definition:

Saves the basic information about the Email
Approval AgileConnector in the AgilePoint Server
log file.

Allowed Values:

• Selected - Saves the basic information in the
AgilePoint Server log file.

• Deselected - Does not save the basic
information in the AgilePoint Server log file.

Default Value:

Selected

Debug Definition:

Saves the debug information about the email
approval AgileConnector in the AgilePoint Server
log file.
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Field Name Definition

Allowed Values:

• Selected - Saves the debugging information
in the AgilePoint Server log file.

• Deselected - Does not save the debugging
information in the AgilePoint Server log file.

Default Value:

Deselected

Test Action:

Verifies whether the specified account credential
is valid.

Configuring Automatic Replies for Email Approval Success or Failure
You can set up the Email Approval AgileConnector so that it will send a custom automated reply message when
an email approval succeeds or fails.

To set up automated approvals, do the following.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select MailApproval.

4. Click Configure.

5. On the Configure Email Approval window, click the Acknowledgement tab.

Instructions

1. On the Acknowledgement tab, complete the following fields as required for your environment.

Field Name Definition

Failed email approval reply message Definition:

Specifies the content the automated message sent
to participants when an email approval fails.

Allowed Values:

A text string that represents the body of the email.

Default Value:

A default email message body.

Successful email approval reply message Definition:
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Field Name Definition

Specifies the content the automated message
sent to participants when an email approval is
successful.

Replies for successful approvals are optional.

Allowed Values:

A text string that represents the body of the email.

To enable email replies for successful approvals,
the check box must be selected.

Default Value:

Deselected, with no default message.

Configure SharePoint Connectivity for the Email Approval AgileConnector
To configure the Email Approval AgileConnector so it can change values in SharePoint ListForm or InfoPath
processes, do the procedure in this topic.

Prerequisites

• If you use Forms Based Authentication, refer to this information from Microsoft to configure your SharePoint
environment: http://msdn.microsoft.com/en-us/library/bb975136%28v=office.12%29.aspx

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select MailApproval.

4. Click Configure.

5. On the Configure Email Approval screen, click the Connect to SharePoint tab.

Procedure

1. On the Connect to SharePoint tab, complete these fields as necessary for your environment .

Field Name Definition

Windows Authentication Definition:

Specifies if AgilePoint uses Windows Authentication
to connect to SharePoint.

Claims Authentication
Definition:

Specifies Claims authentication options for
SharePoint.

Allowed Values:

http://msdn.microsoft.com/en-us/library/bb975136%28v=office.12%29.aspx
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Field Name Definition

If this setting is selected, these types of Claims
Authentication are available:

• Form Based Authentication - Activates
Forms based authentication where a custom
membership provider to connect to an on-
premises SharePoint environment.

• Office 365 - Activates Claims authentication
to connect to SharePoint in an Office 365
environment. You can use this setting side-by-
side with on-premises SharePoint.

• Federated Authentication - Activates
Federated authentication to connect to
SharePoint — for example, ADFS.

Note:  Out of the box, AgilePoint
supports ADFS authentication. If you
want to use your own authentication
provider, see Federated Authentication
Example in the Documentation Library.

Default Value:

Deselected

Domain Definition:

The authentication domain.

This does not apply to Form Based Authentication.

Username The user ID of the SharePoint authentication account.

Password Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None

Custom Attributes:

Yes

Fed Auth Url Definition:

The URI of the federated authentication provider.
This provider supplies security tokens for federated
authentication.

Allowed Values:

http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
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Field Name Definition

A valid federated authentication provider URI.

Default Value:

None

Custom Attributes:

No

Example:

https://fs.agilityclouds.com

Logging
The MailApproval module writes log messages to the AgilePoint Server log file which can be found at
AgilePointServer\Log. The following is an example of a log message in the file:

8/12/2008 8:04:05 >>> AgileConnector MailApproval Started. 
Pop3 server, Server=110, Port=in.telenet.be, userName=xxxxxx 8/12/2008 
8:05:08 >>> TaskId: 65B82D87B3F34765B2DDE64791786961 8/12/2008 
8:05:08 >>> {Approval [X] = {/pd:myFields/pd:Approved}=True} 
8/12/2008 8:05:08 >>> {Remarks [This is a test] = 
{/pd:myFields/pd:Remark}} 8/12/2008 8:05:08 >>> Number of 
email based workitems received: 11

POP3 Limitations
The following limitations apply when using Email Approval on a POP3 server:

• There is no response while testing a connection if you deselect SSL-Connect when the POP3 Server
requires SSL.

• The incorrect emails will not be deleted from the mailbox even if the option Delete incorrect approval
emails is selected.

Creating an Email Template to Support Approvals
For information about creating an email template for direct approvals, see the Envision Online Help.

Email Approval Configuration Window - Settings Tab
Specifies the basic settings for the Email Approval AgileConnector.
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Prerequisites

• Before you add the Email Approval AgileConnector, you must add the Event Service AgileConnector.

• Before you configure these settings, you must add the Email Approval AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select MailApproval.

4. Click Configure.

5. On the Configure Email Approval window, click the Settings tab.
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Fields

Field Name Definition

POP3 Server Definition:

Specifies the host name or IP address of the POP3
server.

To access this field, select POP3.

Allowed Values:

• A valid host name or IP address for your POP3
server.

Default Value:

None

Example:

Demo3

POP3 Port Definition:

Specifies the port number which is configured to
communicate with your POP3 server.

To access this field, select POP3.

Allowed Values:

• A valid port number.

Default Value:

110

SSL-Connection Definition:

Specifies whether the POP3 server uses an SSL
encrypted connection.

To access this field, select POP3 or IMAP.

Allowed Values:

An appSettings key in the following format:

• Selected - SSL communication is enabled.

• Deselected - SSL communication is disabled.

Default Value:

Deselected

Microsoft Exchange Server URL Definition:

Specifies the Exchange Server URL.
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Field Name Definition

To access this field, select the Microsoft Exchange
Server mode.

Allowed Values:

https://[host name]:[port]

Default Value:

None

Custom Attributes:

Yes

Example:

https://agilepoint.com:2030

IMAP4 Server Definition:

Specifies the host name or IP address of the IMAP4
Server.

To access this field, select IMAP.

Allowed Values:

• A valid host name or IP address for your IMAP4
Server.

Default Value:

None

Example:

Demo3

IMAP4 Port Definition:

Specifies the port number that is configured for
communication with your IMAP4 server.

To access this field, select IMAP.

Allowed Values:

• A valid port number.

Default Value:

110

Exchange WebService URL Definition:

Specifies the Exchange WebService URL.

To access this field, select EWS or Office 365.

Allowed Values:
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Field Name Definition

https://[ExchangeServerMachineName]:[Port]/EWS/
exchange.asmx

Default Value:

None

Custom Attributes:

Yes

Example:

https://agilepoint.com:2030/EWS/Exchange.asmx

Login Definition:

Specifies the username for the mailbox containing
the email-based approvals.

Allowed Values:

A valid username.

Default Value:

None

Password Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None

Custom Attributes:

Yes

Schedule every Definition:

Specifies the time interval in minutes for the
AgileConnector to check the mailbox for new
incoming email.

Allowed Values:

Any integer.

Default Value:

1

Delete incorrect approval emails Definition:
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Field Name Definition

Deletes all the emails from the mailbox once it is
read from the server.

Allowed Values:

• Selected - Deletes the emails from the mailbox.

• Deselected - Does not delete the emails from
the mailbox.

Default Value:

Deselected

Basic Definition:

Saves the basic information about the Email
Approval AgileConnector in the AgilePoint Server
log file.

Allowed Values:

• Selected - Saves the basic information in the
AgilePoint Server log file.

• Deselected - Does not save the basic
information in the AgilePoint Server log file.

Default Value:

Selected

Debug Definition:

Saves the debug information about the email
approval AgileConnector in the AgilePoint Server
log file.

Allowed Values:

• Selected - Saves the debugging information in
the AgilePoint Server log file.

• Deselected - Does not save the debugging
information in the AgilePoint Server log file.

Default Value:

Deselected

Test Action:

Verifies whether the specified account credential is
valid.



AgilePoint Server Configuration Utility 65

AgilePoint BPMS v5.0 R2 SP1 AgilePoint Server Administrator's Guide r5.3.16

Email Approval Configuration Window - Acknowledgement Tab
Specifies the configuration of Email Approval AgileConnector for sending a custom automated reply message
when an email approval succeeds or fails.

Prerequisites

• Before you add the Email Approval AgileConnector, you must add the Event Service AgileConnector.

• Before you configure these settings, you must add the Email Approval AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.
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3. On the Extensions tab, select MailApproval.

4. Click Configure.

5. On the Configure Email Approval window, click the Acknowledgement tab.

Fields

Field Name Definition

Failed email approval reply message Definition:

Specifies the content the automated message sent
to participants when an email approval fails.

Allowed Values:

A text string that represents the body of the email.

Default Value:

A default email message body.

Successful email approval reply message Definition:

Specifies the content the automated message
sent to participants when an email approval is
successful.

Replies for successful approvals are optional.

Allowed Values:

A text string that represents the body of the email.

To enable email replies for successful approvals,
the check box must be selected.

Default Value:

Deselected, with no default message.

Configure Email Approval Screen - Connect to SharePoint Tab
Configures the Email Approval AgileConnector to change values in SharePoint ListForm or InfoPath processes.
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Prerequisites

• Before you add the Email Approval AgileConnector, you must add the Event Service AgileConnector.

• Before you configure these settings, you must add the Email Approval AgileConnector.

• If you use Forms Based Authentication, refer to this information from Microsoft to configure your SharePoint
environment: http://msdn.microsoft.com/en-us/library/bb975136%28v=office.12%29.aspx

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select MailApproval.

4. Click Configure.

5. On the Configure Email Approval screen, click the Connect to SharePoint tab.

http://msdn.microsoft.com/en-us/library/bb975136%28v=office.12%29.aspx
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Fields

Field Name Definition

Windows Authentication Definition:

Specifies if AgilePoint uses Windows Authentication
to connect to SharePoint.

Claims Authentication
Definition:

Specifies Claims authentication options for
SharePoint.

Allowed Values:

If this setting is selected, these types of Claims
Authentication are available:

• Form Based Authentication - Activates
Forms based authentication where a custom
membership provider to connect to an on-
premises SharePoint environment.

• Office 365 - Activates Claims authentication
to connect to SharePoint in an Office 365
environment. You can use this setting side-by-
side with on-premises SharePoint.

• Federated Authentication - Activates
Federated authentication to connect to
SharePoint — for example, ADFS.

Note:  Out of the box, AgilePoint
supports ADFS authentication. If you
want to use your own authentication
provider, see Federated Authentication
Example in the Documentation Library.

Default Value:

Deselected

Domain Definition:

The authentication domain.

This does not apply to Form Based Authentication.

Username Definition:

The user name for the SharePoint authentication
account.

Allowed Values:

A valid user name.

http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
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Field Name Definition

Default Value:

None

Custom Attributes:

No

Password Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None

Custom Attributes:

Yes

Fed Auth Url Definition:

The URI of the federated authentication provider.
This provider supplies security tokens for federated
authentication.

Allowed Values:

A valid federated authentication provider URI.

Default Value:

None

Custom Attributes:

No

Example:

https://fs.agilityclouds.com

Enterprise Social AgileConnector
The Enterprise Social AgileConnector facilitates communication with Yammer applications.

Prerequisites

• The user interface for this feature is available in English only.

• AgilePoint Server installed in Windows Service mode.
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Enabling the Enterprise Social AgileConnector
To enable the Enterprise Social AgileConnector, do the following.

Prerequisites

• The user interface for this feature is available in English only.

• AgilePoint Server installed in Windows Service mode.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

Procedure

1. On the Extensions tab, click Add.

2. In the Impersonator field, enter the AgilePoint user name that is used to connect to your email server.

By default, this is the AgilePoint Service Account.

3. Browse to the assembly [AgilePoint Server installation folder]\bin
\AgilePoint.AgileConnector.EnterpriseSocial.dll.

4. Click OK.

Configuring the Enterprise Social AgileConnector
To configure the Enterprise Social AgileConnector, do the following.

Prerequisites

• The user interface for this feature is available in English only.

• AgilePoint Server installed in Windows Service mode.

• Before configuring, you must enable the Enterprise Social Network AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select EnterpriseSocial.

4. Click Configure.

Procedure

1. On the Social Network Configuration Dialog window, complete the following fields as required.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
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Field Name Definition

Application Filter Definition:

Filters the process template based on the
application name.

The messaging service is enabled on the process
templates identified in this field.

Allowed Values:

One or more valid application names.

Multiple application names must be separated
with a semicolon (;).

Default Value:

None

Send task assignment notification Definition:

Specifies that the Enterprise Social Network
AgileConnector sends an notification to the
participants about the task assignment.

Allowed Values:

• Selected - Sends an notification to the
participants.

• Deselected - No notification is sent.

Default Value:

Selected

Retry
Definition:

Specifies the number of times you want to retry
an operation that failed due to a "Too Many
Requests" exception.

The error "429 (Too Many Requests)" occurs
if your Yammer application receives too many
requests within a specified time. For more
information, refer to http://developer.yammer.com/
restapi.

Allowed Values:

Any integer.

Default Value:

5

Delay In Retries
Definition:

http://developer.yammer.com/restapi
http://developer.yammer.com/restapi
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Field Name Definition

Specifies the number of seconds you want to
delay between retries after an operation fails due
to a "Too Many Requests" exception.

The error "429 (Too Many Requests)" occurs
if your Yammer application receives too many
requests within a specified time. For more
information, refer to http://developer.yammer.com/
restapi.

Allowed Values:

Any integer.

Default Value:

30

Thread Pool
Definition:

Specifies the maximum number of concurrent
connections between the AgilePoint Server and
Yammer.

Allowed Values:

Any integer.

Default Value:

1

Trace Mode
Definition:

Specifies whether the AgileConnector writes the
detail logging information into the log file.

Allowed Values:

• Selected - Indicates that the AgileConnector
writes the detail logging information into the
log file.

• Deselected - Indicates that the
AgileConnector does not write the detail
logging information into the log file.

Default Value:

Selected

Social Network Configuration Dialog
Specifies the configuration details for the Enterprise Social AgileConnector.

http://developer.yammer.com/restapi
http://developer.yammer.com/restapi
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Prerequisites

• The user interface for this feature is available in English only.

• AgilePoint Server installed in Windows Service mode.

• Before configuring, you must enable the Enterprise Social Network AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select EnterpriseSocial.

4. Click Configure.

Fields

Field Name Definition

Application Filter Definition:

Filters the process template based on the
application name.

The messaging service is enabled on the process
templates identified in this field.

Allowed Values:

One or more valid application names.
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Field Name Definition

Multiple application names must be separated with
a semicolon (;).

Default Value:

None

Send task assignment notification Definition:

Specifies that the Enterprise Social Network
AgileConnector sends an notification to the
participants about the task assignment.

Allowed Values:

• Selected - Sends an notification to the
participants.

• Deselected - No notification is sent.

Default Value:

Selected

Retry
Definition:

Specifies the number of times you want to retry an
operation that failed due to a "Too Many Requests"
exception.

The error "429 (Too Many Requests)" occurs if your
Yammer application receives too many requests
within a specified time. For more information, refer
to http://developer.yammer.com/restapi.

Allowed Values:

Any integer.

Default Value:

5

Delay In Retries
Definition:

Specifies the number of seconds you want to delay
between retries after an operation fails due to a
"Too Many Requests" exception.

The error "429 (Too Many Requests)" occurs if your
Yammer application receives too many requests
within a specified time. For more information, refer
to http://developer.yammer.com/restapi.

Allowed Values:

Any integer.

Default Value:

http://developer.yammer.com/restapi
http://developer.yammer.com/restapi
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Field Name Definition

30

Thread Pool
Definition:

Specifies the maximum number of concurrent
connections between the AgilePoint Server and
Yammer.

Allowed Values:

Any integer.

Default Value:

1

Trace Mode
Definition:

Specifies whether the AgileConnector writes the
detail logging information into the log file.

Allowed Values:

• Selected - Indicates that the AgileConnector
writes the detail logging information into the log
file.

• Deselected - Indicates that the AgileConnector
does not write the detail logging information into
the log file.

Default Value:

Selected

ContentListener AgileConnector
The Content Listener AgileConnector extension enables you to initiate processes on items in a SharePoint list
or library based on conditions you specify. The Content Listener AgileConnector runs a CAML query based on a
schedule you specify to evaluate the items in the SharePoint list and initiate the appropriate processes.

For example, you could initiate an escalation processes for all items in a SharePoint list that are designated high
priority or past due.

Enabling the ContentListener AgileConnector
To enable the AgilePoint Server extension:

1. Open the AgilePoint Server Configuration utility and go to the Extension window.

2. Click the Add button.

3. Click the Ellipses button on the Extension window and add the following assembly:

…\AgilePointServer\bin\Ascentn.AgileConnector.ContentListener.dll
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Note:  The Name field will be auto-populated, DO NOT change it. Leave the Impersonator field
blank.

Configuring the ContentListener AgileConnector
Once you have added the ContentListener AgileConnector

Prerequisites

1. Enable the ContentListener AgileConnector.

For more information, refer to Enabling the ContentListener AgileConnector in the Documentation Library.

How to Start

1. On the AgilePoint Server Configuration Utility, click the Extension Tab.

Procedure

1. On the Extension tab, select ContentListener.

2. Click Configure.

3. On the SharePoint Content Listener Connector Configuration window, complete the fields as described
in this topic.

Fields

Field Name Definition

Add Task Creates a new task.

Delete Task Removes an existing task.

SharePoint Access Credentials The credentials you wan to use to authenticate to
SharePoint.

• AgilePoint System Account - The standard
AgilePoint system account

• Custom Account - Credentials for an account
you specify in the Domain, User, and Password
fields.

Schedule Name A free text name for the schedule.

Site The URL of the SharePoint site associated with the
process.

List The SharePoint list associated with the process.

Process The process model to use for the initiated process.

CAML Query Specifies the CAML query used to initiate the process.

http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
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Field Name Definition

You can type or paste a CAML query in the box, or
click the Ellipses button to open the CAML Query
Configuration window.

For more information, refer to CAML Query Builder
Configuration Window - List and View Fields Tab.

Recurrence Specifies the schedule to run the CAML query.
Options are:

• One Time - The schedule occurs only one time.

• By Minute - The schedule occurs once every
specified number of minutes.

• By Day - Recurs at the specified time on the
specified interval of days.

• By Week - Recurs at the specified time on the
specified days.

• By Month - Recurs at the specified time on the
specified days of the specified months.

DataService AgileConnector
This AgilePoint Server extension (AgileConnector) allows you to enable application data services to collect and
track application data. The Data Services includes two core components:

• Data Population

• Data Tracking

Data Population allows you to write to a database the desired application data values. The data can then be
used for reporting purposes. The configuration is done via AgilePoint Envision. For more information, refer to
Data Services in the Documentation Library.

Data Tracking provides the functionality to set up fields in AgilePoint Envision to be monitored for changes to
application data, for example you can see for a specific field on a form, the "Old Value" and if the data changes,
the "New Value". This viewpoint is provided via the AgilePoint Enterprise Manager Data Tracking tab.

Enabling the DataService AgileConnector
To enable the DataService AgileConnector, do the following.

Good to Know

• To support multiple applications, you can configure multiple AgileConnectors, or list multiple applications
within the Application Filter of one AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#agileshapeListAndViewFieldsWin.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#agileshapeListAndViewFieldsWin.html
http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
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Procedure

1. On the Extensions tab, click Add.

2. Click the Ellipses button next to the Assembly field to browse the assembly [AgilePoint Server
installation folder] \bin\Ascentn.AgileConnector.DataService.dll.

Note the following:

• The Name field appears with the default AgileConnector name. Do not change this value.

• The Impersonator field must be blank.

3. Click Configure.

4. On the Data Service Configuration window, complete the following fields as required.

Field Name Definition

Application Filter Definition:

Filters the process template based on the process
model type or name.

Allowed Values:

• SPSIntegration - Uses only process models
created using InfoPath, SPList and SPDoc
process templates.

• AgileForms - Uses only process models
created using AgileForms process templates.

• MyApplication - Uses only process models
created using Generic process templates —
usually ASP.NET applications.

• Custom application name - Uses only
process models with a custom application
name specified in the process template.

Multiple application names must be separated
with a semicolon (;).

Default Value:

MyApplication

Connection String Definition:

Specifies the connection string to be used to
connect to the Data Tracking database.

Allowed Values:

A valid connection string.

Default Value:

Data Source=.;Integrated Security=SSPI;Initial
Catalog=AgilePointTracking

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
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Field Name Definition

Example:

Data Source=mydomain;Integrated
Security=SSPI;Initial Catalog=AgilePointTracking

EventService AgileConnector
This AgilePoint Server extension (AgileConnector) allows you to initiate processes automatically via scheduling,
email, database, or file dropping.  

Enabling the EventService AgileConnector
To enable the AgilePoint Server extension:

1. Open the AgilePoint Server Configuration utility and go to the Extension window.

2. On the Extension window, click Add.

3. Click the Ellipses button on the Extension window and add the following assembly:

…\AgilePointServer\bin\Ascentn.AgileConnector.EventService.dll

Note:  The Name field will be auto-populated, DO NOT change it. Leave the Impersonator field
blank.

After registering the EventService AgileConnector, you can check the AgilePoint Server log file for verification.
If you see the two lines as shown below in the log file, this means that the EventService AgileConnector
configuration is correct.

2/23/2009 2:23:14 PM >>> 
        EventServiceManager EventService Started.
2/23/2009 2:23:14 PM >>> EventServiceManager, 
        Event count: [number of event]

Lync Approval AgileConnector
The Lync Approval AgileConnector enables you to receive messages via Lync that can affect your process data.
A common use for this functionality is approvals.

• AgilePoint Server installed in Windows Service mode.

Enabling the Lync Approval AgileConnector
To enable the Lync Approval AgileConnector, do the following.

Prerequisites

• AgilePoint Server installed in Windows Service mode.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.
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2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

Procedure

1. On the Extensions tab, click Add.

2. In the Impersonator field, enter the AgilePoint user name that is used to connect to your email server.

By default, this is the AgilePoint Service Account.

3. Browse to the assembly [AgilePoint Server installation folder]\bin
\AgilePoint.LyncApproval.AgileConnector.dll.

4. Click OK.

Configuring the Lync Approval AgileConnector
To configure the Lync Approval AgileConnector, do the following.

Prerequisites

• AgilePoint Server installed in Windows Service mode.

• Before you configure these settings, you must add the Lync Approval AgileConnector.

For more information, refer to Enabling the Lync Approval AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select LyncApproval.

4. Click Configure.

5. On the Lync Approval screen, click the Lync Settings tab.

Procedure

1. On the Configure Lync Approval AgileConnector screen, complete the following fields as required.

Field Name Definition

Application Filter Definition:

Filters the process template based on the
application name.

The messaging service is enabled on the process
templates identified in this field.

Allowed Values:

One or more valid application names.

Multiple application names must be separated
with a semicolon (;).

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#serverEnableExtensionAdSync.html
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Field Name Definition

Default Value:

None

Lync Sign-In Address Definition:

Specifies the email address for the Lync account.

Allowed Values:

A valid email address.

Default Value:

None

Lync Sign-In Domain Definition:

Specifies the domain name for the Lync account
used by AgilePoint Server.

Allowed Values:

A valid domain name.

Default Value:

None

Password Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None

Send Task Assignment Notifications to Lync Definition:

Specifies that the Lync Approval AgileConnector
sends the task assignment notification to the
participants via Lync.

Allowed Values:

• Selected - Sends a task assignment
notification via Lync.

• Deselected - No task assignment notification
is sent.

Default Value:

Deselected
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Configuring SharePoint Connectivity for the Lync Approval
AgileConnector
To configure the Lync Approval AgileConnector so it can change values in SharePoint ListForm or InfoPath
processes, do the procedure in this topic.

Prerequisites

• AgilePoint Server installed in Windows Service mode.

• Before you configure these settings, you must add the Lync Approval AgileConnector.

For more information, refer to Enabling the Lync Approval AgileConnector.

• If you use Forms Based Authentication, refer to this information from Microsoft to configure your SharePoint
environment: http://msdn.microsoft.com/en-us/library/bb975136%28v=office.12%29.aspx

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select LyncApproval.

4. Click Configure.

5. On the Lync Approval screen, click the Connect to SharePoint tab.

Procedure

1. On the Connect to SharePoint tab, complete these fields as necessary for your environment .

Field Name Definition

Windows Authentication Definition:

Specifies if AgilePoint uses Windows Authentication
to connect to SharePoint.

Claims Authentication
Definition:

Specifies Claims authentication options for
SharePoint.

Allowed Values:

If this setting is selected, these types of Claims
Authentication are available:

• Form Based Authentication - Activates
Forms based authentication where a custom
membership provider to connect to an on-
premises SharePoint environment.

• Office 365 - Activates Claims authentication
to connect to SharePoint in an Office 365

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#serverEnableExtensionAdSync.html
http://msdn.microsoft.com/en-us/library/bb975136%28v=office.12%29.aspx
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Field Name Definition

environment. You can use this setting side-by-
side with on-premises SharePoint.

• Federated Authentication - Activates
Federated authentication to connect to
SharePoint — for example, ADFS.

Note:  Out of the box, AgilePoint
supports ADFS authentication. If you
want to use your own authentication
provider, see Federated Authentication
Example in the Documentation Library.

Default Value:

Deselected

Domain Definition:

The authentication domain.

This does not apply to Form Based Authentication.

Username Definition:

The user name for the SharePoint authentication
account.

Allowed Values:

A valid user name.

Default Value:

None

Custom Attributes:

No

Password Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None

Custom Attributes:

Yes

Fed Auth Url Definition:

http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
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Field Name Definition

The URI of the federated authentication provider.
This provider supplies security tokens for federated
authentication.

Allowed Values:

A valid federated authentication provider URI.

Default Value:

None

Custom Attributes:

No

Example:

https://fs.agilityclouds.com

Lync Approval AgileConnector Configuration Window - Lync Settings Tab
Specifies the configuration options for the Lync Approval AgileConnector.

Prerequisites

• AgilePoint Server installed in Windows Service mode.

• Before you configure these settings, you must add the Lync Approval AgileConnector.

For more information, refer to Enabling the Lync Approval AgileConnector.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#serverEnableExtensionAdSync.html
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How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select LyncApproval.

4. Click Configure.

5. On the Lync Approval screen, click the Lync Settings tab.

Fields

Field Name Definition

Application Filter Definition:

Filters the process template based on the
application name.

The messaging service is enabled on the process
templates identified in this field.

Allowed Values:

One or more valid application names.

Multiple application names must be separated with
a semicolon (;).

Default Value:

None

Lync Sign-In Address Definition:

Specifies the email address for the Lync account.

Allowed Values:

A valid email address.

Default Value:

None

Lync Sign-In Domain Definition:

Specifies the domain name for the Lync account
used by AgilePoint Server.

Allowed Values:

A valid domain name.

Default Value:

None
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Field Name Definition

Password Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None

Send Task Assignment Notifications to Lync Definition:

Specifies that the Lync Approval AgileConnector
sends the task assignment notification to the
participants via Lync.

Allowed Values:

• Selected - Sends a task assignment notification
via Lync.

• Deselected - No task assignment notification is
sent.

Default Value:

Deselected

Lync Approval AgileConnector Configuration Window - Connect to
SharePoint Tab
Configures the Lync Approval AgileConnector to change values in SharePoint ListForm or InfoPath processes.
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Prerequisites

• AgilePoint Server installed in Windows Service mode.

• Before you configure these settings, you must add the Lync Approval AgileConnector.

For more information, refer to Enabling the Lync Approval AgileConnector.

• If you use Forms Based Authentication, refer to this information from Microsoft to configure your SharePoint
environment: http://msdn.microsoft.com/en-us/library/bb975136%28v=office.12%29.aspx

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select LyncApproval.

4. Click Configure.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#serverEnableExtensionAdSync.html
http://msdn.microsoft.com/en-us/library/bb975136%28v=office.12%29.aspx
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5. On the Lync Approval screen, click the Connect to SharePoint tab.

Fields

Field Name Definition

Windows Authentication Definition:

Specifies if AgilePoint uses Windows Authentication
to connect to SharePoint.

Claims Authentication
Definition:

Specifies Claims authentication options for
SharePoint.

Allowed Values:

If this setting is selected, these types of Claims
Authentication are available:

• Form Based Authentication - Activates
Forms based authentication where a custom
membership provider to connect to an on-
premises SharePoint environment.

• Office 365 - Activates Claims authentication
to connect to SharePoint in an Office 365
environment. You can use this setting side-by-
side with on-premises SharePoint.

• Federated Authentication - Activates
Federated authentication to connect to
SharePoint — for example, ADFS.

Note:  Out of the box, AgilePoint
supports ADFS authentication. If you
want to use your own authentication
provider, see Federated Authentication
Example in the Documentation Library.

Default Value:

Deselected

Domain Definition:

The authentication domain.

This does not apply to Form Based Authentication.

Username Definition:

The user name for the SharePoint authentication
account.

Allowed Values:

A valid user name.

http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
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Field Name Definition

Default Value:

None

Custom Attributes:

No

Password Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None

Custom Attributes:

Yes

Fed Auth Url Definition:

The URI of the federated authentication provider.
This provider supplies security tokens for federated
authentication.

Allowed Values:

A valid federated authentication provider URI.

Default Value:

None

Custom Attributes:

No

Example:

https://fs.agilityclouds.com

MSMQ AgileConnector
This AgilePoint Server extension (AgileConnector) allows you to run Microsoft Message Queuing.

Enabling the MSMQ AgileConnector
To enable the AgilePoint Server extension:

1. Open the AgilePoint Server Configuration utility and go to the Extension window.

2. Click the Add button.



AgilePoint Server Configuration Utility 90

AgilePoint BPMS v5.0 R2 SP1 AgilePoint Server Administrator's Guide r5.3.16

3. Click the Ellipses button on the Extension window and add the following assembly:

…\AgilePointServer\bin\Ascentn.AgileConnector.MSMQ.dll

Note:  The Name field will be auto-populated, DO NOT change it. Leave the Impersonator field
blank.

4. Click OK.

5. Click the Configure button and specify the desired configuration settings.

MSWFRuntime AgileConnector
This AgilePoint Server extension (AgileConnector) allows you to enable AgilePoint Server to host and execute
Microsoft Windows Workflow Foundation activities at run time. AgilePoint provides the Sequential Workflow
AgilePart that can be initiated from an AgilePoint process as a sub-process to facilitate the data-exchange
between AgilePoint and Windows Workflow Foundation. The Sequential Workflow AgilePart can be customized
by leveraging this AgileConnector for Windows Workflow Foundation.

Note:  This AgileConnector requires the .NET Framework 3.0 or later.

This AgileConnector is implemented as a class named Ascentn.AgileConnector.MSWFRuntime in
the Ascentn.AgileConnector.MSWFRuntime assembly. The assembly is located by default in the ...
\AgilePointServer\bin\ folder under your AgilePoint Server installation location.

Once you have enabled and configured the AgileConnector from the AgilePoint Server Configuration utility's
Extensions window (as shown below), then you can create AgilePoint workflow applications that execute
Windows Workflow Foundation activities and workflow applications. 

Enabling the MSWFRuntime AgileConnector
To enable the AgilePoint Server extension:

1. Open the AgilePoint Server Configuration utility and go to the Extension window.

2. Click the Add button.

3. Ensure the database is configured properly.

4. Click the Ellipses button on the Extension window and add the following assembly:

…\AgilePointServer\bin\Ascentn.AgileConnector.MSWFRuntime.dll

Note:  The Name field will be auto-populated, DO NOT change it. Leave the Impersonator field
blank.

5. Click OK.

6. Click the Configure button and specify the desired configuration settings. It prompts the following window for
the Windows Workflow Foundation persistence and tracking database configuration.

This step requires DBA privileges for creating tables and stored procedures. Also, the following SQL files are
used:

• SqlPersistenceService_Logic.sql

• SqlPersistenceService_Schema.sql

• Tracking_Logic.sql
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• Tracking_Schema.sql

These files can be found in the AgilePoint Server folder at ...\AgilePoint Server\Components\Workflow
Foundation.

The Database Server needs to be same as AgilePoint Server, but the Database can be different.

7. Once finished with the configuration, click OK.

RemotingService AgileConnector
This AgilePoint Server extension (AgileConnector) allows you to enable and configure AgilePoint
Server to use Remoting to interact with AgilePoint Server. This extension opens up a port that
can be used to connect (via Remoting) to the AgilePoint Server Process Engine and API. This
AgileConnector is implemented as a class named Ascentn.Workflow.Extension.RemotingService in the
Ascentn.AgileConnector.RemotingService.dll assembly. The assembly is located by default in the ...
\AgilePointServer\bin\ folder under your AgilePoint Server installation location.

Once you have enabled and configured the AgileConnector from the AgilePoint Server Configuration utility's
Extensions window (as shown below), then you can create client applications that use Remoting to interact with
AgilePoint Server. 

Enabling the RemotingService AgileConnector
To enable the AgilePoint Server extension:

1. Open the AgilePoint Server Configuration utility and go to the Extension window.

2. Click the Add button.

3. Click the Ellipses button on the Extension window and add the following assembly:

…\AgilePointServer\bin\Ascentn.AgileConnector.RemotingService.dll

Note:  The Name field will be auto-populated, DO NOT change it. Leave the Impersonator field
blank.

4. Click OK.

5. Click the Configure button and specify the desired configuration settings.

6. Click OK.

SAP Integration AgileConnector
This AgilePoint Server extension (AgileConnector) enables you to run the SAP Integration component of the
AgilePoint BPMS Suite.

Prerequisites

• The standard SAP AgileConnector requires a .NET 3.5 environment. For .NET 4.0 environments, you must
use a custom web service to connect to the ERPLink SAP connector installed on a .NET 3.5 machine. For
more information, contact AgilePoint Professional Services.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#ContactingAgilePoint.html
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Enabling the SAP AgileConnector
To configure the SAP AgileConnector, do the following.

Prerequisites

• The standard SAP AgileConnector requires a .NET 3.5 environment. For .NET 4.0 environments, you must
use a custom web service to connect to the ERPLink SAP connector installed on a .NET 3.5 machine. For
more information, contact AgilePoint Professional Services.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

Procedure

1. On the Extensions tab, click Add.

2. Browse to the assembly [AgilePoint Server installation folder]\bin
\Ascentn.AgileConnector.SAPIntegration.dll, and then click OK to add this extension to AgilePoint
Server.

Configuring the SAP AgileConnector
To configure the SAP AgileConnector, do the following.

Prerequisites

• The standard SAP AgileConnector requires a .NET 3.5 environment. For .NET 4.0 environments, you must
use a custom web service to connect to the ERPLink SAP connector installed on a .NET 3.5 machine. For
more information, contact AgilePoint Professional Services.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

Procedure

1. On the Extensions tab, select the SAPIntegration AgileConnector.

2. Click the Configure button.

3. In the configuration window for the SAP Integration AgileConnector, configure the following fields as
required.

Field Name Definition

Max Threads for SAP Integration Definition:

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#ContactingAgilePoint.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#ContactingAgilePoint.html
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Field Name Definition

Specifies the maximum number of concurrent
connections between AgilePoint Server and SAP.

Allowed Values:

Any integer.

Default Value:

5

Send Notification for Suspended Processes Definition:

Specifies whether the SAP Integration
AgileConnector sends a notification to the
AgilePoint system administrator if a process
instances is suspended as a result of an SAP
integration error.

Allowed Values:

• Deselected - No email notification is sent.

• Selected - Sends an email notification if a
process instance is suspended.

Default Value:

Deselected

Configuring the AgilePoint SharePoint Integration
AgileConnector
This AgilePoint Server extension (AgileConnector) allows for the communication between AgilePoint Server and
SharePoint. This extension is only applicable for the AgilePoint SharePoint Integration v2.

Prerequisites

• AgilePoint Server is installed.

• The credentials for the SharePoint Impersonator account.

The SharePoint Impersonator account is determined during pre-installation. For more information, refer to
Creating a SharePoint Impersonator User Account in the Documentation Library.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

Procedure

1. On the Extension tab, click on Add.

2. Browse one of the following locations to open the file Ascentn.SharePoint.AgileConnector.dll:

http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
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• For IIS installations, this file is located in the bin folder under the AgilePoint Server installation folder.

• For Windows Service installations, this file is located in the bin folder under the path provided in the
Location field in Windows Server Manager for the Windows Service instance you want to configure.

3. Change the Name from AgileConnector to SPSIntegration.

4. Enter the Impersonator (e.g. Administrator).

5. Click OK.

6. Optionally, you can click Configure to set the maximum thread for SharePoint access and to set the
credential for SharePoint access. By default it will use the AgilePoint System User Account credential.

7. When you have finished the configuration, on the AgilePoint Configuration window, click OK.

Accept any informational messages.

If you are prompted to restart IIS or the AgilePoint Service, click Yes.

Configuring the SharePoint Integration AgileConnector
To configure the SPSIntegration extension, do the following.

Prerequisites

• If you use Forms Based Authentication, refer to this information from Microsoft to configure your SharePoint
environment: http://msdn.microsoft.com/en-us/library/bb975136%28v=office.12%29.aspx

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select SPSIntegration.

4. Click Configure.

Instructions

1. On the AgileConnector for SharePoint window, configure the following fields as required for your
environment, and then click OK.

Field Name Definition

Max Threads for SharePoint Access Definition:

Specifies the maximum number of concurrent
connections between AgilePoint Server and
SharePoint.

Allowed Values:

Any integer.

Default Value:

10

http://msdn.microsoft.com/en-us/library/bb975136%28v=office.12%29.aspx
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Field Name Definition

Windows Authentication Definition:

Specifies if AgilePoint uses Windows Authentication
to connect to SharePoint.

Claims Authentication
Definition:

Specifies Claims authentication options for
SharePoint.

Allowed Values:

If this setting is selected, these types of Claims
Authentication are available:

• Form Based Authentication - Activates
Forms based authentication where a custom
membership provider to connect to an on-
premises SharePoint environment.

• Office 365 - Activates Claims authentication
to connect to SharePoint in an Office 365
environment. You can use this setting side-by-
side with on-premises SharePoint.

• Federated Authentication - Activates
Federated authentication to connect to
SharePoint — for example, ADFS.

Note:  Out of the box, AgilePoint
supports ADFS authentication. If you
want to use your own authentication
provider, see Federated Authentication
Example in the Documentation Library.

Default Value:

Deselected

Domain Definition:

The authentication domain.

This does not apply to Form Based Authentication.

Username The user ID of the SharePoint authentication account.

Password Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None

http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
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Field Name Definition

Custom Attributes:

Yes

Fed Auth Url Definition:

The URI of the federated authentication provider.
This provider supplies security tokens for federated
authentication.

Allowed Values:

A valid federated authentication provider URI.

Default Value:

None

Custom Attributes:

No

Example:

https://fs.agilityclouds.com

Use UTF8 Encoding Definition:

Specifies whether to use UTF-8 encoding when
communicating with the external system.

Allowed Values:

• Selected - Specifies to use UTF-8 encoding.

• Deselected - Specifies not to use UTF-8
encoding.

Default Value:

Deselected

Send Notification for Suspended Processes Definition:

Specifies whether the SPSIntegration
AgileConnector sends a notification to the
AgilePoint system administrator if a process
instances is suspended as a result of a SharePoint
Integration error.

Allowed Values:

• Deselected - No email notification is sent.

• Selected - Sends an email notification if a
process instance is suspended.

Default Value:

Deselected
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SMS Service and Approval AgileConnector
The SMS AgileConnector enables you to send messages from a process via SMS. Optionally, you can use a
third-party SMS listening service in order to receive SMS messages for responses such as approvals.

• AgilePoint Server installed in Windows Service mode.

• If you want to use StrikeIron SMS listener functionality, you must set up an account with StrikeIron. This is a
paid account.

To register an account, visit  www.strikeiron.com.

• If you want to use a different SMS listener vendor, contact AgilePoint Professional Services to request a new
AgileConnector.

Enabling the SMS Service and Approval AgileConnector
To enable the SMS Service and Approval AgileConnector, do the following.

Prerequisites

• AgilePoint Server installed in Windows Service mode.

• If you want to use StrikeIron SMS listener functionality, you must set up an account with StrikeIron. This is a
paid account.

To register an account, visit  www.strikeiron.com.

• If you want to use a different SMS listener vendor, contact AgilePoint Professional Services to request a new
AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

Procedure

1. On the Extensions tab, click Add.

2. In the Impersonator field, enter the AgilePoint user name that is used to connect to your email server.

By default, this is the AgilePoint Service Account.

3. Browse to the assembly [AgilePoint Server installation folder]\bin
\AgilePoint.AgileConnector.SMSService.dll.

4. Click OK.

Configuring the SMS Service and Approval AgileConnector
The Configuring the SMS Service and Approval AgileConnector supports two types of actions using SMS:

• Sending notifications based on events - SMS notifications are set up in the AgileWorks within a process
model. Sending SMS notifications does not require a listener service account.

http://www.strikeiron.com/
http://www.strikeiron.com/
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html


AgilePoint Server Configuration Utility 98

AgilePoint BPMS v5.0 R2 SP1 AgilePoint Server Administrator's Guide r5.3.16

• Listening for incoming responses for process input - This is typically used for simple responses such as
approve/reject. This requires a listener service account.

To configure the SMS Service and Approval AgileConnector, do the following.

Prerequisites

• AgilePoint Server installed in Windows Service mode.

• If you want to use StrikeIron SMS listener functionality, you must set up an account with StrikeIron. This is a
paid account.

To register an account, visit  www.strikeiron.com.

• If you want to use a different SMS listener vendor, contact AgilePoint Professional Services to request a new
AgileConnector.

• Before configuring, you must enable the SMS Service and Approval AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select SMSService.

4. Click Configure.

Procedure

1. If you want to filter out process models that will not use SMS messaging, complete the following field.

Field Name Definition

Application Filter Definition:

Filters the process template based on the
application name.

The messaging service is enabled on the process
templates identified in this field.

Allowed Values:

One or more valid application names.

Multiple application names must be separated
with a semicolon (;).

Default Value:

None

2. To set the "from" name participants see in their SMS notifications, complete the following field:

Field Name Definition

From Name in SMS Text Definition:

http://www.strikeiron.com/
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Field Name Definition

Specifies the name displayed in an SMS text
message.

Allowed Values:

A single line of text.

Default Value:

None.

3. If you want users to receive notifications when tasks are assigned, select Send Notification to Users about
Task Assignment.

4. If you want AgilePoint to listen to incoming SMS messages to support SMS responses, do the following:

a. On the Configure SMS Service AgileConnector window, enter the user name and password for your
SMS.

Field Name Definition

User ID Definition:

Specifies the user name of the StrikeIron
service account.

Allowed Values:

A valid user name.

Default Value:

None

Custom Attributes:

No

Password Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None

Schedule Interval Definition:

Specifies the number of minutes for the
AgileConnector to wait before checking whether
the task has been approved.

Allowed Values:

Any integer.
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Field Name Definition

Default Value:

1

SMS Service Provider Definition:

Specifies the name of the service provider.

Allowed Values:

A valid service provider name that appears in
the list.

If you want to use a different SMS listener
vendor, contact AgilePoint Professional
Services to request a new AgileConnector.

Default Value:

StrikeIron.

b. To test whether the SMS listener account is valid, click Test.

SMS Service and Approval AgileConnector Configuration Window
Specifies the configuration details of the SMS Service and Approval AgileConnector.
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Prerequisites

• AgilePoint Server installed in Windows Service mode.

• If you want to use StrikeIron SMS listener functionality, you must set up an account with StrikeIron. This is a
paid account.

To register an account, visit  www.strikeiron.com.

• If you want to use a different SMS listener vendor, contact AgilePoint Professional Services to request a new
AgileConnector.

• Before configuring, you must enable the SMS Service and Approval AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select SMSService.

4. Click Configure.

Fields

Field Name Definition

Application Filter Definition:

Filters the process template based on the
application name.

The messaging service is enabled on the process
templates identified in this field.

Allowed Values:

One or more valid application names.

Multiple application names must be separated with
a semicolon (;).

Default Value:

None

User ID Definition:

Specifies the user name of the StrikeIron service
account.

Allowed Values:

A valid user name.

Default Value:

None

http://www.strikeiron.com/
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Field Name Definition

Custom Attributes:

No

Password Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None

From Name in SMS Text Definition:

Specifies the name displayed in an SMS text
message.

Allowed Values:

A single line of text.

Default Value:

None.

Schedule Interval Definition:

Specifies the number of minutes for the
AgileConnector to wait before checking whether the
task has been approved.

Allowed Values:

Any integer.

Default Value:

1

SMS Service Provider Definition:

Specifies the name of the service provider.

Allowed Values:

A valid service provider name that appears in the
list.

If you want to use a different SMS listener vendor,
contact AgilePoint Professional Services to request
a new AgileConnector.

Default Value:

StrikeIron.
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Field Name Definition

Send SMS Notification to Users about Task
Assignment

Definition:

Specifies that the SMS Service AgileConnector
sends an SMS notification to the participants about
the task assignments.

Allowed Values:

• Selected - Sends an SMS notification to the
participants.

• Deselected - No SMS notification is sent.

Default Value:

Deselected

Test Action:

Verifies whether the specified account credential is
valid.

Configuring the SPSyncModule Extension
This AgilePoint Server extension (AgileConnector) allows you to synchronize SharePoint site collection groups
with AgilePoint groups automatically.

This extension is optional.

Prerequisites

• The AgilePoint System User (as defined in the AgilePoint Server Configuration utility) should be a
SharePoint user.

• AgilePoint Server's Application Pool's Identity user account (as configured in IIS) needs to have read
permissions to the SharePoint data.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

Procedure

1. On the Extension tab, click on Add.

2. Browse one of the following locations to open the file SPSyncModule.dll:

• For IIS installations, this file is located in the bin folder under the AgilePoint Server installation folder.

• For Windows Service installations, this file is located in the bin folder under the path provided in the
Location field in Windows Server Manager for the Windows Service instance you want to configure.

3. Leave the Impersonator field blank.

4. Click OK.
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Now you will need to configure the module to schedule the synchronization.

5. Click the Configure button, and specify the desired configuration settings.

In the configuration interface, you can specify the SharePoint site for which you want to synchronize
the groups; you can also optionally provide the site prefix and group prefix. You can also specify the
synchronization with the frequency of every day, week, or month and at a particular time of day starting with
the day you set the schedule. The synchronization module also provides the option of registering the users
automatically or sending an alert email to AgilePoint system user if there are members in the SharePoint
groups that have yet to be registered in AgilePoint.

6. Provide a valid SharePoint Site URL, for example http://[hostname]:[port]/sites/MySite.

7. The Site Prefix field is optional.

In a case where two site collections are configured, then groups with a common name can be
distinguished using this property. For example Site "A" has a group called "Employees" and Site "B"
also has a group called "Employees". In AgilePoint, you can create two groups "SiteA_Employees"
corresponding to Employees group in site A and "SiteB_Employees" corresponding to siteB's Employees.
So while configuring Site A mention "SiteA_" in site prefix so that it will sync with "SiteA_Employees"
during the synchronization process and for site B mention "SiteB_" in site prefix so that it sync's with
"SiteB_Employees".

8. The "Group Prefix" field is optional.

This property is used in case a new group is created in SharePoint and you want that group to be created
in AgilePoint. If a group prefix is not empty, then all the groups created in SharePoint starting with a Group
prefix value will be created in AgilePoint during the Synchronization process. For example, the group prefix
value is set as "GR_" then all the new groups in SharePoint starting with GR_ will be created and synced
during the synchronization process.

9. The Schedule section is used to schedule the frequency of synchronization.

You can configure Synchronization frequency to sync daily (Every Day) at a particular time, or Weekly
(Every Week), or Monthly (Every Month).

10. The Option section provides an option to select what action needs to be taken when a SharePoint group
member is not an AgilePoint user. Either one can select to register user to AgilePoint automatically or send a
notification to AgilePoint System user. 

Group Member Synchronization Rules

• Only groups that have already been added into AgilePoint will be synchronized with SharePoint. New
SharePoint groups will be added automatically to AgilePoint only if the group prefix value is not empty
and the new SharePoint group name starts with a Group prefix value. The new groups will automatically
be assigned to the default "Users" Role. If a group prefix value is empty, then new groups can be added
manually through the Enterprise Manager interface.

• The changes of user members (adding or removing) in the SharePoint groups will be synchronized to
AgilePoint but the changes in AgilePoint groups will NOT be synchronized back to the SharePoint groups.

• The synchronization only applies to member association (Add or Remove) within the groups. Group
properties such as names and descriptions are NOT synchronized.

• When a new member is added to SharePoint group, this member will also be added to the corresponding
AgilePoint group. If the actual user entity is not registered in AgilePoint yet, the user entity will be registered
to AgilePoint automatically.
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• When a member is removed from SharePoint group, this member in the corresponding AgilePoint group will
also be removed. The actual user entity will NOT be removed from AgilePoint as the same user entity can
also be associated with other groups in the system.

User Synchronization Rules
Changes to the following SharePoint User properties will be synchronized to AgilePoint. Other properties will
NOT be synchronized.

• Full Name

• Email Address

• Department

• Title

• Manager

Scheduling
The schedule of the synchronization is set through the module's configuration interface. The synchronization can
be performed at a particular time of day with the frequency of every day, every week, or every month.

For example, if you schedule the synchronization to be performed at 2am on Jan. 1 and you also select Every
day as the frequency, the synchronization will be started automatically at 2am on Jan 1, Jan 2, Jan 3, etc.

The following table summarizes the different ways that the schedule can be set for the synchronization.

Frequency Time 1st Sync 2nd Sync 3rd Sync 4th Sync 5th Sync

Every Day 2am Jan. 1 Jan. 2 Jan. 3 Jan. 4 Jan. 5

Every Week 2am Jan. 1 Jan. 8 Jan. 15 Jan. 22 Jan. 29

Every Month 2am Jan. 1 Feb. 1 March. 1 April. 1 May. 1

The synchronizations typically happen within five minutes of the scheduled time. For example, if the scheduled
time is 2am, the actual synchronization could happen between 1:55am to 2:05am.

Note:  The scheduling pattern (daily, weekly, or monthly) and scheduling time should be the same for
multiple AgileConnectors of the same type.

Exception Handling
This module also provides exception handling for the scheduling. In the event that your server is down during
the scheduled synchronization, as soon as your server is back online, the synchronization will be automatically
kicked off. After that, the next synchronization will resume the original schedule.

Log Files

Note:  The SharePoint Groups Synchronization module also writes log messages to the
SPSyncModule.log file. The SPSyncModule.log file can also be found at the AgilePointServer\log folder.
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This log file contains detail information about each synchronization operation, such as the status of each
group, or what users were unable to be registered to AgilePoint.

The following is an example of the log message in the ActiveDirectorySynchronizer.log file:

3/1/2005 5:51:49 PM>> Synchronization has started
    to perform on 3/1/2005 5:51:47 PM
Synchronizing Group 'Employees', SharePoint site URL =
    http://r61i-01:8000 Registering user 'MYDOMAIN\Test1' to
    AgilePoint. User full name: Test1

Notifications
In addition to log files that keep track of the synchronization statuses, the synchronization module also provides
email notification capability. Email notification is sent out to the AgilePoint System User with information about
the synchronization. This will allow the system user to determine if there is a need to manually synchronize the
groups or users in the event of failed synchronization.

Configuration Interface

SharePoint Section

• SiteURL - Provide a valid SharePoint site URL, for example http://[hostname]:[port]/sites/MySite

• Site Prefix - This property is optional. In case two site collections are configured then groups with common
name can be distinguished using this property. For example Site "A" has group called "Employees" and
Site "B" also has a group called "Employees". In AgilePoint you can create two groups "SiteA_Employees"
corresponding to Employees group in site A and "SiteB_Employees" corresponding to siteB's Employees.
So while configuring Site A mention "SiteA_" in site prefix so that it will sync with "SiteA_Employees"
during synchronization process and for site B mention "SiteB_" in site prefix so that it sync's with
"SiteB_Employees"

• Group Prefix - This property is optional. This property is used in case a new group is created in SharePoint
and you want that group to be created in AgilePoint.  If a group prefix is not empty then all the groups
created in SharePoint starting with Group prefix value will be created in AgilePoint during Synchronization
process. For example, the group prefix value is set as "GR_" then all the new groups in SharePoint starting
with GR_ will be created and synced during synchronization process.

Option Section

This section provides an option to select what action needs to be taken when a SharePoint group member is
not an AgilePoint user. Either one can select to register user to AgilePoint automatically or send a notification to
AgilePoint System user. 

Schedule Section

This section is used to Schedule the frequency of Synchronization. One can configure Synchronization
frequency to sync daily (Every Day) at particular time, or Weekly (Every Week) or Monthly (Every Month).

Configuration for SharePoint Groups Synchronization Window
Specifies how to synchronize SharePoint groups with AgilePoint groups.
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Prerequisites

• Before configuring, you must enable the SPSync Module AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select SPSyncModule.

4. Click Configure.

Fields

Field Name Definition

Configure Opens the Following Window:

SharePoint Groups Synchronization Window
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Field Name Definition

To Access This Field:

You must be using a Multi-Tenant environment.

Purpose of this Window:

Specifies how to synchronize SharePoint groups
with AgilePoint groups within a tenant.

Site URL Definition:

Specifies the URL for your SharePoint site.

Allowed Values:

A valid SharePoint site URL.

Default Value:

None

Custom Attributes:

Yes

Example:

http://mysharepoint:8000/sites/${mysite}

Site Prefix
Action:

Distinguishes a site with the specified name prefix
in two site collections during the synchronization
process.

Allowed Values:

A single line of text with no spaces.

Default Value:

None

Example:

Two sites, Site A and Site B, each have a group
called "Employees." In AgilePoint, you can
create two groups: "SiteA_Employees" and
"SiteB_Employees." While configuring site A, enter
"SiteA_" in the Site Prefix so this site syncs with
"SiteA_Employees." While configuring Site B,
enter "SiteB_" in Site Prefix so this site syncs with
"SiteB_Employees".

Group Prefix
Action:

Indicates that all the groups in SharePoint starting
with a specified prefix in the group name are
created in AgilePoint during the synchronization
process.
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Field Name Definition

Allowed Values:

A single line of text with no spaces.

Default Value:

None

Example:

If the group prefix value is set as GR_ then all the
new groups in SharePoint starting with GR_ will
be created and synced during the synchronization
process.

Schedule Action:

The frequency for SharePoint synchronization.
Synchronization can occur every day, week, or
month, at a particular time or day.

If Active Directory group member is not AgilePoint
user

Definition:

Specifies what actions to take if a member of your
Active Directory is not a registered AgilePoint user.

Allowed Values:

• Register user to AgilePoint automatically
- Creates an AgilePoint account for the user
using their Active Directory information.

• Send email to AgilePoint system user, and
do not take any action - Does not create an
AgilePoint account for the Active Directory user,
but sends a notification email to the AgilePoint
system user account.

Default Value:

Register user to AgilePoint automatically

Sync all Lync IDs with email IDs Definition:

Synchronizes all of your users' Lync IDs with their
email IDs.

This synchronization occurs each time and Active
Directory synchronization occurs. AgilePoint
recommends using this option only if all of your
users' messaging IDs and email IDs are the same.

Allowed Values:

• Selected - Synchronizes Lync IDs with users'
email IDs.

• Deselected - Does not synchronize Lync IDs
with users' email IDs.
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Field Name Definition

Default Value:

Deselected

Sync all Yammer IDs with email IDs Definition:

Synchronizes Yammer IDs with AgilePoint users'
email IDs. This synchronization occurs each time
and Active Directory synchronization occurs.
AgilePoint recommends using this option only if all
of your users' messaging IDs and email IDs are the
same.

Allowed Values:

• Selected - Synchronizes Yammer IDs with
users' email IDs.

• Deselected - Does not synchronize Yammer
IDs with users' email IDs.

Default Value:

Deselected

Sync all Chatter IDs with email IDs Definition:

Synchronizes Chatter IDs with AgilePoint users'
email IDs. This synchronization occurs each time
and Active Directory synchronization occurs.
AgilePoint recommends using this option only if all
of your users' messaging IDs and email IDs are the
same.

Allowed Values:

• Selected - Synchronizes Chatter IDs with users'
email IDs.

• Deselected - Does not synchronize Chatter IDs
with users' email IDs.

Default Value:

Deselected

SharePoint Groups Synchronization Window
Specifies how to synchronize SharePoint groups with AgilePoint groups within a tenant.
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Prerequisites

• To access this window, you must have a multi-tenant environment.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select SPSyncModule.

4. Click Configure.

5. On the SharePoint Groups Synchronization window, click Configure.

Fields

Field Name Definition

Tenant Definition:

Specifies the tenant name.

Allowed Values:

List of your enabled tenant names.

Default Value:
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Field Name Definition

None

Site URL Definition:

Specifies the URL for your SharePoint site.

Allowed Values:

A valid SharePoint site URL.

Default Value:

None

Custom Attributes:

Yes

Example:

http://mysharepoint:8000/sites/${mysite}

Site Prefix
Action:

Distinguishes a site with the specified name prefix
in two site collections during the synchronization
process.

Allowed Values:

A single line of text with no spaces.

Default Value:

None

Example:

Two sites, Site A and Site B, each have a group
called "Employees." In AgilePoint, you can
create two groups: "SiteA_Employees" and
"SiteB_Employees." While configuring site A, enter
"SiteA_" in the Site Prefix so this site syncs with
"SiteA_Employees." While configuring Site B,
enter "SiteB_" in Site Prefix so this site syncs with
"SiteB_Employees".

Group Prefix
Action:

Indicates that all the groups in SharePoint starting
with a specified prefix in the group name are
created in AgilePoint during the synchronization
process.

Allowed Values:

A single line of text with no spaces.

Default Value:
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Field Name Definition

None

Example:

If the group prefix value is set as GR_ then all the
new groups in SharePoint starting with GR_ will
be created and synced during the synchronization
process.

Add Action:

Creates a row where you can specify your tenant
name, site url, site prefix and group prefix.

Update Action:

Updates the selected row from the SharePoint
groups synchronization configuration list.

Remove (-) Action:

Deletes the selected row from the SharePoint
groups synchronization configuration list.

Edit ( ) Action:

Modifies the selected row from the SharePoint
groups synchronization configuration list.

Delete ( ) Action:

Deletes all rows from the SharePoint groups
synchronization configuration list.

Yammer Hashtag AgileConnector
The Yammer Hashtag AgileConnector enables process participants to initiate process instances using Yammer
hashtags.

Prerequisites

• The user interface for this feature is available in English only.

• AgilePoint Server installed in Windows Service mode.

Enabling the Yammer Hashtag AgileConnector
To enable the Yammer Hashtag AgileConnector, do the following.

Prerequisites

• The user interface for this feature is available in English only.
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• AgilePoint Server installed in Windows Service mode.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

Procedure

1. On the Extensions tab, click Add.

2. In the Impersonator field, enter the AgilePoint user name that is used to connect to your email server.

By default, this is the AgilePoint Service Account.

3. Browse to the assembly [AgilePoint Server installation folder]\bin
\AgilePoint.AgileConnector.YammerHashTag.dll.

Configuring the Yammer Hashtag AgileConnector
To configure the Yammer Hashtag AgileConnector, do the following.

Prerequisites

• The user interface for this feature is available in English only.

• AgilePoint Server installed in Windows Service mode.

• Before configuring, you must enable the Yammer Hashtag AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select YammerHashTag.

4. Click Configure.

Procedure

1. On the Yammer Hashtag Configuration window, select the schedule you want to start a process instance
after the hashtag is posted to Yammer:

• Fixed Time - A time of day after the hashtag appears.

For example, if the fixed time is set to Hour 22 and Minute 15, the process will start at the next
occurrence of 10:15 pm.

• Time Frequency - A time interval following the time the hashtag is posted.

For example, if this is set to 15 Minutes, the process will start 15 minutes after the hashtag is used.

2. Click Next.

3. On the Yammer Hashtag Configuration window, click Add (+).

4. On the Add Yammer Definition window, in the Yammer Definition Name field, enter an identifying name
for your Yammer hashtag configuration settings.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
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5. Complete the fields on the Yammer Hashtag Configuration window as required.

For more information, see the following topics:

• Yammer HashTag Configuration Window - Yammer Credentials Tab

• Yammer HashTag Configuration Window - Hash Details Tab

• Yammer HashTag Configuration Window - Process Initiation Configuration Tab

Configuration Windows
The following topics provide details about the configuration windows for this AgileConnector.

Yammer HashTag Configuration Window - Yammer Credentials Tab

Identifies your Yammer application credentials.

Prerequisites

• The user interface for this feature is available in English only.

• AgilePoint Server installed in Windows Service mode.

• Before configuring, you must enable the Yammer Hashtag AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.
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2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select YammerHashTag.

4. Click Configure.

5. On the Yammer Hashtag AgileConnector Configuration window, set the schedule to initiate your process
instance.

6. Click Next.

Fields

Field Name Definition

Yammer Definitions Definition:

A group of configuration settings for initiating
a specified process instance using a specified
Yammer connection.

You can select a Yammer definition to modify, or
click Add to create a new Yammer definition to add
to the list.

Allowed Values:

The list of your defined Yammer definitions.

Default Value:

None

Add Action:

Creates new Yammer definition.

Remove Action:

Deletes the selected Yammer definition.

Access Token Name Definition:

Specifies the unique name for your connection to
the enterprise social application.

Allowed Values:

An alphanumeric string with no spaces.

Default Value:

None

Custom Attributes:

No
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Yammer HashTag Configuration Window - Hash Details Tab

Specifies the combination of Yammer hashtags and recipients that are used to initiate your process.

Prerequisites

• The user interface for this feature is available in English only.

• AgilePoint Server installed in Windows Service mode.

• Before configuring, you must enable the Yammer Hashtag AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select YammerHashTag.

4. Click Configure.

5. On the Yammer Hashtag AgileConnector Configuration window, set the schedule to initiate your process
instance.

6. Click Next.
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Fields

Field Name Definition

Yammer Definitions Definition:

A group of configuration settings for initiating
a specified process instance using a specified
Yammer connection.

You can select a Yammer definition to modify, or
click Add to create a new Yammer definition to add
to the list.

Allowed Values:

The list of your defined Yammer definitions.

Default Value:

None

Add Action:

Creates new Yammer definition.

Remove Action:

Deletes the selected Yammer definition.

Group / User Definition:

Specifies where to listen for messages that include
the Yammer hashtag key posted to the specified
group, or the administrator user.

Allowed Values:

• Group - Listens for the posted message to
specified group.

• User - Listens for the posted message to the
administrator user account associated with the
application name and configuration key.

Default Value:

Group

HashTag Definition:

Specifies the Yammer hashtag which, when posted
to the specified user or group, will initiate your
process.

Allowed Values:
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Field Name Definition

A single line of text with prefix # symbol and no
space.

Default Value:

None

Group Definition:

Specifies the group name which is used in the
Yammer application.

Allowed Values:

A valid Yammer group name.

Default Value:

None

Add (+) Action:

Creates a new Yammer hashtag key.

Remove (-) Action:

Deletes the selected Yammer hashtag.

Yammer HashTag Configuration Window - Process Initiation Configuration Tab

Specifies the behavior when a process instance is initiated using a Yammer hashtag.
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Prerequisites

• The user interface for this feature is available in English only.

• AgilePoint Server installed in Windows Service mode.

• Before configuring, you must enable the Yammer Hashtag AgileConnector.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the  AgilePoint Server Configuration Tool  screen, click the Extensions tab.

3. On the Extensions tab, select YammerHashTag.

4. Click Configure.

5. On the Yammer Hashtag AgileConnector Configuration window, set the schedule to initiate your process
instance.

6. Click Next.

Fields

Field Name Definition

Yammer Definitions Definition:

A group of configuration settings for initiating
a specified process instance using a specified
Yammer connection.
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Field Name Definition

You can select a Yammer definition to modify, or
click Add to create a new Yammer definition to add
to the list.

Allowed Values:

The list of your defined Yammer definitions.

Default Value:

None

Add Action:

Creates new Yammer definition.

Remove Action:

Deletes the selected Yammer definition.

SharePoint / Non-SharePoint Definition:

Specifies whether your process is associated with a
SharePoint list.

Allowed Values:

• SharePoint - Specifies that your process is
associated with a SharePoint list. This option
allows you to associate Yammer variables with
SharePoint list columns associated with your
process.

• Non-SharePoint - Specifies that your process
is not associated with a SharePoint list.
This option allows you to associate Yammer
variables with custom attributes from a non-
SharePoint process.

Default Value:

Non-SharePoint

SharePointListUrl / Process Definition Definition:

Specifies the process model you want to initiate.

Allowed Values:

• SharePoint list URL - Enter the SharePoint list
URL associated with the AgilePoint process you
want to initiate.

In SharePoint, ensure your SharePoint list is
associated with a workflow that initiates your
AgilePoint process.

• Process Definition - Select the process model
you want to initiate.
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Field Name Definition

Default Value:

None

Custom Field Definition:

Specifies to a variable to map from your process to
a Yammer variable.

Allowed Values:

• For a SharePoint process, to select name of
a custom SharePoint list column as custom
attribute do the following:

1.

Click Connect ( ).

2. On the Connect to SharePoint window,
enter the user account you want to use to
connect to SharePoint.

For more information, refer to Logging on
to SharePoint from a Process Template or
AgileShape.

3. Select the name of the custom SharePoint
list column.

• For a non-SharePoint process, specify a
process attribute you want to map to the
Yammer field.

Default Value:

None

Yammer Field Definition:

Specifies the standard Yammer variable you want to
map with your process variable.

Allowed Values:

• MESSAGE_ID

• GROUP_NAME

• SENDER_ID

• REPLIED_TO_ID

• CREATED_AT

• NETWORK_ID

• MESSAGE_TYPE

• SENDER_TYPE

• URL

• WEB_URL

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#envLogonSP.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#envLogonSP.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#envLogonSP.html
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Field Name Definition

• BODY_PARSED_TEXT

• BODY_PLAIN_TEXT

• BODY_RICH_TEXT

• THREAD_ID

• SENDER_FULL_NAME

• SENDER_DEPARTMENT

• SENDER_EMAIL

• CLIENT_TYPE

• CLIENT_URL

• SYSTEM_MESSAGE

• DIRECT_MESSAGE

• CHAT_CLIENT_SEQUENCE

• CONTENT_EXCERPT

• LANGUAGE

Default Value:

None

Add (+) Action:

Creates a new custom field.

Remove (-) Action:

Deletes the selected custom field.

Work Calendar Window
This window allows you to configure the "business hours" that are used by certain AgilePoint technologies that
use "business time". E.g. When a Manual or Delay AgileShape is configured to use "business time", the settings
on this window determine how the specified interval of "business time" corresponds to real (absolute) time.
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AgilePoint Server Manager Configuration in Windows
Service Mode
This topic provides information about the configuration file for AgilePoint Server running in Windows Service
mode. This is the configuration file for the windows service version of AgilePoint Server. It stores information
about the services configured in AgilePoint Server Manager.

Location: [AgilePoint Server installation folder]\APServerManagerConfig.cfg

Prerequisites

• AgilePoint Server installed in Windows Service mode.

Example
<?xml version="1.0" encoding="utf-8"?>
<Services>
  <Service Name="APServer1" DisplayName="AgilePointServer" Location="C:\AgilePoint
\APServer1" EMVirtualPath="EnterpriseManager" EMURL="http://localhost:9000/
EnterpriseManager" EMSite="AgilePointServer" />
</Services>

Multi-Tenant Configuration
AgilePoint Server can run in a multi-tenant environment. A multi-tenant environment allows you to operate
multiple AgilePoint databases from a single AgilePoint Server instance. This is especially useful for in-house
cloud-like environments within an organization.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html


AgilePoint Server Configuration Utility 125

AgilePoint BPMS v5.0 R2 SP1 AgilePoint Server Administrator's Guide r5.3.16

If you are using AgilePoint Server in a multi-tenant environment, you must set up your tenants (databases and
data sets) using the information in this section.

Prerequisites

• Multi-Tenant environments require a special license.

For more information, refer to Contacting AgilePoint Sales.

• AgilePoint recommends setting up a Multi-Tenant environment only with the help of AgilePoint Professional
Services.

For more information, refer to Contacting AgilePoint Sales.

AgilePoint Multi-Tenant Configuration Window - Tenant
Configuration Tab
Specifies the setup for tenants, or database instances to associate with your AgilePoint Server.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#ContactingAgilePoint.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#ContactingAgilePoint.html
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How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the AgilePoint Server Configuration Tool window, click Multi-Tenant Configuration.

3. On the Mult-Tenant Configuration window, click the Tenant Configuration tab.

Fields

Field Name Definition

Enable Tenant Definition:

Specifies whether to enable the selected tenant.

Allowed Values:
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Field Name Definition

• Selected - Activates the selected tenant.

• Deselected - Deactivates the selected tenant.

Default Value:

Selected

Name Definition:

Specifies unique name of tenant.

Allowed Values:

A single line of text.

Default Value:

None

Description
Definition:

Specifies a free text description of the tenant.

Allowed Values:

Multiple lines of text.

Default Value:

None

Tenant Administrator Definition:

Specifies the user name for the tenant
administrator.

Allowed Values:

A valid user name in the format [domain]\[user
name].

Default Value:

None

Example:

demo3\tenantadmin.

Tenant Admin Email Definition:

The tenant administrator's email address to which
notification to be send.

Allowed Values:

A valid email address.

Default Value:
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Field Name Definition

None

Tenant Database Tab Action:

Specifies the connection to the database to store
workflow data for your tenant.

Tenant Archive Database Tab Action:

Specifies the connection to the archive database for
your tenant, where AgilePoint stores backup of the
workflow data and archived process data.

Configure ( ) Opens the Following Window:

Connection String Builder Window

Purpose of this Window:

Sets up a connection string to a workflow database
or archive database for your tenant.

Add ( ) Action:

Adds new tenant.

Remove ( ) Action:

Deletes the selected tenant from the tenant list.

Validate Action:

Validates the selected database connection string.

Update Action:

Saves your tenant settings.

Print Action:

Displays the AgilePoint multi-tenant license
information and tenant information.

Tenant Identifier Configuration Tab Opens the Following Window:

AgilePoint Multi-Tenant Configuration Window -
Tenant Identifier Configuration Tab

Purpose of this Window:

Sets the Tenant Identifier assembly to determine
which tenant the user belongs to based on a user
name, e-mail address, or mobile number stored in
the AgilePoint database.
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Connection String Builder Window
Sets up a connection string to a workflow database or archive database for your tenant.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the AgilePoint Server Configuration Tool window, click Multi-Tenant Configuration.

3. On the Mult-Tenant Configuration window, click the Tenant Configuration tab.

4. Click the Tenant Database\Tenant Archive Database tab.

Fields

Field Name Definition

Database Type Definition:

Specifies the database technology you are using to
store AgilePoint data.

Allowed Values:

Read only
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Field Name Definition

Username Definition:

The user name for the database account AgilePoint
Server uses to connect to the database.

Allowed Values:

A valid user name for the database.

Default Value:

None

Password Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None

Integrated Security Definition:

When integrated security is selected, the current
windows account credentials are used for
authentication.

Allowed Values:

• Selected - The windows account credentials
are used for authentication automatically.

• Deselected - The user and password fields are
enabled for database authentication.

Default Value:

Selected

Database Server Definition:

Specifies the server name and domain for your
database.

Allowed Values:

A valid database server name.

Default Value:

None

Database Name Definition:

Specifies the name of your database.
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Field Name Definition

Allowed Values:

A valid database name.

Default Value:

None

Retrieve Action:

Retrieves the names of existing databases from the
data source.

Connection Pool Size Definition:

Specifies the maximum number of database
connections that use to connect to the workflow
database at runtime.

Allowed Values:

Any integer.

It is recommended to use a connection pool size
that is >= 100 or 2 * the thread pool size.

Default Value:

100

AgilePoint Multi-Tenant Configuration Window - Tenant Identifier
Configuration Tab
Sets the Tenant Identifier assembly to determine which tenant the user belongs to based on a user name, e-mail
address, or mobile number stored in the AgilePoint database.
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How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Configuration.

2. On the AgilePoint Server Configuration Tool window, click Multi-Tenant Configuration.

3. On the Multi-Tenant Configuration window, click the Tenant Identifier Configuration tab.

Fields

Field Name Definition

Name Definition:

The text ID of the tenant identifier.

Allowed Values:
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Field Name Definition

The value is determined by the assembly

Assembly Definition:

Specifies the dll file of your tenant identifier. Click
Browse to select your dll.

Allowed Values:

A valid assembly name.

Default Value:

None

Class Name Definition:

Specifies the implementation of the
IWFTenantIdentifier interface.

Allowed Values:

A valid class name

Default Value:

None

Identifier Definition:

Specifies whether the assembly contains an
implementation of the IWFTenantIdentifier interface
or both the IWFTenantIdentifier interface and the
IWFIntegratedApplication interface.

Allowed Values:

Read only

Clear Action:

Clears all the field values on the configuration tab.
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AgilePoint Server Log Files
AgilePoint Server creates and maintains log files to store informational, warning, and error messages about the
server and the workflow engine.

Enabling AgilePoint Server Debug Mode
To enable AgilePoint Server debug mode, do the following.

How to Start

1. In a text editor, open the file [AgilePoint Server installation folder]\netflow.cfg.

Procedure

1. Add the debug attribute to the server element in the netflow.cfg file:

<server
    eventCap="50"
    workingCap="50"
    maxLoop="50"
    swapoutTime="60"
    debug="true"
    archiveTime="180"
    assemblyPath="C:\Inetpub\AgilePointSite\TuscaSampleApplication\bin">

2. Save the file.

3. Restart the Windows service for the AgilePoint Server instance.

Log File Name Format and Location
This topic provides the location and naming convention for the AgilePoint Server log.

The log files are located in the following folder:

[AgilePoint Server installation folder]\log.

The following is the file name convention for the AgilePoint Server log files.

apsvc-[Assembly version]-[yyyymmdd]T[hhmmss]-[MachineName]-[ProcessID].log

Example:

apsvc-5.0.4.42679-20140611T100710-APS-1636.log

Details:

Field Name Definition

Assembly version The version of your Ascentn.Workflow.WFCore.dll file.

yyyymmdd The year, month and date of log file creation.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
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Field Name Definition

hhmmss The hours, minutes, seconds of log file creation.

MachineName The name of machine where the AgilePoint Server is
installed.

ProcessID The PID of AgilePoint Server instance in task
manager.

Managing Log File Size
To help you manage storage space for log files, AgilePoint Server creates a new log file when the current log
file reaches the specified maximum file size, and provides an option for specifying a custom log file location. To
manage your log file size, do the following.

Prerequisites

• Back up the AgilePoint.WCFService.exe.config file.

How to Start

1. In a text editor, open the file [AgilePoint Server installation folder]\bin
\Ascentn.AgilePoint.WCFService.exe.config.

Procedure

1. Add one of the following keys to the <appSettings> node:

Field Name Definition

LogFileFolder Definition:

Specifies the location for your AgilePoint Server
log file.

Allowed Values:

An appSettings key in the following format:

<add key="LogFileFolder" value="[absolute path
to your log file folder]" />

Default Value:

[AgilePoint Server installation folder]\log

Example:

<add key="LogFileFolder" value="c:\Users\Log" />

MaxLogFileSize Definition:

Specifies the maximum file size for your log file.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
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Field Name Definition

Allowed Values:

An appSettings key in the following format:

<add key="MaxLogFileSize" value="[number of
MB]" />

This value is an integer that represents log file
size in MB.

Default Value:

50

Example:

<add key="MaxLogFileSize" value="150" />

2. Save the file.

3. Restart the Windows service for the AgilePoint Server instance.
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AgilePoint Deployment Services
The AgilePoint Deployment Utility is used to package and migrate AgilePoint Process Models and associated
AgilePart/AgileWork assemblies amongst the different AgilePoint Server environments (e.g. Development,
Testing, Staging, and Production). This tool can also be used to backup and restore Process Models and
associated AgilePart/AgileWork assemblies.

Installing AgilePoint Deployment Services is optional. For a fresh installation and upgrade, AgilePoint
Deployment Services is installed as a separate component via the AgilePoint Utilities and Other Support
Files section of the installer.

The AgilePoint Deployment Services consists of the following components:

• AgilePoint Deployment Service

• AgilePoint Deployment Utility

AgilePoint Deployment Service
The AgilePoint Deployment Service is a Windows service that runs on the AgilePoint Server machine, and
provides a WCF communication channel between the server and the client.

AgilePoint Deployment Utility
The AgilePoint Deployment Utility is used to package and migrate AgilePoint Process Models and associated
AgilePart/AgileWork assemblies amongst the different AgilePoint Server environments (e.g. Development,
Testing, Staging, Production). This tool can also be used to backup and restore Process Models and associated
AgilePart/AgileWork assemblies.

Opening the AgilePoint Deployment Utility
To open the AgilePoint Deployment Utility:

1. Click Start > All Programs > AgilePoint > AgilePoint Deployment Utility.

Adding an AgilePoint Server
To expose process templates and associated dependencies that are deployed to an AgilePoint Server, first
add the AgilePoint Server to the server collection. Two things are accomplished at this stage; the first is to test
the connection to the AgilePoint Server, the second is to create a connection to the AgilePoint Server. After
the information about the AgilePoint Server is gathered, the AgilePoint Deployment Service will validate the
connection, and the certification of the user.

To add an AgilePoint Server:

1. From the AgilePoint Explorer tab, click the Add button.

2. In the Display Name field, type a Display Name that specifies the name of the AgilePoint Server that will be
displayed in the AgilePoint Server Collection list.
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3. In the Server field, select either Host Name or IP Address and enter the information about the AgilePoint
Server as necessary.

4. In the Port field, type the Port number for the WCF Service (the default is 8917). The port number can be
found and changed in the file [AgilePoint Deployment Service installation folder]\apds.exe.config.

5. In the Domain field, type the Domain Name for the AgilePoint Server.

6. In the Username field, type the AgilePoint Server System username.

7. In the Password field, type the password for the AgilePoint Server System user.

8. Click Test Connection to test the connection to the AgilePoint Server. If the test connection is successful,
click OK.

9. The AgilePoint Deployment Utility appears with the AgilePoint Server added.

10. Repeat the process to add the desired AgilePoint Servers to the AgilePoint Deployment Utility.

Removing an AgilePoint Server
For one reason or another, an AgilePoint Server may need to be removed from the collection if it is no longer
used.

To remove an AgilePoint Server:

1. From the AgilePoint Explorer tab, select the AgilePoint Server for which you would like to remove and click
the Remove button on the toolbar. The AgilePoint Server is removed from the list.

Backing up a Process Model and Associated Dependencies
The Backup function allows for Process Models and associated dependencies on an AgilePoint Server to
be backed up into a package file. The process definition will be saved as an XML file, and the associated
dependencies will be copied from GAC. After all items are gathered, a package file (.odp) will be created and
saved to the location specified. The package file can then be restored in a recovery scenario.

To backup a process model and associated dependencies:

1. From the AgilePoint Explorer tab, select the AgilePoint Server for which you would like to backup a
Process Model and associated dependencies from and click the Backup button on the toolbar. The Backup
Process Definition Wizard appears.

2. Click Next.

3. Select the Application(s) type(s) for which to backup and click Next.

4. Select the Process Model(s) and click Next.

5. Select the AgileParts and AgileWorks for which to backup and click Next.

6. Type the file path of browse and select the folder location for which to save the package file and click Next.

7. Once the backup has been completed successfully, click Finish. The package file is saved to the folder
specified as an .odp package file that can then be later restored as needed.

Restoring a Process Model and Associated Dependencies
The Restore function allows for the package file (i.e. Process Model and associated dependencies) to be
restored on an AgilePoint Server.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
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To restore a process model and associated dependencies:

1. From the AgilePoint Explorer tab, select the AgilePoint Server for which you would like to backup a Process
Model and associated dependencies from and click the Backup button on the toolbar. The Restore Process
Definition Wizard appears.

2. Add the desired package file(s) (.odp) and click Next.

3. Once the restore has been completed successfully, click Finish.

Migrating a Process Model and Associated Dependencies
The following provides instructions for migrating a Process Model and associated dependencies from one
AgilePoint Server to another.

To migrate a Process Model and the associated dependencies:

In this example, the Document Approval Process Model and associated dependencies will be migrated from the
AgilePoint Server on the Dimension4700-01machine to the AgilePoint Server on the ibmt61-005 machine. 

1. Right-click on the AgilePoint Server host machine name that contains the Process Model and dependencies
for which you would like to export.

2. Click the Import Export button. The Export & Import Process Definition Wizard appears.

3. Click Next.

4. Select the application type(s) (ASP.NET or SPSIntegration).

5. Select the Process Template(s).

6. Click Next. The system automatically selects all the dependencies for the Process Templates.

7. Click Next. The list of Process Templates appears.

8. Click Next.

9. Select the target machine where AgilePoint Server is installed.

10. Click Next. The system moves the Process Template and associated dependencies to the target AgilePoint
Server.

11. Click Finish.

Rolling back a Process Model and Associated Dependencies
The rollback function can be used if a Process Model and associated dependencies fail to be deployed to a
target AgilePoint server, a new project fails to be deployed, or a package file fails to be restored. The AgilePoint
Deployment Service records the information in a XML file and provides a way to rollback the migration.

To rollback a Process Model and the associated dependencies:

1. From the AgilePoint Explorer tab, select the AgilePoint Server that contains the Process Model and
associated dependencies that failed to be migrated to a target AgilePoint server, the project failed to be
deployed, or a package file failed to be restored and click the Rollback button on the toolbar. The Rollback
Process Definition Wizard appears.

2. Click Next.

3. Select the item(s) (i.e. Process Model and dependencies, project, or package files) and click Next.

4. Once the rollback has been completed successfully, click Finish.
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Creating a Project
If a new edition of a process definition is to be deployed to an AgilePoint Server, a new project can be created.
The project includes the Process Model that will be saved in the folder location you have specified. The Process
Model should be an XML file.

To create a new project

1. Click the Local Projects tab and click Create.

2. In the Name field, type a name for the project.

3. In the Location field, type a file path or browse and select the folder for which to store the project collection.

4. In the Description field, type a description for the process.

5. In the Process field type a file path to the XML file for a Process Model to add to the project or browse and
select it.

6. Click OK.

Note:  The Process Model must be a XML file.

Note:  AgilePoint Envision should NOT be running when creating a project.

Project Functions
Add Project

Once a project is created, you can add a project to the project collection from another place by right-clicking on
the project collection name and selecting Add Project.

Remove Project

Once a project is created, you can remove a project from the project collection by right-clicking on the project
name and selecting Remove Project.

Add a Process

Once a project is created, you can add a process to the project by right-clicking on the project and selecting Add
Process.

Remove a Process

Remove a process from a project by right-clicking on the project and selecting Remove Process.

Analyze AgilePart

Once a project is created, you can analyze AgileParts for a Process Model by right-clicking on a project and
selecting Analyze AgilePart. If an AgilePart has been unintentionally removed, this function will allow you to get
all AgileParts associated with the Process Model.

Add AgilePart Assembly

Once a project is created, you can add an AgilePart assembly for a Process Model by right-clicking on an
assembly and selecting Add AgilePart Assembly.

Exclude AgilePart Assembly
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Once a project is created, you can remove an AgilePart assembly for a Process Model by right-clicking on an
assembly and selecting Exclude AgilePart Assembly.

Analyze AgileWork

Once a project is created, you can analyze AgileWorks for a Process Model by right-clicking on a project and
selecting Analyze AgileWork. If an AgileWork has been unintentionally removed, this function will allow you to
get all AgileWorks associated with the Process Model.

Add AgileWork Assembly

Once a project is created, you can add an AgileWork assembly for a Process Model by right-clicking on an
assembly and selecting Add AgileWork Assembly.

Exclude AgileWork Assembly

Once a project is created, you can remove an AgileWork assembly for a Process Model by right-clicking on an
assembly and selecting Exclude AgileWork Assembly.

Analyze Dependency

Once a project is created, you can analyze dependencies for an assembly by right-clicking on an assembly and
selecting Analyze Dependency. If a dependency has been unintentionally removed, this function will allow you
to get all dependencies associated with the assembly.

Add Dependency Assembly

Once a project is created, you can add a dependency assembly for an assembly by right-clicking on an
assembly and selecting Add Dependency Assembly.

Exclude Dependency Assembly

Once a project is created, you can remove an dependency assembly for an assembly by right-clicking on an
assembly and selecting Exclude Dependency Assembly.

Opening a Project
This function allows you to add an existing project to the project collection for editing.

To open a project:

1. Click the Local Projects tab and click Open.

2. Select the project to add or click More and browse to select it.

Saving a Project
After a project collection has been created or edited, it must be saved. All items of a project collection including
the Process Model XML file and associated dependencies will be saved. When saving a project collection, you
have the option to change the name as desired.

Packaging a Project
This function allows you to package an entire project collection and save it to the client machine for archive
purposes.
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Deleting a Project or Project Collection
This function allows you to delete a project or project collection from the Deployment Services Utility.

Closing Projects
This function allows you to close a project or project collection.

Deploying a Project
This function allows you to deploy a project to a target AgilePoint Server machine.

To deploy a project:

1. Click the Local Projects tab and click Deploy. The Deploy Project Wizard appears.

2. Click Next.

3. Select the project(s) to add and click Next.

4. Select the target AgilePoint Server and click Next.

5. Once the deployment has been completed successfully, click Finish.

Viewing Deployment History
This function allows you to view deployment history interaction (e.g. what operations occurred and the result) on
an AgilePoint Server machine.

To view deployment history:

1. Click the Deployment History tab.

2. Expand the AgilePoint Server for which you would like to view deployment history.

3. Click the date icon to view the deployment history.

To delete deployment history, right-click on a date icon and select Delete History.
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AgilePart Deployment Wizard Utility
The AgilePart Deployment Wizard is a utility application that allows you to register custom AgilePart assemblies
with AgilePoint Server so that those assemblies can be downloaded from AgilePoint Envision and used by
AgilePoint Server's workflow engine at run time.

How to Start

• To open the AgilePart Deployment Wizard, Click Start > All Programs > AgilePoint > AgilePart
Deployment Wizard.

Procedure

1. On the AgilePart Deployment Wizard, click Add.

2. On the Deploy AgilePart window, in the Assembly section, click the Ellipse button to select the required
custom AgilePart dll.

3. Click OK.



Performance Tracing Utility 144

AgilePoint BPMS v5.0 R2 SP1 AgilePoint Server Administrator's Guide r5.3.16

Performance Tracing Utility
The Performance Tracing utility allows you to report on performance of custom components such as custom
AgileParts, AgileWorks, AgileConnectors, AgileStubs, or Web Services. The performance criteria is based on
milliseconds, for example you can write a query to return the most time consuming AgileParts. To use this utility,
you will need a database that includes a table called WF_PERF_TRACES (it is not recommended to add this
table to the AgilePoint database). You will also need to add a PerfTrace.config XML file to the root level folder
where AgilePoint Server is installed (e.g. c:\inetpub\wwwroot\AgilePointServer\). The location of AgilePoint
Server can be determined from the registry.

To use the utility to perform performance tracing:

1. Create a new table called WF_PERF_TRACES in a database as below. It is not recommended to use the
AgilePoint database for this table.

SET ANSI_NULLS ON
GO
SET QUOTED_IDENTIFIER ON
GO
SET ANSI_PADDING ON
GO
CREATE TABLE [WF_PERF_TRACES](
[SOURCE] [varchar](1024) NULL,
[CATEGORY] [int] NULL,
[OBJECT_ID] [varchar](256) NULL,
[TIME_STARTED] [datetime] NULL,
[TIME_SPAN] [int] NULL
) ON [PRIMARY]
GO
SET ANSI_PADDING OFF

A sample query may return results as shown below:

2. In a text editor, create a new file with the following content:, and save it with the name PerfTrace.config.

<?xml version="1.0" encoding="utf-8"?>
<PerformanceTraceSetting xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
 xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <Database>
      <Vendor>MSSQLDatabase</Vendor>
      <Connstr>server=localhost;database=lock;trusted_Connection=yes</Connstr>
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  </Database>
  <Filter>
     <Category>TrackingEvent</Category>
     <Category>WebService</Category>
     <Category>ProcessEventHandler</Category>
     <Category>AgilePart</Category>
  </Filter>
  <MinimumTimeSpan>10</MinimumTimeSpan>
</PerformanceTraceSetting>

3. Save the file to the following path and file name:

[AgilePoint Server installation folder]\PerfTrace.config

4. Configure PerfTrace.config as follows:

a. Within the Database section, enter the database vendor and connection string for your performance
tracking database.

b. The Filter section allows you to add the categories for which you want to report on. The categories that
are available include:

• AgilePart – Reports on all AgilePart data.

• ProcessEventHandler – Reports on AgileWork and AgileStub data.

• TrackingEvent – Reports on AgileConnector data.

• WebService – Reports on Web Service data.

When doing the reporting, a few of the filtering options that are available include:

• Exclude Categories - To exclude one or more of the categories, remove the category from the
PerfTrace.config file. For example, remove the <Category>WebService</Category> to tell AgilePoint
Server to exclude Web Service tracing data from being recorded to the database.

• When writing your SQL, each category has been assigned a numerical identifier for filtering. This allows
you to report only on a certain category. Each category is identified as follows:

• AgilePart – 0.

• ProcessEventHandler – 1.

• TrackingEvent – 2.

• WebService – 3.

A couple of sample query statements are shown below:

select * from WF_PERF_TRACES where source like
'%Sample%' order by time_span desc

select * from WF_PERF_TRACES
where  category = 0 and source like '%Move%'
order by time_span desc

A sample query may return results similar to below:

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
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Note:  It is not necessary to restart IIS upon making changes to the configuration file. AgilePoint Server
will begin recording this tracing data to the database within 10-30 seconds. You can delete this file or
rename it to stop this service.
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APADM Command Line Utility
This topic provides examples using commands for the APADM SharePoint command line utility. The APADM
application is a command line utility that can be used to perform some administrative tasks from the command
line.

Prerequisites

• To use the ExecutionTimeout argument, you must have a release that includes Intermediate Fix 08.0081.02.

• To use the SyncSocialAccounts argument, you must have AgilePoint v5.0 R2 with Intermediate Fix
08.0082.01.

How to Start

1. In a command prompt, change directories to [AgilePoint Server installation folder]\Tools

Procedure

1. Run the following commands as required, using the following format:

apadm.exe [command] [arguments]

Command Required Arguments Optional Arguments Example

-help

-adduser • [LDAP path]

• [AgilePoint Server
URL]

• ExecutionTimeout
= [seconds] -
Specifies a timeout
value, in seconds, for
the operation.

• SyncSocialAccounts
- Synchronizes users'
email IDs with their
Yammer and Lync
IDs.

• apadm -
adduser LDAP://
dc=tusca,dc=com
http://localhost/
AgilePointServer

• apadm -
adduser LDAP://
dc=tusca,dc=com
http://localhost/
AgilePointServer
ExecutionTimeout=100

-archive • [days] or [process
instance ID] or
[ProcessDefinitionName:ProcessInstaneName]

• [AgilePoint Server
URL]

• -Y - Supresses
the interactive
confirmation to
proceed with the
action.

• ExecutionTimeout
= [seconds] -
Specifies a timeout
value, in seconds, for
the operation.

The following example
archives all processes
that were completed or
canceled 10 days ago.

• apadm -archive
10 http://localhost/
AgilePointServer

The following example
archives the process with
the specified process
instance ID.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
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Command Required Arguments Optional Arguments Example

• apadm -archive
501630F1C09743dbBA25FAC9C3DA7524
http://localhost/
AgilePointServer

• apadm -archive
10 http://localhost/
AgilePointServer -Y
ExecutionTimeout=100

-restore • [process
instance ID] or
[ProcessDefinitionName:ProcessInstaneName]

• [AgilePoint Server
URL]

• ExecutionTimeout
= [seconds] -
Specifies a timeout
value, in seconds, for
the operation.

• apadm -restore
501630F1C09743dbBA25FAC9C3DA7524
http://localhost/
AgilePointServer

• apadm -restore
ExpenseReport:JohnSmith-01-20-2010-09
http://localhost/
AgilePointServer
ExecutionTimeout=100

-syncgm • [LDAP path]

• [authentication
domain name]

• [AgilePoint Server
URL]

• [retry count] - An
integer that specifies
a number of times to
retry the operation
before quitting.

• ExecutionTimeout
= [seconds] -
Specifies a timeout
value, in seconds, for
the operation.

• SyncSocialAccounts
- Synchronizes users'
email IDs with their
Yammer and Lync
IDs.

• apadm -
syncgm LDAP://
dc=tusca,dc=com
TUS http://localhost/
AgilePointServer

In the following example,
if synchronization fails,
it retries 5 times as
specified in the optional
last parameter.

• apadm -
syncgm LDAP://
dc=tusca,dc=com
TUS http://localhost/
AgilePointServer 5
ExecutionTimeout=100

-rmprocdef • [process definition
name]

• [AgilePoint Server
URL]

• -Y - Supresses
the interactive
confirmation to
proceed with the
action.

• ExecutionTimeout
= [seconds] -
Specifies a timeout
value, in seconds, for
the operation.

• apadm -rmproc
PurchaseRequest
http://localhost/
AgilePointServer

• apadm -rmproc
PurchaseRequest
http://localhost/
AgilePointServer -Y
ExecutionTimeout=100
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Command Required Arguments Optional Arguments Example

-mgproc • [process migration
instruction XML
file]

• [AgilePoint Server
URL]

• -NoSchemaMigrate
- Stops upgrading
the schema to the
latest updated
schema.

• -Run - Keeps the
process running,
even if an error
occurs while running
the operation.
By default, if an
error occurs, the
process moves to a
suspended state.

• ExecutionTimeout
= [seconds] -
Specifies a timeout
value, in seconds, for
the operation.

• apadm -mgproc
PurchaseRequest
http://localhost/
AgilePointServer

• apadm -mgproc
PurchaseRequest
http://localhost/
AgilePointServer -
NoSchemaMigrate
-Run
ExecutionTimeout=100

-sysinfo • [AgilePoint Server
URL]

• ExecutionTimeout
= [seconds] -
Specifies a timeout
value, in seconds, for
the operation.

• apadm -systeaminfo
http://localhost/
AgilePointServer

• apadm -systeaminfo
http://localhost/
AgilePointServer
ExecutionTimeout=100

-publishprocdef • [AgilePoint Server
URL]

• [folder] or [file]

• [release date]

• ExecutionTimeout
= [seconds] -
Specifies a timeout
value, in seconds, for
the operation.

In this example, abc is a
folder that contains XML
files of process definition
that need to be published
and scheduled to be
released on 1/20/2011.

• apadm -
publishprocdef
http://localhost/
AgilePointServer abc
1/20/2011

• apadm -
publishprocdef
http://localhost/
AgilePointServer
abc 1/20/2011
ExecutionTimeout=100

In this example,
expensereport.xml is
an XML file of process
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Command Required Arguments Optional Arguments Example

definition that needs to
be published.

• apadm -
publishprocdef
http://localhost/
AgilePointServer
expensereport.xml

-analyzeclusterlog • [cluster log file] • ExecutionTimeout
= [seconds] -
Specifies a timeout
value, in seconds, for
the operation.

• apadm -
analyzeclusterlog
20110521T043713Cluster.log

• apadm -
analyzeclusterlog
20110521T043713Cluster.log
ExecutionTimeout=100

APADM Archive Database Command
The APADM utility can be used to manually initiate archiving of AgilePoint Server data to the archive database.
Archiving the workflow data will move the data for old processes from the main workflow database to an archive
database. Old processes are those that have been Canceled or Completed for at least a specified minimum
number of days.

Prerequisites

• Configure a connection to an archive database using the AgilePoint Server Configuration utility.

• Log on to Windows using a user account with the access rights "Archive Process Instance" in AgilePoint.

How to Start

1. Open the APADM Command Line Utility:

[AgilePoint Server installation folder]\Tools\apadm.exe

Procedure

1. Run the archive database command:

apadm -archive [days] [AgilePointServer URL]

The following is an example of using the utility to archive all processes that were completed or canceled at
least 170 days ago:

D:\>apadm -archive 170 http://[hostname]/AgilePointServer
Connecting AgilePoint Server...You currently logon as 'MYDOMAIN\admin'
Query AgilePoint database...12 process(es) can be archived.
Please enter <Y> to continue, otherwise stop...y
Archiving process '/sites/AgilePointFinancialSite/
     ExpenseReport_InfoPath/ER-2005-0032.xml#1'…Done ( 0.334(s))

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
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APADM Synchronize Active Directory Command
The apadm.exe utility can be used to manually initiate a synchronization of AgilePoint Server's users and groups
with Active Directory. (This is a manual alternative to the ADSyncModule server extension.)

APADM Bulk Migration Command
The apadm.exe utility can be used to do a bulk migration of process instances. For more information, refer to
Migrating a Process Model and Associated Dependencies in the Documentation Library.

http://documentation.agilepoint.com/SupportPortal/Docs/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html
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AgilePoint Server Monitor Service

Prerequisites

• AgilePoint Server installed in Windows Service mode.

• AgilePoint Server running in IIS mode.

The AgilePoint Server Monitor is a Windows service application that can be used to monitor the AgilePoint
Server application, and to automatically restart the application if IIS should stop and/or recycle the application's
process. This service can be useful if you want to prevent your end users from experiencing the occasional delay
that may occur during the first use of the application after IIS has recycled the application's worker process.

When running, the service makes a simple request to the AgilePoint Server application once per minute in order
to ensure that the application is still initialized and running. If the application isn't running, the request will cause
IIS to start it.

Note:  The utility will be automatically installed to Windows' Services console when installing AgilePoint
Server v3.2.0.2 or later. However, when upgrading from v3.2.0.1 or earlier, you will need to use the .NET
Framework's InstallUtil.exe utility to manually register the apsvrmon.exe executable.

The executable is located in your AgilePoint Server folder at:

…\AgilePointServer\Tools\apsvrmon.exe

E.g. You could run the following command from the command prompt in the folder where the exe is located:

InstallUtil.exe apsvrmon.exe
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AgilePoint Server Manager
The AgilePoint Server Manager is a sever management application that enables you to start, stop, add, delete,
configure, and manage AgilePoint Server instances in a Windows Service environment.

Good to Know

• If you make changes to ports or SSL information on the AgilePoint Server Manager, you must run the Client
Utility Tool against any affected web applications. This includes Enterprise Manager and SharePoint.

For more information, refer to Running the SVC Client Utility Tool.

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Server Manager.



AgilePoint Server Manager 154

AgilePoint BPMS v5.0 R2 SP1 AgilePoint Server Administrator's Guide r5.3.16

Field Definitions

Field Name Definition

Service Name Definition:

Specifies the name you want to use to identify the
Windows service associated with the AgilePoint
Server instance.

Allowed Values:

A single line of text.

Default Value:

None

Display Name
Definition:

Specifies the name you want to display to users to
identify the AgilePoint Server instance.

Allowed Values:

A single line of text.

Default Value:

None

Location
Definition:

Specifies the path to the AgilePoint Windows
Service instance.

Allowed Values:

A valid absolute file path.

Default Value:

None

WSHttp Port Definition:

A free, unique port AgilePoint Server can use for
WSHttp binding.

This field is required.

Allowed Values:

Specifies a valid WSHttpPort number.

Default Value:

None
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Field Name Definition

TCP Port Definition:

Specifies a free, unique port AgilePoint Server can
use for TCP binding.

This field is required.

Allowed Values:

A valid TCP port number.

Default Value:

None

BasicHttp Port Definition:

A free, unique port AgilePoint Server can use for
BasicHttp binding.

This field is required.

Allowed Values:

A valid port number.

Default Value:

None

Web HTTP Port Definition:

Specifies a free, unique port AgilePoint Server can
use for REST API calls.

To Access This Field:

Click the Rest Port Information tab.

Allowed Values:

A valid HTTP port number that can be used for
REST API calls.

Default Value:

None

Service Factory Binding Opens the Following Window:

Global Extended Module Window

Purpose of this Window:

Specifies the authentication scheme for your REST
endpoint.

To Access This Field:

Click the Rest Port Information tab.
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Field Name Definition

Use Secure Connection (SSL) Definition:

The common name (CN) or domain name or fully
qualified domain name associated with your SSL
certificate.

To Access This Field:

Click the SSL Settings tab.

Allowed Values:

An appSettings key in the following format:

• Selected - SSL encryption is enabled.

• Deselected - SSL encryption is disabled.

Default Value:

Deselected

Domain Name Definition:

The common name (CN) or domain name or fully
qualified domain name associated with your SSL
certificate.

To Access This Field:

Click the SSL Settings tab.

Allowed Values:

An appSettings key in the following format:

A text string representing your common name or
domain name.

Default Value:

None

Example:

mydomain.com

Check Availability of Ports Action:

Tests the specified ports to ensure they are free.

UserName Definition:

Specifies the user name for the AgilePoint service
account.

Allowed Values:

A valid user name in the format domain\username.
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Field Name Definition

Default Value:

None

Example:

MYDOMAIN\APServiceUser

Password
Definition:

The password for the authentication account.

Allowed Values:

A valid password.

Default Value:

None

Site
Definition:

Specifies the web site from the list you created for
AgilePoint during pre-installation.

Allowed Values:

A valid web site name.

Default Value:

AgilePointWebsite

Virtual Directory
Definition:

Specifies the name you want to use for the virtual
directory that contains the files for the Enterprise
Manager web application.

Allowed Values:

A valid virtual directory name.

The name EnterpriseManager is suggested.

Default Value:

None

Application Pool Definition:

Specifies the IIS application pool for the Enterprise
Manager web application you want to run.

Allowed Values:

A valid application pool.

Default Value:
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Field Name Definition

AgilePointAppPool

Add ( ) Creates a new AgilePoint Windows Service instance.

Start ( ) Action:

Starts the selected AgilePoint Windows Service
instance.

Stop ( ) Action:

Stops the selected AgilePoint Windows Service
instance.

Delete ( ) Action:

Deletes the selected AgilePoint Windows Service
instance.

Refresh ( ) Action:

Refreshes the selected AgilePoint Windows Service
instance.

Server Configuration ( ) Action:

Opens the AgilePoint Server Configuration window
for the selected AgilePoint Windows Service
instance.

Enterprise Manager ( ) Action:

Opens Enterprise Manager for the selected
AgilePoint Windows Service instance.

Update Action:

Saves changes to an AgilePoint Windows Service
instance configuration.

Global Extended Module Window
Specifies the authentication scheme for your REST endpoint.
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How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Server Manager.

2. On the AgilePoint Server Manager window, select your AgilePoint service.

3. Click the Rest Port Information tab.

4. On the Rest Port Information tab, in the Service Factory Binding field, click Browse.

Fields

Field Name Definition

Assembly Definition:

Specifies the .dll file that provides server side
authentication for REST services. In some
circumstances you must create a custom
authentication module.

For more information, refer to Server Side
Authentication Using WCF Endpoints for AgilePoint
Server.

Allowed Values:

A valid assembly name.

Default Value:

None.

The default .dll is [AgilePoint
Server installation folder]\bin
\AgilePoint.REST.ServiceBindingFactory.dll

Class Name Definition:

Specifies the implementation of the
IWFServiceBindingFactory interface.

http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#devServerSideAuth.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#devServerSideAuth.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#devServerSideAuth.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#kbDefaultInstallLocations.html
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Field Name Definition

Allowed Values:

A valid class name

Default Value:

None

Adding a Server Instance
To add a server instance, in AgilePoint Server Manager, click the Add button.

Deleting a Server Instance
To delete a server instance, in AgilePoint Server Manager, click the Delete button.

Starting a Server Instance
To start a server instance, in AgilePoint Server Manager, click the Start button.

Stopping a Server Instance
To stop a server instance, in AgilePoint Server Manager, click the Stop button.

Configuring a Server Instance
To configure a server instance, in AgilePoint Server Manager, click the Configure button. The AgilePoint
Configuration window opens. Follow the instructions for the AgilePoint Server Configuration utility in this
document.

Managing a Server Instance
To manage a server instance, in AgilePoint Server Manager, click the Internet Explorer icon. Enterprise
Manager opens in Internet Explorer. Follow the instructions for Enterprise Manager in this document and the
Enterprise Manager online help.

Running the SVC Client Utility Tool
Once you have upgraded to AgilePoint BPMS v5.0 R2, you must run the SVC Client Utility Tool on each
instance of AgilePoint Enterprise Manager in your environment.
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This topic provides the standard instructions for running the SVC Client Utility on any ASP.NET web application.

Prerequisites

• AgilePoint Server running in Windows Service mode.

• You have applied the AgilePoint BPMS v5.0 R2 upgrade on all applicable AgilePoint machines.

• You have updated your AgilePoint Server instances.

• Create a backup copy of the configuration file for the application you are configuring before using this utility.

• If you are using SharePoint or AgileForms Server on a machine that is not the AgilePoint Server machine
(typically the case), copy the web.config file from the SharePoint or AgileForms machine to AgilePoint
Server machine. The following are the default locations of the target web.config files:

• SharePoint - c:\inetpub\wwwroot\wss\VirtualDirectories\[port number]

• AgileForms - [AgileForms Server installation folder]\Webroot

How to Start

Do one of the following:

1. On the AgilePoint Server machine, navigate to [AgilePoint Server Installation]\SVCUtilityTool
\AgilePointWindowsServiceClientUtilityTool.exe

2. Open the AgilePoint installation file, and click Utilities and Other Support Files > AgilePoint Windows
Service Client Utility Tool.

Procedure

1. In the AgilePoint Windows Service Client Utility Tool dialog box, complete the following fields:

• Service Address – The URI for the Windows Service for which you are creating the binding. The
information required to build this URI is provided in the AgilePoint Server Manager window.

• HTTP - http://[APServer Machine Name]: [Http Port]/AgilePointServer

• Target Config – The file name and location of the configuration file for the application you are
configuring. This is required for SharePoint Integration. For other applications, you only need to run this
utility if you are prompted.

• SharePoint Integration – The web.config for the SharePoint web application you want to bind.

• Enterprise Manager – The web.config for the Enterprise Manager web application.

• Data Services – DataServicesWindowsService.exe.config in the Data Services installation folder.
The default location is C:\Program Files\AgilePoint\AgilePoint Data Services\

• AgileForms - The web.config file in the AgileForms installation folder. The default location is C:
\Program Files\AgilePoint\AgileForms Server\Webroot

• Deployment Service - apds.exe.config file in the Deployment Service installation folder. The default
location is C:\Program Files (x86)\AgilePoint\AgilePoint Deployment Service\

2. Click Settings to configure the following fields:

• Max Buffer Size

• Max Buffer Pool Size

• Max Received Message Size

• Max String Content Length
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• Max Array Length

Guidance for modifying these values can be found at the following articles on MSDN:

• http://msdn.microsoft.com/en-us/library/ms731361(v=VS.100).aspx

• http://msdn.microsoft.com/en-us/library/ms731325(v=VS.100).aspx

3. If you are using SharePoint or AgileForms Server on a machine that is not the AgilePoint Server machine,
copy the modified web.config file back to its original location on the SharePoint or AgileForms Server
machine.

http://msdn.microsoft.com/en-us/library/ms731361(v=VS.100).aspx
http://msdn.microsoft.com/en-us/library/ms731325(v=VS.100).aspx
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Enabling SSL in AgilePoint Server Manager
To enable the SSL Settings in AgilePoint Server Manager, do the following.

Prerequisites

• You must have an SSL certificate. To create one, see Creating a Self-signed SSL Certificate

• Your certificate must be bound to AgilePoint Server. For more information, refer to Binding the SSL
Certificate to AgilePoint Server Port

How to Start

1. On the AgilePoint Server machine, click Start > All Programs > AgilePoint > AgilePoint Server Manager.

Procedure

1. On the AgilePoint Server Manager, select your AgilePoint Windows Service instance.

2. On the SSL Settings tab, select Use secure connection (SSL).

3. On the Domain Name field, enter the common name or domain name for your SSL certificate.

4. Restart the AgilePoint Server instance.

Creating a Self-signed SSL Certificate
To create a self-signed SSL certificate, do the following.

Prerequisites

• Microsoft Visual Studio installed.

How to Start

1. Click Start > All Programs > Visual Studio  > Visual Studio Tools > Visual Studio Command Prompt.

Procedure

1. On the Visual Studio command prompt, enter the following command:

Makecert -sv SignRoot.pvk -cy authority -r signroot.cer -a sha1 -n "CN=[your certification name]" -ss
my -sr localmachine

2. To move your SSL certificate from Personal folder to Trusted Root Certificate Authorities folder,
complete the following steps:

a. In the Visual Studio command prompt, enter mmc.

b. On the Console Root window, click File > Add/Remove Snap-in.

c. On the Add or Remove Snap-ins window, select Certificates, and click Add.

d. On the Certificates snap-in window, click Computer account.

e. On the Select Computer window, click Local computer.
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f. On the Console Root window, click the Right arrow to expand Certificates (Local Computer)

g. Drag your SSL certificate from the Personal folder to the Trusted Root Certificate Authorities folder.

3. To give your SSL certificate URL name, enter the following command:

Makecert -iv SignRoot.pvk -ic signroot.cer -cy end -pe -n CN="SSL-Url-Name" -eku 1.3.6.1.5.5.7.3.1 -
ss my -sr localmachine -sky exchange -sp "Microsoft RSA SChannel Cryptographic Provider" -sy 12

More Information

• http://msdn.microsoft.com/en-us/library/bfsktky3.aspx

Binding the SSL Certificate to AgilePoint Server Port
To bind the SSL Certificate to AgilePoint Server Port, do the following.

Prerequisites

• AgilePoint Server installed on premises in Windows Service mode.

• The ports you use for binding in AgilePoint Server. You can find these in AgilePoint Server Manager.

• You must have an SSL certificate. To create one, see Creating a Self-signed SSL Certificate

How to Start

1. Click Start > All Programs > Visual Studio  > Visual Studio Tools > Visual Studio Command Prompt.

Procedure

1. In the Visual Studio command prompt, enter mmc.

2. On the Console Root window, click File > Add/Remove Snap-in.

3. On the Add or Remove Snap-ins window, select Certificates, and click Add.

4. On the Certificates snap-in window, click Computer account.

5. On the Select Computer window, click Local computer.

6. On the Console Root window, click the Right arrow to expand Certificates (Local Computer)

7. Click the Right arrow to expand Personal folder.

8. Right-click the Certificates folder.

9. Select All Task > Import.

10. On the Certificates Import wizard, click the Next button.

11. In the File name field, browse your SSL certificate.

12. Double-click your SSL certificate.

13. Select the Details tab.

14. In the shown field, select ALL.

15. Select Thumbprint.

16. Copy the value of the thumbprint.

http://msdn.microsoft.com/en-us/library/bfsktky3.aspx
http://documentation.agilepoint.com/SupportPortal/DOCS/ProductDocumentation/CurrentRelease/DocumentationLibrary/maps/index.html#serverServerManagerWcf.html
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17. On the Visual Studio command prompt, enter the following command:

netsh http add sslcert ipport=0.0.0.0:portnumber certhash=SSL-Certifcate-thumbprint-value-without-
spaces appid={c929c857-e10a-48c4-b123-5713faba528e}
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