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Disclaimer of Warranty

AgilePoint, Inc. makes no representations or warranties, either express or implied, by or with respect to anything
in this document, and shall not be liable for any implied warranties of merchantability or fitness for a particular
purpose or for any indirect, special or consequential damages.

Copyright

Copyright © 2013 AgilePoint, Inc. All rights reserved.

Trademarks

AgilePoint, Inc. and AgilePoint's products are trademarks of AgilePoint Inc. References to other companies and
their products use trademarks owned by the respective companies and are for reference purpose only.

Government Rights Legend

Use, duplication or disclosure by the U.S. Government is subject to restrictions set forth in the applicable license
agreement and as provided in DFARS 227.7202-1(a) and 227.7202-3(a) (1995), DFARS 252.227-7013(c)(1)(ii)
(Oct 1988), FAR 12.212(a) (1995), FAR 52.227-19, or FAR 52.227-14, as applicable.

Virus-free software policy

AgilePoint recognizes that viruses are a significant security consideration for our customers. To date, we have
had no report of AgilePoint BPMS carries any virus. AgilePoint takes the following measures to ensure our
software is free of viruses upon delivery:

e AgilePoint is built on top of Microsoft .NET framework. The pre-compiled executable is a.NET Common
Language Runtime (CLR) application, not a native machine binary. As far as is known at this time, there are
no viruses that infect .NET CLR executables.

e The virtual environment for the product packaging process in is fully isolated and protected, and anti-virus
software is installed and running during packaging.

e The deliverable package is scanned by anti-virus software before upload to our customer download site.

Document Revision Numbers

AgilePoint documentation uses the revision number format rX.Y.Z. The letters and numbers in this revision
number can be interpreted as follows:
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® r - Indicates "revision." This helps to differentiate the document version numbers, which start with v.

® X - The major version number for AgilePoint BPMS to which this document refers. For example, AgilePoint
releases 5.0, 5.0 SP1, and 5.5 would all have an X value of 5.

® Y - The major document revision number. This number typically changes only when either there is a new
AgilePoint release, or there are major changes to the document.

® 7 - The minor document revision number. This number is incremented each time the document is
republished.

AgilePoint Documentation in PDF and HTML

AgilePoint documentation is provided in both print-friendly (PDF) and web-based (HTML) formats.

Advantages of HTML Documentation
® HTML is the primary delivery format for AgilePoint documentation.

¢ Unified, global search across all documentation. PDF documents allow you to search only within the context
of a given PDF file.

¢ All hyperlinks supported. Links in PDFs are only supported in certain contexts.
® "One-stop shopping" for all information related to AgilePoint BPMS.

® The HTML documentation is updated more frequently than the PDF documentation. Web-based
documentation is updated periodically between AgilePoint releases to address errors and omissions, but the
PDF documentation is updated only at the time of a software release.

Advantages of PDF Documentation

PDFs can be more easily printed, archived, and transferred (such as by FTP or email) than HTML
documentation.

For more information, see Downloading Files and Sharing Links from the Documentation Library in the
Documentation Library.

Opening the Documentation Library

To open the AgilePoint Documentation Library, do the following.

Prerequisites

You must have a valid account on the AgilePoint Support Portal.

Instructions

1. Log on to the AgilePoint Support Portal.

2. Click Documentation.

3. Onthe Documentation page, click the documentation library for your AgilePoint release.

® For AgilePoint BPMS v5.0 SP1 and higher, the web-based documentation library opens in a new tab or
window in your web browser.
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® Forreleases prior to v5.0 SP1, a download starts for a Zip file with the PDF documentation for your
release.

Finding Information in the Documentation Library

The information in this topic will help you to locate information in the AgilePoint Documentation Library.

Using the Table of Contents

The table of contents in the AgilePoint Documentation Library is divided by content areas. For example, the
Installation section includes all the information you need to install AgilePoint BPMS. The AgilePoint API section
includes information about the AgilePoint APIs.

You can use the Table of Contents to explore the AgilePoint documentation content and find the information you
want.

Searching

The web-based documentation includes a centralized search for all documentation content. To search for
information:

1. Inthe AgilePoint Documentation Library, click the Search tab. In the Search box, enter 1 search team, and
click Search.

The search results display in alphabetical order by topic title.

It is important to understand that the third-party software AgilePoint uses to generate web-based
documentation allows only 1 search term. More than 1 search term will cause the search to fail.

AgilePoint recommends using a relatively unique search term to find the information you need. For example,
entering a common term, such as "process," will return a high percentage of the total documentation topics
in the search results.

2. Browse the list of topic titles to find the information you want.

Printing

The PDF documentation is provided mainly for the purpose of printing and archiving. To print a set of
information:

1. Navigate to the main page of the Documentation Library from which you want to print.
2. Inthe list of documents, click the document name in the PDF column.

3. From your PDF reader software, print the portion of the document you want.

Downloading Files and Sharing Links from the
Documentation Library

You can download and share files AgilePoint's documentation library as you would in any other web page. Note
that if you send links to recipients, they must have a Support Portal login to view the file.

These procedures are common examples based on Internet Explorer with the Adobe Reader plug-in. Exact
procedures may vary depending on your web browser, PDF viewer, and email client configuration.
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Share a Link to an HTML Topic
1. Navigate to the topic you want to share.
2. Copy the URL in the Location box in your web browser.

3. Paste the URL in an email, IM client, etc.

Share a Link to a PDF Document

1. InInternet Explorer, navigate to the Documentation Library home page.

2. In the PDF column, right-click the name of the PDF file you want to share.
3. Inthe quick menu, click Copy shortcut.
4

Paste the URL in an email, IM client, etc.

Save a Copy of a PDF Document
1. InInternet Explorer, open the Documentation Library home page.
2. Inthe PDF column, click the name of the PDF file you want to share.

3. Inthe Adobe Reader plug-in, click Save button.

Contacting AgilePoint Sales

AgilePoint is a leading Business Process Management System (BPMS) provider created by a team of driven
people who strive to incorporate the principles of relentless innovation for the benefit of our customers. Our
mission is to help companies of any size attain and sustain operational success through process excellence.

Headquarters: AgilePoint Corporation 1916C Old Middlefield Way Mountain View, CA 94043, USA
Tel: (650) 968 - 6789
Fax: (650) 968 - 6785

Email: info@agilepoint.com

Web site: www.agilepoint.com

International: For AgilePoint EMEA and AgilePoint Asia Pacific, please call the AgilePoint Corporate Office for
contact information.

Contacting Customer Support

To contact AgilePoint Support, please submit a ticket on the AgilePoint Support Portal: http://
support.agilepoint.com/SupportPortal/

If you do not have a Support Portal account, you can send an email to request one: support@agilepoint.com
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InfoPath Integration

This document is a user's guide and reference to the features, functionality, usage, configuration, and
administration of the AgilePoint InfoPath Integration component of the AgilePoint BPMS Suite.

Usage Instructions

Once installed, the functionality of the AgilePoint InfoPath Integration component is entirely transparent to
the user. It simply allows other functionality of the AgilePoint SharePoint Integration component to integrate
seamlessly with the end user's browser.

Creating a Workflow-Enabled SharePoint Form Library

When creating an InfoPath form library in SharePoint by publishing the InfoPath form to SharePoint, it is
recommended that the form library has the same name as the process template name.

In addition to deploying the InfoPath form from within the InfoPath client, you can also deploy the process
template and InfoPath form together directly from AgilePoint Envision using the File > Update Server > Create
or Checkin, and Release Process menu command.

Creating Custom Buttons in InfoPath

AgilePoint provides a built-in Submit & Close button for InfoPath forms. However, you can also create your own
InfoPath buttons that submit the form as well as performing other functionality.

Creating a Custom Button Using a Data Connection

To create a custom button by setting up an AgilePoint data connection in InfoPath:

1. InInfoPath, open your Data Connections list, and click Add.

2. Onthe Data Connection Wizard, select Create a new connection to: Submit data, and click Next.

3. Under How do you want to submit your data? select To the hosting environment..., and click Next.

4. Inthe field Enter a name for this data connection, enter AgilePoint.
Note: The name must be AgilePoint exactly as it is written here. This hame enables the data
connection.

5. Click Finish.

Once this setup is complete, you can create custom behavior for this button as desired.

Creating a Custom Button Using Custom Code

In InfoPath, you can create a custom button using your own custom software code. To create a custom button
using code:
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Submit

To create a button that will submit an InfoPath form and close the form, include the following line in your code:
NotifyHost ("Submit&Close") ;

Cancel

To create a button that will close an InfoPath form without submitting the form, include the following line in your
code:

NotifyHost ("Close") ;

Auto Naming of InfoPath Form through Submit & Close

CD Note: This feature only works if you have chosen to use the InfoPath client to show your InfoPath forms
(i.e. not for browser based forms). If you are using Microsoft Office Forms Server and browser based
forms, AgilePoint will use InfoPath's default naming convention for naming the form.

The Submit & Close button allows users to complete the form operation and submit and close the form at the
same time. Users do not have to go back to the Web part to submit the form. The process will automatically
move to the next step in the process once the form is submitted and closed.

This feature supports the auto-naming of the InfoPath Form through the customized Submit & Close button.
Typically, users will be prompted for the form name when clicking the Save button after filling out the form.

This may pose a potential issue that a form may be overwritten by mistake. AgilePoint has provided a powerful
feature that can allow users to automatically save the form with a unique form name in a logical way. This not
only prevents the accidental overwriting of existing forms, but also allows for the creation of form names that are
logical and easier to manage.

AgilePoint provides an enhanced customized Submit & Close button embedded in the InfoPath toolbar. Users
can configure their InfoPath form/views to display the customized toolbar in AgilePoint Envision.

The process of determining the auto naming of your InfoPath form depends on whether you are using the
WebDAV or Soap Toolkit protocol method. WebDAYV is the default method that AgilePoint uses due to some
authentication limitations in Soap Toolkit. For more information, see the following Knowledge Base article:

For more information, see Customize the Document File Name when Submitting an InfoPath form to SharePoint
in the Documentation Library.

Auto-naming via the WebDAV Method (recommended)

To use the WebDAV method, simply customize the scripting as desired within the InfoPath's Jscript to perform
the auto naming of the InfoPath form.

Auto-naming via the AgilePoint Web Service Method

1. To use the AgilePoint Web Service method, since WebDAV is being used as the default, you must first
enable the use of the APWS Web Service method within the Jscript of the InfoPath form by removing the
comment tags. Also you will need to disable the WebDAV method by adding the comment tags where
appropriate.

2. In AgilePoint Envision, within an InfoPath based process template where the InfoPath form has already been
associated to the process template, click File > InfoPath > InfoPath Toolbar, Auto Naming and Others.
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3. Onthe InfoPath Settings dialog box on the Toolbar Buttons tab, select the views of the InfoPath Form that
you want to include in the customized toolbar.

4. During run time, to automatically save the form after filling out the form, instead of clicking the Save button to
save the form, click the Submit and Close button.

Configuring the Auto-naming Format

Using the AgilePoint Web Service auto-naming, the form name will be saved automatically to the format of
[DocLibName]-[yyyy]-[0000], where DocLibName is the name of the form library, yyyy is the year, and 0000 is a
unigue ID number that is generated by AgilePoint in a sequential order. For example: InfoPath-2005-0001. Once
the form is saved, a message box will be displayed with the form name.

This file name will be used to reference the form throughout the process.

You can easily override this auto-naming behavior by simply saving the file first, using the standard InfoPath

Save button (File > Save). The standard Save function behavior will still remain the same. Similarly, you can
continue to use the Save button throughout the process, or use both the Save button and the Submit & Close
button.

AgilePoint also allows you to configure the naming convention in AgilePoint Envision. To adjust the format, follow
these steps:

1. Open the process template with InfoPath using AgilePoint Envision.

Click File > InfoPath > InfoPath Toolbar.

Click the Naming Convention tab. The current format will be shown.

You can enter a new Prefix such as PR to replace the Document library name.

For Number Format, you can select number from 3 to 10.

o o M w D

You can click on the Ellipses button to preview the sample file name and determine if further changes are
needed.

Configuring the Auto-naming of InfoPath Form using Submit

When opening the InfoPath form from the Task List Web Part, the Submit and Close buttons are displayed on
the top toolbar in a browser window. If the InfoPath form is open within a form library, the Submit and Close
buttons are not displayed.

It is recommend to use the InfoPath default Submit button for submitting a new form.

The Submit and Close button is built on top of the default InfoPath Submit button. Hence, in your XSN, a Submit
Option must be configured and the Submit button must be visible on the InfoPath top toolbar.

For submitting a new form, auto naming support is not provided by AgilePoint, because the auto naming
capability provided by InfoPath is rich enough.

To configure the auto naming when creating a data connection for Submit Options, do the following.

Navigation

1. To open Microsoft InfoPath, click Start > All Programs > Microsoft Office > Microsoft Office InfoPath.

Instructions
1. In Microsoft Office InfoPath, click File > Design a Form Template.

2. Inthe Design a Form Template window, select the required InfoPath form template in design mode.

AgilePoint BPMS v5.0 R2 SP1 InfoPath Integration Guide r5.2.14



InfoPath Integration 10

In InfoPath form template, click Tools > Submit Options.
In Submit Options window, select Allow users to submit this form.

Select the Send form data to a single destination option.

o o M W

Select SharePoint document library from the drop-down list to select a destination for the InfoPath form
data.

~

To specify a data connection, click Add.
8. Inthe Data Connection Wizard window, in the Document library field, enter the URL of the form library.

If you only provide SharePoint site URL, InfoPath doesn't know where to submit the form. You must provide
the form library URL here.

9. In the File name field, click fx.
10. In the Insert Formula window, click Insert Function.
11. In the Categories pane, click Date and Time.
12. In the Functions pane, click now.
13. Click OK.
The function now() is inserted in the Formula box.
14. Click OK to save the specified settings.
15. In the Data Connection Wizard window, click Next.
16. In the Enter a name for this data connection field, enter a name for submit.
17. Click Finish to save the settings.

18. On the Submit Options window, in the Choose a data connection for submit list, select the data
connection that you have just created.

19. Click OK.
20. To display the Submit button on the InfoPath form in a web browser, click Tools > Form Options.
21. In the Category pane, click Browser, and ensure that the Submit check box is selected.

If the Browser category is not available, this indicates that your form is not browser compatible.

22. To make it browser compatible, click the Compatibility category and under Browser compatibility, select
the Design a form template that can be opened in a browser or InfoPath.

23. Click OK to save the setting.
24. To verifying the configuration settings, save the InfoPath form template.

25. Then, publish it to the form library in SharePoint. The URL of the form library must be the same URL you
entered when configuring the data connection for Submit as explained earlier.

The InfoPath form can be submitted successfully if the submit options are configured correctly. The simple
auto-naming is applied to the form name, once the form is submitted.

Best Practices for Using InfoPath Forms

This document explains the guidelines and best practices for using InfoPath forms with AgilePoint BPMS.

AgilePoint BPMS v5.0 R2 SP1 InfoPath Integration Guide r5.2.14
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Prerequisites

® AgilePoint BPMS v4.0 or later
® Microsoft Office InfoPath

® Microsoft Office Forms Server

® Microsoft Office SharePoint Server

Displaying InfoPath Forms to User

The designing and deployment of your InfoPath forms depends on how you want to display the InfoPath form to
your end users.

Before you create an InfoPath form template, you must decide how you want to display the InfoPath form to your
end users. The following are two options for InfoPath forms to display:

e InfoPath form in a Web browser (using Microsoft Office Forms Server)
e InfoPath form in InfoPath client (using the InfoPath client software)
Microsoft Office InfoPath

Microsoft Office InfoPath, which is part of the Microsoft Office system, allows business to both design and
complete electronic forms. InfoPath is based on XML.

Microsoft Office InfoPath allows the business analyst or IT to develop attractive forms for BPM solutions in a
fraction of the time required to create traditional coded forms. Conditional rules and data validation can be added
to the forms without writing code.

Standard InfoPath forms are executed on the desktop. As a result, it is recommended that InfoPath be used with
AgilePoint BPMS solutions under the following conditions:

e InfoPath is licensed and installed on all of the desktops that will participate in the BPM project or need to
view the form.

e There is sufficient network bandwidth to download the InfoPath form template from the SharePoint document
library each time the form is displayed.

e The form rules and data validation can be created without writing code.

e Secondary data sources are not required. Direct connections to data sources from the InfoPath form on the
client desktop add complexity, performance delays and additional security configuration.

e The data being collected in the form does not require encryption. Encrypted XML cannot be evaluated in the
process instance at runtime.

e Active forms in the Microsoft SharePoint document library can be limited to 2000 items at a time.
Microsoft Office Forms Server

Microsoft Office Forms Server is a server product built on Microsoft Windows SharePoint Services as an
ASP.NET Version application. It enables users to fill out Microsoft Office InfoPath forms by using a Web browser
instead of, or in addition to, the Office InfoPath client program. Like standard InfoPath forms, InfoPath forms
published to the Microsoft Office Forms Server are based on Extensible Markup Language (XML).

Microsoft Office Forms Server allows the business analyst and/or IT to develop attractive forms for BPM
solutions in a fraction of the time required to create traditional coded forms. The primary advantage it offers over
the full InfoPath client software is that Microsoft Office Forms Server renders the form in a browser window and
does not require that the Microsoft Office InfoPath to be installed on the desktop. The second advantage is that
it executes the form on the server and downloads a smaller HTML based form similar to an ASP.NET form. As a
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result of not having the Microsoft Office InfoPath client, it is recommended that Microsoft Office Forms Server be
used with AgilePoint BPMS solutions under the following conditions:

e Microsoft Office Forms Server licensing has been obtained or budgeted for the Microsoft SharePoint front
end web servers.

e The form design is basic and can be created with a limited set of data controls.
e The form does not require Jscript for conditional presentation or data validation.

e The development team can support the use of managed code to create and maintain custom form
functionality.

e JavaScript and cookies can be enabled on the client browser.

e Active forms in the Microsoft SharePoint document library can be limited to 2000 items at a time.Topic
paragraph.

Displaying InfoPath Form in Web browser

This section provides information about designing and deployment of InfoPath forms to render it in a web
browser.

By default, Microsoft Forms Server doesn't support InfoPath form templates that include JScript. Forms that
include JScript cannot be rendered in a web browser.

If you want to display your InfoPath form using Forms Server in a web browser, you have two options available
when developing your InfoPath form:

e Using InfoPath Client Software (Clean - no Managed code and no JScript)

This option is best if the basic InfoPath form development functionality included within the browser-based
InfoPath form can meet your requirements. This is a good approach for fast and easy development and
deployment. This approach also maintains the business user friendly InfoPath development and deployment
strategy.

If you associate an InfoPath form that does not have a managed code DLL to a process model in AgilePoint
Envision, AgilePoint Envision will add JScript to the InfoPath form, making it unable to be rendered in a
Web browser. Therefore, it is not supported at this time to publish this type of InfoPath form to SharePoint
via AgilePoint Envision. It is necessary to publish the InfoPath form through the InfoPath client and make
sure you remove the JScript before publishing. For more information, see Deploying the InfoPath Form to
SharePoint section below.

e Using Managed Code in the XSN using Microsoft Visual Studio If you want to incorporate some custom
or advanced logic in your InfoPath form, then it is recommended to use the managed code approach to
implement your logic. Design your form template in Visual Studio.NET using Microsoft Visual Studio Tools
for the Microsoft Office System.

It is recommended that you design your form template in Visual Studio using Microsoft Visual StudioTools for the
Microsoft Office System, even if you don't plan to use managed code at the beginning.

More Information

® To download Microsoft Visual Studio Tools for the Microsoft Office System - http://www.microsoft.com/
downloads/details.aspx?familyid=5e86cab3-6fd6-4955-b979-e1676db6b3cb&displaylang=en

® Useful information about Microsoft Visual Studio Tools for the Microsoft Office System - http://
msdn2.microsoft.com/en-us/office/aa905543.aspx

Setting Up InfoPath Forms to Display in Web Browser

To configure the deployment settings to render the InfoPath in a Web Browser, do the following.
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InfoPath Integration

Prerequisites

Microsoft Visual Studio Tools for the Microsoft Office System.

Navigation

1.

To open Microsoft InfoPath, click Start > All Programs > Microsoft Office > Microsoft Office InfoPath.

Instructions

1.

2
3
4,
5

In Microsoft Office InfoPath, click File > Design a Form Template.

In the Design a Form Template window, select the required InfoPath form template in design mode.
In InfoPath form template, click Tools > Form Options.

In the Category pane, click Compatibility.

In the Browser compatibility section, select the Design a form template that can be opened in a
browser or InfoPath.

To verify whether your form is browser compatible, click Tools > Design Checker.
Ensure that all InfoPath views are browser compatible.

If the form is not compatible with a browser, the Designer Checker displays the errors and messages about
it. For example, an InfoPath form containing Combo box displays errors as a Combo box is not supported on
a web browser.

When publishing the InfoPath form, ensure that the Enable this form to be filled out by using a browser
is selected.

At the Advanced Settings of your form library, under the Opening browser-enabled Documents section,
select Display as a Web page.

Best Practices for Using InfoPath Forms in SharePoint

To use the InfoPath forms with SharePoint in a web browser, refer to the following table.

InfoPath Form Template (XSN) Details

Clean Displays form in a Web browser. Deployment of XSN

(XSN is designed in the InfoPath client - no managed
code DLL in XSN, no JScript in XSN, and no
involvement of Visual Studio 2005) If you accidentally associate your XSN to a process

from within Envision to SharePoint is not supported,
must use InfoPath client software to publish.

template and AgilePoint Envision has added JScript
into your XSN, which makes your XSN unable to be
rendered in a Web browser, you can use the Remove
Code feature in InfoPath client to remove the JScript
using (Tools > Form Options > Programming >
Programming Language > Remove Code).

JScript in XSN Microsoft does not support displaying the XSN in a

Web browser.

Managed code DLL in XSN Deployment of XSN from within Envision to

SharePoint is supported. The XSN is first added to the
SharePoint Central Admin, then it is activated to the
SharePoint site as a content type, and finally a form lib

AgilePoint BPMS v5.0 R2 SP1 InfoPath Integration Guide r5.2.14
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InfoPath Form Template (XSN) Details

is created based on the content type. Envision will not
add JScript to the XSN if the XSN contains a DLL, so
that it can be displayed in a web browser.

Administrative Operations

Best Practices for Deploying InfoPath 2007 Forms

With the availability of InfoPath 2007 and Microsoft Office InfoPath 2007 Forms Server, you now have the ability
to choose whether you would like to display the InfoPath forms to your end-user in the InfoPath Client or via

a Web browser. The advantage of showing the InfoPath form via a Web browser is that it does not require
InfoPath to be installed on the users’ machine to view and work with the InfoPath form.

For more information, see http://kb.agilepoint.com/KB/KnowledgebaseArticle10346.aspx .

Enable (or disable) Client-Side Logging

AgilePoint InfoPath integration supports error logging capabilities. Once enabled, this feature writes information
to a file that can be useful when troubleshooting errors relating to the AgilePoint InfoPath Integration component.

Enabling Client-Side Logging
To enable client-side logging for the AgilePoint InfoPath Integration component, please do the following
1. Create afile named "log.txt" in the [AgilePoint Integration for InfoPath installation folder]\log.txt.

2. Repeat the steps necessary to reproduce the error originally observed.

Disabling Client-Side Logging
To disable client-side logging for the AgilePoint InfoPath Integration component, please do the following

Delete the file [AgilePoint Integration for InfoPath installation folder]\log.txt.

Best Practices for Using InfoPath Forms

This document explains the guidelines and best practices for using InfoPath forms with AgilePoint BPMS.

Prerequisites

® AgilePoint BPMS v4.0 or later
® Microsoft Office InfoPath

® Microsoft Office Forms Server

® Microsoft Office SharePoint Server
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Displaying InfoPath Forms to User

The designing and deployment of your InfoPath forms depends on how you want to display the InfoPath form to
your end users.

Before you create an InfoPath form template, you must decide how you want to display the InfoPath form to your
end users. The following are two options for InfoPath forms to display:

e InfoPath form in a Web browser (using Microsoft Office Forms Server)

e InfoPath form in InfoPath client (using the InfoPath client software)

Microsoft Office InfoPath

Microsoft Office InfoPath, which is part of the Microsoft Office system, allows business to both design and
complete electronic forms. InfoPath is based on XML.

Microsoft Office InfoPath allows the business analyst or IT to develop attractive forms for BPM solutions in a
fraction of the time required to create traditional coded forms. Conditional rules and data validation can be added
to the forms without writing code.

Standard InfoPath forms are executed on the desktop. As a result, it is recommended that InfoPath be used with
AgilePoint BPMS solutions under the following conditions:

e InfoPath is licensed and installed on all of the desktops that will participate in the BPM project or need to
view the form.

e There is sufficient network bandwidth to download the InfoPath form template from the SharePoint document
library each time the form is displayed.

e The form rules and data validation can be created without writing code.

e Secondary data sources are not required. Direct connections to data sources from the InfoPath form on the
client desktop add complexity, performance delays and additional security configuration.

e The data being collected in the form does not require encryption. Encrypted XML cannot be evaluated in the
process instance at runtime.

e Active forms in the Microsoft SharePoint document library can be limited to 2000 items at a time.

Microsoft Office Forms Server

Microsoft Office Forms Server is a server product built on Microsoft Windows SharePoint Services as an
ASP.NET Version application. It enables users to fill out Microsoft Office InfoPath forms by using a Web browser
instead of, or in addition to, the Office InfoPath client program. Like standard InfoPath forms, InfoPath forms
published to the Microsoft Office Forms Server are based on Extensible Markup Language (XML).

Microsoft Office Forms Server allows the business analyst and/or IT to develop attractive forms for BPM
solutions in a fraction of the time required to create traditional coded forms. The primary advantage it offers over
the full InfoPath client software is that Microsoft Office Forms Server renders the form in a browser window and
does not require that the Microsoft Office InfoPath to be installed on the desktop. The second advantage is that
it executes the form on the server and downloads a smaller HTML based form similar to an ASP.NET form. As a
result of not having the Microsoft Office InfoPath client, it is recommended that Microsoft Office Forms Server be
used with AgilePoint BPMS solutions under the following conditions:

e Microsoft Office Forms Server licensing has been obtained or budgeted for the Microsoft SharePoint front
end web servers.
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e The form design is basic and can be created with a limited set of data controls.
e The form does not require Jscript for conditional presentation or data validation.

e The development team can support the use of managed code to create and maintain custom form
functionality.

e JavaScript and cookies can be enabled on the client browser.

e Active forms in the Microsoft SharePoint document library can be limited to 2000 items at a time.Topic
paragraph.

Displaying InfoPath Form in Web browser

This section provides information about designing and deployment of InfoPath forms to render it in a web
browser.

By default, Microsoft Forms Server doesn't support InfoPath form templates that include JScript. Forms that
include JScript cannot be rendered in a web browser.

If you want to display your InfoPath form using Forms Server in a web browser, you have two options available
when developing your InfoPath form:

e Using InfoPath Client Software (Clean - no Managed code and no JScript)

This option is best if the basic InfoPath form development functionality included within the browser-based
InfoPath form can meet your requirements. This is a good approach for fast and easy development and
deployment. This approach also maintains the business user friendly InfoPath development and deployment
strategy.

If you associate an InfoPath form that does not have a managed code DLL to a process model in AgilePoint
Envision, AgilePoint Envision will add JScript to the InfoPath form, making it unable to be rendered in a
Web browser. Therefore, it is not supported at this time to publish this type of InfoPath form to SharePoint
via AgilePoint Envision. It is necessary to publish the InfoPath form through the InfoPath client and make
sure you remove the JScript before publishing. For more information, see Deploying the InfoPath Form to
SharePoint section below.

e Using Managed Code in the XSN using Microsoft Visual Studio If you want to incorporate some custom
or advanced logic in your InfoPath form, then it is recommended to use the managed code approach to
implement your logic. Design your form template in Visual Studio.NET using Microsoft Visual Studio Tools
for the Microsoft Office System.

It is recommended that you design your form template in Visual Studio using Microsoft Visual StudioTools for the
Microsoft Office System, even if you don't plan to use managed code at the beginning.

More Information

® To download Microsoft Visual Studio Tools for the Microsoft Office System - http://www.microsoft.com/
downloads/details.aspx?familyid=5e86cab3-6fd6-4955-b979-e1676db6b3cbh&displaylang=en

® Useful information about Microsoft Visual Studio Tools for the Microsoft Office System - http://
msdn2.microsoft.com/en-us/office/aa905543.aspx

Setting Up InfoPath Forms to Display in Web Browser

To configure the deployment settings to render the InfoPath in a Web Browser, do the following.

AgilePoint BPMS v5.0 R2 SP1 InfoPath Integration Guide r5.2.14


http://www.microsoft.com/downloads/details.aspx?familyid=5e86cab3-6fd6-4955-b979-e1676db6b3cb&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=5e86cab3-6fd6-4955-b979-e1676db6b3cb&displaylang=en
http://msdn2.microsoft.com/en-us/office/aa905543.aspx
http://msdn2.microsoft.com/en-us/office/aa905543.aspx

InfoPath Integration 17

Prerequisites

® Microsoft Visual Studio Tools for the Microsoft Office System.

Navigation

1. To open Microsoft InfoPath, click Start > All Programs > Microsoft Office > Microsoft Office InfoPath.

Instructions

1. In Microsoft Office InfoPath, click File > Design a Form Template.

2. Inthe Design a Form Template window, select the required InfoPath form template in design mode.
3. InInfoPath form template, click Tools > Form Options.

In the Category pane, click Compatibility.

U

In the Browser compatibility section, select the Design a form template that can be opened in a
browser or InfoPath.

6. To verify whether your form is browser compatible, click Tools > Design Checker.
Ensure that all InfoPath views are browser compatible.

If the form is not compatible with a browser, the Designer Checker displays the errors and messages about
it. For example, an InfoPath form containing Combo box displays errors as a Combo box is not supported on
a web browser.

7. When publishing the InfoPath form, ensure that the Enable this form to be filled out by using a browser
is selected.

8. Atthe Advanced Settings of your form library, under the Opening browser-enabled Documents section,
select Display as a Web page.

Best Practices for Using InfoPath Forms in SharePoint

To use the InfoPath forms with SharePoint in a web browser, refer to the following table.

InfoPath Form Template (XSN) Details

Clean Displays form in a Web browser. Deployment of XSN
from within Envision to SharePoint is not supported,

(XSN is designed in the InfoPath client - no managed must use InfoPath client software to publish,

code DLL in XSN, no JScript in XSN, and no
involvement of Visual Studio 2005) If you accidentally associate your XSN to a process
template and AgilePoint Envision has added JScript
into your XSN, which makes your XSN unable to be
rendered in a Web browser, you can use the Remove
Code feature in InfoPath client to remove the JScript
using (Tools > Form Options > Programming >
Programming Language > Remove Code).

JScript in XSN Microsoft does not support displaying the XSN in a
Web browser.

Managed code DLL in XSN Deployment of XSN from within Envision to
SharePoint is supported. The XSN is first added to the
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InfoPath Form Template (XSN) Details
SharePoint Central Admin, then it is activated to the
SharePoint site as a content type, and finally a form lib
is created based on the content type. Envision will not
add JScript to the XSN if the XSN contains a DLL, so
that it can be displayed in a web browser.
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