Why do I get a database permissions error when accessing AgileReports in the Enterprise Manager?

Symptoms

When attempting to access AgileReports from Enterprise Manager, the following error occurs: "Sorry, your assigned roles don't have permission to use any of the databases."

Cause

AgilePoint Server was not restarted after the adHocAdmin group was created in Active Directory.

Resolution

To test whether the adHocAdmin group has been created and AgilePoint Server has been restarted, do the following on the machine where AgileReports is installed:

  1. Add the attached NTLoginTest.aspx page to [AgileReports installation folder].
  2. Browse to [AgileReports installation folder]\_Definitions\_Settings.lgx file.
  3. Add LogonFailPage="NTLoginTest.aspx" as below.

    Sample “ _Settings.lgx” file:

    <Security SecurityEnabled="True" 
        AuthenticationSource="AuthNT" AnonymousUserID="1" 
        LogonFailPage="NTLoginTest.aspx" 
        NTAuthenticationDomain="xxxx" CacheRights="Session" 
        LogonPage="http://localhost:9000/EnterpriseManager/Common/LogonForm.aspx" 
        SchedulerUsername="Admin">
  4. Restart the machine.

Downloads

NTLoginTest.zip.

Cause

No AgileReports role is configured for the Active directory Group.

Resolution

If there is group in Active Directory that has the users that can access AgileReports, create a corresponding role in AgileReports that uses the same group name — for example, AgileReportUsers. The role name is case-sensitive.