Why Does an Error Occur when I Open Enterprise Manager in a Windows Service Environment?

Symptoms

  1. Upgrade to AgilePoint 5.0 SP2 or higher.
  2. Configure Windows authentication.
  3. Open Enterprise Manager.
  4. The following error occurs.
"Exception Details: System.Web.Services.Protocols.SoapException: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Exception: 1DCED31183B04261896B23C4452276F1_AGILEPOINTUser '[domain]\[username]' is not recognized as the impersonator for 'AgilePoint EnterpriseManager' on machine='[machine name]'. This may occur because a) the AgileConnector is not configured properly, or b) the server license does not support 'AgilePoint EnterpriseManager'. Please contact system administrator."

Cause

The AgilePoint EnterpriseManager extension is not configured in the AgilePoint Server configuration. This extension is required in AgilePoint 5.0 SP2 and higher when Enterprise Manager uses Windows authentication.

Resolution

  1. Open the AgilePoint Server configuration and navigate to Extensions tab.
  2. Click Add.
  3. Enter the following information:
    Field Value

    Name

    AgilePoint EnterpriseManager

    Note that spaces and capitalization must be exactly how they appear here.

    Impersonator

    The application pool identity user for Enterprise Manager. Usually this user name is included in the error message.

    Example: demo3\administrator