Why Does an Envision Registry Key Error Occur When I Configure the Web Service AgileShape?

Symptoms

In AgilePoint Envision, when I attempt to configure the Web Service AgileShape, the following error appears:

Access to the registry key 'HKEY_LOCAL_MACHINE\SOFTWARE\Ascentn\Envision' is denied."

Cause

This error indicates the user does not have sufficient privileges to access the Envision node in the registry. This problem occurs because the user account that you used to log on (to Envision) is not an administrator.

Resolution

To resolve the issue, do one of the following:
  • Use the Run as administrator option to open Envision:
    1. Click Start > All Programs > AgilePoint.
    2. Right-click AgilePoint Envision, and then select the Run as administrator option.
  • Provide Full Control permission on the HKEY_LOCAL_MACHINE\SOFTWARE\Ascentn\Envision registry key to the logged on user account:
    1. Click Start > Run.
    2. In the Open field, type regedit.
    3. Click OK.
    4. In the Registry, create the following node:
      HKEY_LOCAL_MACHINE\SOFTWARE\Ascentn\Envision
    5. Right-click the following node to set the Permissions to Full Control:
      HKEY_LOCAL_MACHINE\SOFTWARE\Ascentn\Envision