InfoPath Form's Submit and Close button displays an error

Applies To

Symptoms

When clicking the "Submit and Close" button in an InfoPath form, the following error occurs:

Failed to submit InfoPath form, detail:
Attachment:Maximum retry on the connection exceeded. HRESULT=0x80004005: Unspecified error
- Client:An unanticipated error on the connection exceeded. HRESULT=0x80004005: 
    Unspecified error
- Client:Sending the Soap message failed or no recognizable 
    response was received HRESULT=0x80004005: Unspecified error
- Client:Unspecified client error. HRESULT=0x80004005: Unspecified error

Cause

This may be caused because the client system running InfoPath is not able to successfully call web services on the AgilePoint Server and/or the SharePoint server the form is associated with.

Resolution

Here are some suggestions that may help resolve the above error: