The Process Viewer is Not Correctly Mapping Workflow Activities with the Associated Status Indicators

Applies To

Symptoms

There is an issue with the Process Viewer not correctly mapping workflow activities with the associated status indicators.

Cause

  1. In Envision, check to see if any portion of the process model (shapes, lines, text, graphics, etc.) extends beyond the "page" borders?
  2. Check to see if the process model contains any specific "non-AgilePoint" or custom Visio shapes (such as text bubble graphics)?

Resolution

Ensure that no portions of the process model extend beyond the page borders by moving all portions of the model into the page area. You can use the "Shape > Actions > Page Size" menu command to increase the page size. If the page size/boundaries aren't an issue, then try removing any text bubbles or any other similar shapes/graphics, and see if that resolves the issue. The Process Viewer's graphics rely on the coordinates within the VSD file, and it is possible that some custom shapes or graphics could modify or corrupt the coordinates in the VSD file.

Also, if the process modeler did anything else to the model that might potentially affect shape coordinates (e.g. rotating or flipping shapes, or resizing shapes) and that hasn't been done in other models not affected by this issue, then you might need to try removing and then replacing any shapes that were modified in such a way to see if such actions are the cause.