Reassigned Task Does Not Route to the New Participant Set By the Custom Attribute

Applies To

Symptoms

A manual activity has a dynamic participant (set by custom attribute). In the desired process scenario, after the manual task is completed, the process will check again to see if the same task need to be performed again by another person and the custom attribute value of the participant will be set accordingly. The process will then be routed back to the manual activity again with the new participant. However, in the process that client implemented, the task is still assigned to the previous participant when the task is routed back with a new participant value. It seems like the new custom attribute value does not take into account at all.

Cause

This is caused by the incorrect setting in the 'Reuse participant' property for the manual activity.

Resolution

It is because the manual activity's “Reuse Participant” property set to 'True'. In this case, when the process is routed back to this manual activity, the task will always be assigned to the previous participant regardless of what the new value of the Participant property is. In order to achieve the above process scenario, the 'Reuse Participant' property must be set to 'False'.