Can't Log On to AgilePoint Enterprise Manager After Installation

Applies To

Symptoms

After installation, you can't login to AgilePoint Enterprise Manager and/or the AgilePoint Tusca sample application.

When attempting to login, you may see one of the following error messages:

Cause

There are several possible causes for this problem, including:

See below for suggestions on how to diagnose and fix the problem.

Resolution

Use the information below to help verify that your AgilePoint products were installed correctly:

The following is a check list that can help you troubleshoot the problem.

If the problem still persists, you can try the following depending on what your system OS is:

Windows 2003 : Add an application pool such as "AgilePoint" and uses local Administrator as the identity. Then assign this application pool to both AgilePoint Server and Enterprise Manager websites and virtual directories in IIS. Reset IIS after the changes. If you are using a domain user as the identity, make sure this domain user is added to the local Administrators and IIS_WPG groups. The domain user must also be added to the database as db_owner if the windows authentication is used.

Windows 2000/XP : Locate the machine.config under the .NET framework such as:

c:\windows\microsoft.NET\Framework\v.1.1.4322\CONFIG\machine.config.

Make a copy before your modification. Look for the line with username="system" password="AutoGenerate", modify to username="administrator" password="your_administrator_password" where your_administrator_password is the actual password for your local Administrator account. Reset IIS after the changes.

Note : You should always consult your company's IT department for system security setting to make sure it follows your company's security policy. Please contact Ascentn support for additional information about AgilePoint security setting. For general information about Microsoft .NET and system security, please refer to Microsoft documentation.